Author Topic: Linux MCE kills my adsl connection  (Read 2988 times)

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Linux MCE kills my adsl connection
« on: October 09, 2007, 07:59:24 pm »
Hi,

I just installed Linux MCE 0704. As I started installing I noticed repeated disconnectes of my adsl connection. When the system was fully installed and booted, my Linksys Router was unable to establish an adsl connection. As soon as I plugged the network cable out of the Linux MCE machine, the problems were all gone.

The Linux MCE System is in the same ethernet segment as the dsl modem and the wan port of the Linksys router. Does Linux MCE somehow try to talk to the dsl modem?

Regards,

Raoul

MarcoZan

  • Veteran
  • ***
  • Posts: 148
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #1 on: October 09, 2007, 09:59:26 pm »
Hi Raoul

just an idea on what your issue may be.
LMCE has a  flickr based screen saver, that downloads new images from flickr site. Maybe this is somehow disturbing your router and causing disconnections. I know that some router are sensitive to continous download (my router for example does not like aMule ...).

If this is the case, you may solve your problem upgrading your router firmware or disabling pictures download. you can achieve this last option by renaming flickr.pl in /usr/pluto/bin

There are other posts in this forum talking about customizing flickr images that you may want to read.

HTH
Marco

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #2 on: October 10, 2007, 09:39:16 am »
I don't think that it's a problem with flicker. I can download gigabytes, having bittorrent running, etc. This never caused any disconnect. LinuxMCE is not just causing diconnects, it completely prevents my dsl router from establishing any connection. When I tell the Linksys router to bring up the connection, it takes some minutes, then it tells me that it could not get an ip address from the pppoe peer. I think that the LinuxMCE tries to use the dsl modem for whatever and interferes with the communication between the router and the modem. I'll do some changes in my network and connect the dsl modem directly to the routers wan port, so that the LinuxMCE has no access to it. I think this will solve to problem, but I'm still curious what the LinuxMCE tries to do.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4526
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Linux MCE kills my adsl connection
« Reply #3 on: October 10, 2007, 11:03:33 am »
I don't think that it's a problem with flicker. I can download gigabytes, having bittorrent running, etc. This never caused any disconnect. LinuxMCE is not just causing diconnects, it completely prevents my dsl router from establishing any connection. When I tell the Linksys router to bring up the connection, it takes some minutes, then it tells me that it could not get an ip address from the pppoe peer. I think that the LinuxMCE tries to use the dsl modem for whatever and interferes with the communication between the router and the modem. I'll do some changes in my network and connect the dsl modem directly to the routers wan port, so that the LinuxMCE has no access to it. I think this will solve to problem, but I'm still curious what the LinuxMCE tries to do.

It sounds to me like it might be that your Core's somehow offering DHCP addresses to the WAN side your Linksys... and if your Linksys is set up to get its WAN side connection from your ADSL providers DHCP server then that would certainly cause a problem like you have described.

Can you explain in detail how your Core/Linksys/network are laid out? what connected to what etc etc would help figure this out I think.

Regards

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #4 on: October 10, 2007, 11:53:44 am »
Can you explain in detail how your Core/Linksys/network are laid out? what connected to what etc etc would help figure this out I think.

I already mentioned that in the first posting. I do have a Linksys WRTG54G, the WAN Port of that router is connected to the rest of my network. The DSL modem is not directly connected to the Linksys WAN Port, ist just connected to my switched network and gets to the WAN port via some switches. So it is definitely possible for the LinuxMCE to have ethernet access to the DSL modem and the WAN port of the Linksys router. I never had any problems with that configuration before, there is a DHCP server running on the Linksys router, it never interfered anyhow. I don't want to LinuxMCE to act as a DHCP server in the network. I thought LinuxMCE might be so clever not to turn on any dhcp server as it got its own ip from another dhcp server at startup.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #5 on: October 10, 2007, 01:35:46 pm »
How many network cards do you have in your core?
"Change is inevitable. Progress is optional."
-- Anonymous


totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4526
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Linux MCE kills my adsl connection
« Reply #6 on: October 10, 2007, 02:07:52 pm »
Can you explain in detail how your Core/Linksys/network are laid out? what connected to what etc etc would help figure this out I think.

I already mentioned that in the first posting. I do have a Linksys WRTG54G, the WAN Port of that router is connected to the rest of my network. The DSL modem is not directly connected to the Linksys WAN Port, ist just connected to my switched network and gets to the WAN port via some switches. So it is definitely possible for the LinuxMCE to have ethernet access to the DSL modem and the WAN port of the Linksys router. I never had any problems with that configuration before, there is a DHCP server running on the Linksys router, it never interfered anyhow. I don't want to LinuxMCE to act as a DHCP server in the network. I thought LinuxMCE might be so clever not to turn on any dhcp server as it got its own ip from another dhcp server at startup.

Well thats would seem to be the heart of your problem. LMCE is fighting the DHCP in your Linksys. Turn the Linksys's DHCP off and you should find that your setup works fine.

By the way I have the same Linksys as you in my Home LMCE system. My Linksys's WAN port is connected to my Cable Modems LAN port and gets its WAN side setup using the my providers DHCP. My Linksys has its DHCP set to off and I use a single NIC in my Core. The Linksys has a fixed LAN side address IP of 192.168.20.1 and my Core has a fixed LAN side address in the same IP circle at 192.168.20.99 and my core has the Linksys set as its gateway/DNS (ie 192.168.20.1). My core then issues LAN side addresses in the 192.168.80.1 range from the same NIC. All devices on my LAN therfore get 192.168.80.1 addresses if they are themselves set to DHCP.

Hope the above helps you.

All the best.

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #7 on: October 10, 2007, 02:41:36 pm »
I don't want to turn the DHCP in the Linksys off, because the LinuxMCE will just be a media player thats on for some hours every day, but I need the DHCP server to be on day and night. So, how do I turn off the DHCP server of the LinuxMCE? I can't remebert that the setup asked me about that, it's not very nice to enable a DHCP server without asking...

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4526
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Linux MCE kills my adsl connection
« Reply #8 on: October 10, 2007, 04:00:36 pm »
I don't want to turn the DHCP in the Linksys off, because the LinuxMCE will just be a media player thats on for some hours every day, but I need the DHCP server to be on day and night. So, how do I turn off the DHCP server of the LinuxMCE? I can't remebert that the setup asked me about that, it's not very nice to enable a DHCP server without asking...

You can turn the Core's DHCP of in Web Admin... but you will loose the PnP Engine if you do;

Open a Web browser at the Core/Hybrid and go to 192.168.80.1 in the Address Bar

Login to Web Admin using whatever login you created at setup (ie the first user you created) and then go to ;

Advanced -> Networks -> Network Settings and un-tick 'Enable DHCP Server' then click 'Update' at the bottom of the screen and you done.
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #9 on: October 14, 2007, 12:02:07 am »
I just logged onto the machine and turned the dhcpd off, then plugged the network cable back in, and after a few seconds all the other machines in the network lost the internet connection again. I unplugged the network cable quickly, then everything went back to normal. So it's not the dhcpd that causes the problems.

teedge77

  • Addicted
  • *
  • Posts: 591
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #10 on: October 14, 2007, 12:17:49 am »
can you give us a diagram...being very specific....what are the ports labeled that you are plugging things into....what ports go to what..how many switches...the more specific the better.
AMD Athlon 64 X2 6000+
Asus M2V Via AM2 ATX
Lite-On LH-20A1S SATA DVD Burner
80GB  SATA-150
EVGA GeForce 7300 GT 512MB DDR2 PCI Express
Sound Blaster Audigy SE
Kingston 2 GB PC6400 DDR2 800MHz
Ultra X-Finity 800-Watt
ZCU000
Cisco 7970
TDM400P

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #11 on: October 14, 2007, 12:37:50 am »

Just a quick drawing, but it should contain any relevant information. Nothing that I did not mention earlier in this thread:

http://www.funlynx.de/~borkert/setup.png


teedge77

  • Addicted
  • *
  • Posts: 591
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #12 on: October 14, 2007, 01:04:42 am »
what is the ip linuxmce is using and what is the address of your gateway?
AMD Athlon 64 X2 6000+
Asus M2V Via AM2 ATX
Lite-On LH-20A1S SATA DVD Burner
80GB  SATA-150
EVGA GeForce 7300 GT 512MB DDR2 PCI Express
Sound Blaster Audigy SE
Kingston 2 GB PC6400 DDR2 800MHz
Ultra X-Finity 800-Watt
ZCU000
Cisco 7970
TDM400P

RaoulDuke

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #13 on: October 14, 2007, 01:27:37 am »
The Gateway is 192.168.0.1

The LinuxMCE box gets the 192.168.0.109 from the DHCP server of the Linksys router.

teedge77

  • Addicted
  • *
  • Posts: 591
    • View Profile
Re: Linux MCE kills my adsl connection
« Reply #14 on: October 14, 2007, 01:39:44 am »
have you tried plugging the dsl modem directly to the wan port of the wireless router?
AMD Athlon 64 X2 6000+
Asus M2V Via AM2 ATX
Lite-On LH-20A1S SATA DVD Burner
80GB  SATA-150
EVGA GeForce 7300 GT 512MB DDR2 PCI Express
Sound Blaster Audigy SE
Kingston 2 GB PC6400 DDR2 800MHz
Ultra X-Finity 800-Watt
ZCU000
Cisco 7970
TDM400P