Author Topic: Media Director PC - boot from disk : Issue with Regeneration of Skin  (Read 1969 times)

rbarara

  • Newbie
  • *
  • Posts: 10
    • View Profile
Hi

I installed Media Director on a PC and when I click on "Start Media Station", it connects with the DCE router (core) and then fails to regenerate skin.

In connection tab on Linux MCE launch manager, I see that there is a MySQL data required - host, user and password - I have tried various combinations like localhost / IP address of the core (192.168.80.1) and user id of root with root;s password and MCE users with their passwords. Nothing works..

Any pointers / suggestions to resolve this will be highly appreciated.

regards

Rajan

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #1 on: October 05, 2007, 05:15:34 am »
By default your linuxMCE database should be running on your CORE machine.
Default address is "dcerouter" or "192.168.80.1" - assuming that you didn't change it on setup.

The database default user is "root" with an empty password.

If those settings don't work then you are looking at may other connectivity problems.

HTH
Darren

rbarara

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #2 on: October 05, 2007, 05:32:38 am »
Thanks for the reply. The database component is resolved now.

Next problem that I run into is "Failed to regenerate skin for Orbiter!!"

Help pls !

foneguy9

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #3 on: October 05, 2007, 07:26:58 am »
Hi rbarara,

It's great that you have the database component solved.  Since you described the problem pretty clearly, would you be able to present how you resolved the issue, for those of us who may or may not come across a similar issue?

 :)  Thanks....


Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #4 on: October 05, 2007, 09:10:52 am »
It would help if you posted the specs of the machine you are trying to run this on.
Video card, processor speed +++
Both for the core and the MD

rbarara

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #5 on: October 05, 2007, 04:18:10 pm »
To solve the databse issue - I had to download QMYSQL3 package and I discovered that (on my installation) a lot of files were missing from /usr/lib and /usr/pluto/lib and /usr/pluto/bin.

The issue of regeneration of skin was resolved by editing pluto.conf (in /etc) and adding the following line:

PK_DEVICE <device number of media director>

You can get the device number of media director from LinuxMCE's admin website.

So far - I have managed to copy the missing files from core and am stuck in a stage where registration of Orbiter with the core is timing out.

I will look into /usr/pluto/bin/LaunchOrbiter.sh to investigate this issue.

Help !

regards

Rajan

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #6 on: October 05, 2007, 07:11:58 pm »
sounds like you just need to side-step all of this and do a full re-install.

-Thom

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #7 on: October 05, 2007, 08:00:00 pm »
sounds like you just need to side-step all of this and do a full re-install.

-Thom

I was thinking the exact same thing.  That is waaay to much trouble for a simple install, and here shouldn't be any files missing at all in my experience.
"Change is inevitable. Progress is optional."
-- Anonymous


rbarara

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #8 on: October 08, 2007, 05:28:31 pm »
I reinstalled the system from a scratch - Kubuntu followed by LinuxMCE (using 3 CD edition). the same results :-(

One thing that I noticed during MCE installation was that it runs Setup_DisklessMD.sh. I am wondering if I have the wrong disks or am doing something wrong ? Here is what I do :

Install the MCE installer package from Linux MCE CD#1 and that leaves me with a MCE Installer icon on the desktop. When I click on the MCE installer, it ckecks with CORE and starts a Diskless setup and is done within less than 30 seconds. At the end, it displays a box saying - reboot the syetem and then there will be regeneration of  skin etc.

In the meantime, I also configure the CORE/ Hybrid  for a new Generic PC media director - along with an OnScreen Orbiter. I use MAC address of the PC that I will use for Media director.
 
After reboot, I have to login to the Kubuntu login  prompt using my user id and password. Then I run LMCE from my desktop. All goes well and the Orbiter starts . Somehow the orbiter is in a small screen on the left side - showing BIG buttons and only half the items. 

Also, I read somewhere that there is a StartupDiskedMD.sh - a script  that I cannot find anywhere on my system. 

Help !

regards

Rajan

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #9 on: October 08, 2007, 08:30:10 pm »
In the meantime, I also configure the CORE/ Hybrid  for a new Generic PC media director - along with an OnScreen Orbiter. I use MAC address of the PC that I will use for Media director.

I suspect that at least part of the problem is that you install a MD locally on the HD, and then tell your core that it is a diskless MD.  Have you tried network-booting the MD instead?
"Change is inevitable. Progress is optional."
-- Anonymous


rbarara

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #10 on: October 08, 2007, 10:04:47 pm »
My PC's BIOS doesn't support network boot. I read on this forum that disked media director is an option on the latest release of LMCE.

I was trying to avoid buying another PC whose bios supports PXE boot.



rafik24

  • Guru
  • ****
  • Posts: 158
    • View Profile
Re: Media Director PC - boot from disk : Issue with Regeneration of Skin
« Reply #11 on: October 09, 2007, 12:33:59 am »
hi you can use grub source with a usb dongle or a plfoyy it can do pxe boot if you happend to have a generic network card in your system. works for me

 You will basically need to compile the source with the right option for your network card it's all explained in both grub and lmce wiki.

 hope it helps,

Rafik