Author Topic: setup  (Read 1194 times)

rancid_elf

  • Newbie
  • *
  • Posts: 11
    • View Profile
setup
« on: October 04, 2007, 03:35:44 pm »
Hi,  I am new to LMCE been playign about with it for a few days now and need a bit of advice.  I have browsed and searched through the forums and also for the Wiki and found some stuff I need to know but there is some stuff I have had to work out or not found at all.

Before I ask my questions I wish to give a description of how I got my system setup.  The reason I am going to do this is because a lot of the information I needed for setting up my system was hard to find or trial and error.  I have also noticed others asking for similar information with no results.

Solution :

Right I have a home network.  Netgear router running DHCP connected to my 24 meg adsl2 internet.  Attached to the router is a netgear gig 4 port switch.

Attached to the switch is -

game / develop rig...Windows Vista

10 Terabyte file server....Windows Xp...contains 40,000 albums ( mp3 ), dvd images, HD movies h264 xvid.

Media box...Windows Xp...Previously running Meedio.  This is attached to my LCD tv.


When 1st installing LMCE ( DVD install ) on my media box I ran into the problems of it wanted its own DHCP server to handle attached devices.  I initially went with this and turned off my router's dhcp.  I forgot a simple fact that if the media box is off I lose net on all other machines.  This was not a good option for me.

After a lot of messing about I finally got the system running how I wanted it.  I have noticed other people asking in here how to setup LMCE without the dhcp server running etc and the threads never seem to get very far or never give a definative solution.  Well this is mine.

I downloaded Kubuntu 7.04 live cd and installed it.
Downloaded LMCE 2 cd and installed it.

When installing I specified not to enable the dhcp server.

Enabled routers dhcp server with ip ranges of 192.168.0.2 - 192.168.0.200.  Router is 192.168.0.1
Subnet masks setup for entire range. 192.168.0.*   255.255.255.0

In Kubuntu networking I set it to obtain ip from router.
In LMCE I set the dhcp off.  I set the internal network ip address to static and gave it the ip address of 192.168.0.201.  This is still inside the subnet range of the network but outside the dhcp range so the ip will never be used by the dhcp server.

LMCE set itself to teh workgroup Linuxmce so I set my file server and games rig also to this workgroup.


This setup has allowed me to keep my existing home network as is and add LMCE as a meedia box attached to that network.  I know it will make life harder when I come to add additional home devices to the system but I will cross that bridge when I come to it.  If possible I will just add the devices from ip range 202 upwards with static ip addresses and do the setup myself.

At this stage of use though I am mainly doing testing on the software to see if it will actually do the job I require.  If I decide to stick with LMCE then my end result will result in my file server being installed with Kubuntu / LMCE and used as the core and my media box used as a portal.  This will mean I can run the dhcp server in teh core as my file server is never turned off.


Right this is where I am at.  LMCE has detected all my shares form my windows boxes and things seem to be connecting nicely.  My problem is this.  So far only certain files form file server are appearing in LMCE and everything is messy.  I need to find some documentation on how to setup and configure all my media in the manager web page.  I have fiddled around with the file options in the manager but it is not clear what is what and how to control all aspects of it.  I have searched forums and hunted through the Wiki but cannot actually find any definitive guide to what everything is...what options are to do what and how to group, arrange things etc.

Could someone direct me to this information please.

Thanks in advance and I hope my setup information becomes usefull to a few.

Paul



foneguy9

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: setup
« Reply #1 on: October 04, 2007, 04:47:15 pm »
Great post Racid_elf!

Your explainer is a good overview of a network setup with a static IP setup from the Core.  Very helpful!

I haven't gotten to the bridge you are at yet, but hopefully someone will be able to help out, like Z!



24 M ADSL ????   :o :o :o :o

I salivate in your general direction!!! ;D

foneguy9

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: setup
« Reply #2 on: October 04, 2007, 05:14:56 pm »
Hey, Rancid_elf!

In the LinuxMCE admin web browser page, at the top under Files and Media then Media Browser, you have several Check boxes related to the media itself. 

Hope that help!

rancid_elf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: setup
« Reply #3 on: October 04, 2007, 05:22:17 pm »
Hey, Rancid_elf!

In the LinuxMCE admin web browser page, at the top under Files and Media then Media Browser, you have several Check boxes related to the media itself. 

Hope that help!


Yes iv been playing around with that.  What I am looking for is a detailed description of teh stuff in there. Also maybe descriptions on how it works....as in if I wanted to do certain stuff how it can be accomplished etc.

rancid_elf

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: setup
« Reply #4 on: October 04, 2007, 06:22:40 pm »
One other options I cannot seem to find anywhere in forums is..What is the quickest and easiest way to remove the shared drives that have been allocated in LMCE.  After reading through threads and thinking for a while I have decided to use the LMCE file sharing method. 

If I have read correctly when LMCE finds one of my shared hard drives it gives me the option to just share all media as is on drive or use it in the LMCE method.  If I select the LMCE method it will create the directories on the HD for LMCE sharing.  Then I can just copy my media into these directories in the correct directory for..pictures...video...audio..etc.

At the moment I selected all my shared drives as just shared and not the LMCE method.  So I want to remove all these shares from LMCE...restart the wizard to connect all these shared drives and then copy all my media accross.

Another benifit of this is that at the moment I have like 40,000 albums in mp3 and about 2-3,000 movies stored in dvd image, dvd rip & hd files.  They are all messy so by copying them into the new directories created by LMCE I can gradually copy them and tidy them up with art work etc at same time :)

So in short...what is the best way to remove all the shares form LMCE and rerun the wizard to add them again.

Thanks

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5496
  • DOES work for LinuxMCE.
    • View Profile
Re: setup
« Reply #5 on: October 04, 2007, 07:05:22 pm »
I will add more detailed information on the wiki, but until I get home...

Basically, you need to go into the Configuration->Devices section of the web admin site...and find your hard drive in the device list...it will be under the computer that they're attached to in the device list...

after deleting the device, wait a bit.. LinuxMCE will attempt to scan and re-add them automatically, and in the process, ask you the questions.

-Thom