Author Topic: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?  (Read 3012 times)

MediaMonkey

  • Veteran
  • ***
  • Posts: 61
    • View Profile
Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« on: September 28, 2007, 07:01:48 pm »
There are two different Microsoft MCE remote controls available. One for WindowsXP and the other for Windows Vista. Anybody knows which one works better with LinuxMCE?

Thanks
Core/Hybrid: Foxconn N570SM2AA-8EKRS2H (has 2 network ports), ASUS EN6200LE, AMD-X2 4000+, 1GB DDR2-800, 500 GB SATA/300, DVD drive/writer, Sony XL1B3, BTC 9019URF, Gyro Mouse, Gyro Remote, USB-UIRT, MS Win XP Remote, ATI HDTV Wonder, HDHomeRun

MediaMonkey

  • Veteran
  • ***
  • Posts: 61
    • View Profile
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #1 on: September 29, 2007, 02:19:05 am »
One more question..

If I get the regular MCE Gyro Remote (looks similar to fiire) will it be plug and play? What functionalities will I miss in it compared to fiire?
Core/Hybrid: Foxconn N570SM2AA-8EKRS2H (has 2 network ports), ASUS EN6200LE, AMD-X2 4000+, 1GB DDR2-800, 500 GB SATA/300, DVD drive/writer, Sony XL1B3, BTC 9019URF, Gyro Mouse, Gyro Remote, USB-UIRT, MS Win XP Remote, ATI HDTV Wonder, HDHomeRun

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #2 on: September 29, 2007, 07:58:51 am »
There are actually several MCE remotes. Look at the follow post page for more information to determine which version of the remote you have.

http://www.mythtv.org/wiki/index.php/MCE_Remote

Here is a post about new MCE Remotes which seems to point to the older XP remote.
http://forum.linuxmce.org/index.php?topic=2517.0
I have the XP remote along with the Hauppauge Version which both work out of the box.  I do not have a Vista version, so I can not directly commit on the status of the Vista version, but according to the MythTV wiki it needs the mceusb module and not mceusb2 module, so I would be inclined to say it is not supported.  I know there is no device template, and this is generally needed for LinuxMCE to see and know how to use the device.  This would likely be a pretty easy task to create a template, but it looks like the lastest CVS version of LIRC is needed.
Please let us know if you get this remote working.

A simple search would have turn up the following post about the MCE gyro remote
http://forum.linuxmce.org/index.php?topic=2308.0

Thanks,
Rob

MediaMonkey

  • Veteran
  • ***
  • Posts: 61
    • View Profile
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #3 on: September 29, 2007, 04:12:56 pm »
There are actually several MCE remotes. Look at the follow post page for more information to determine which version of the remote you have.

http://www.mythtv.org/wiki/index.php/MCE_Remote

Here is a post about new MCE Remotes which seems to point to the older XP remote.
http://forum.linuxmce.org/index.php?topic=2517.0
I have the XP remote along with the Hauppauge Version which both work out of the box.  I do not have a Vista version, so I can not directly commit on the status of the Vista version, but according to the MythTV wiki it needs the mceusb module and not mceusb2 module, so I would be inclined to say it is not supported.  I know there is no device template, and this is generally needed for LinuxMCE to see and know how to use the device.  This would likely be a pretty easy task to create a template, but it looks like the lastest CVS version of LIRC is needed.
Please let us know if you get this remote working.

A simple search would have turn up the following post about the MCE gyro remote
http://forum.linuxmce.org/index.php?topic=2308.0

Thanks,
Rob

Thanks for those links, Rob. In fact I saw those forum posts and mythtv wiki. There is little reference about vista remote among the users. For now, I don't want to configure LMCE to use mceusb instead of mceusb2 and all that! I am still far away from creating templates on my own. I have to learn the LMCE architecture and that is going to take some time (pretty busy finishing the basement). Looks like it is safer for me to go with Windows XP remote and later upgrade to Fiire chief once prices fall to reasonable levels. $150 seems to be too high.
Core/Hybrid: Foxconn N570SM2AA-8EKRS2H (has 2 network ports), ASUS EN6200LE, AMD-X2 4000+, 1GB DDR2-800, 500 GB SATA/300, DVD drive/writer, Sony XL1B3, BTC 9019URF, Gyro Mouse, Gyro Remote, USB-UIRT, MS Win XP Remote, ATI HDTV Wonder, HDHomeRun

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4462
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #4 on: September 29, 2007, 07:02:18 pm »
There are actually several MCE remotes. Look at the follow post page for more information to determine which version of the remote you have.

http://www.mythtv.org/wiki/index.php/MCE_Remote

Here is a post about new MCE Remotes which seems to point to the older XP remote.
http://forum.linuxmce.org/index.php?topic=2517.0
I have the XP remote along with the Hauppauge Version which both work out of the box.  I do not have a Vista version, so I can not directly commit on the status of the Vista version, but according to the MythTV wiki it needs the mceusb module and not mceusb2 module, so I would be inclined to say it is not supported.  I know there is no device template, and this is generally needed for LinuxMCE to see and know how to use the device.  This would likely be a pretty easy task to create a template, but it looks like the lastest CVS version of LIRC is needed.
Please let us know if you get this remote working.

A simple search would have turn up the following post about the MCE gyro remote
http://forum.linuxmce.org/index.php?topic=2308.0

Thanks,
Rob

Thanks for those links, Rob. In fact I saw those forum posts and mythtv wiki. There is little reference about vista remote among the users. For now, I don't want to configure LMCE to use mceusb instead of mceusb2 and all that! I am still far away from creating templates on my own. I have to learn the LMCE architecture and that is going to take some time (pretty busy finishing the basement). Looks like it is safer for me to go with Windows XP remote and later upgrade to Fiire chief once prices fall to reasonable levels. $150 seems to be too high.


Hi,

Changing the IR receiver setting for an MD or a Core/Hybrid is very easy just got to Web Admin -> Wizard -> Devices ->Media Directors and then scroll to the MD you want to change the IR receiver setting on and select it from the 'IR Receivers' pop up - choose mce_usb. Next choose your remote from the 'Add Remote' button. The Vista MCE remote is not currently listed... but its possible that it will work with one of the standard MCE remote settings. Once you have selected the receiver and the remote you need then scroll to the bottom of the page and click 'Update'

Hope the above helps

Andrew

Andrew
Andy Herron,
Convergent Home Technologies Ltd

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

MediaMonkey

  • Veteran
  • ***
  • Posts: 61
    • View Profile
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #5 on: October 01, 2007, 07:02:02 am »
Hi,

Changing the IR receiver setting for an MD or a Core/Hybrid is very easy just got to Web Admin -> Wizard -> Devices ->Media Directors and then scroll to the MD you want to change the IR receiver setting on and select it from the 'IR Receivers' pop up - choose mce_usb. Next choose your remote from the 'Add Remote' button. The Vista MCE remote is not currently listed... but its possible that it will work with one of the standard MCE remote settings. Once you have selected the receiver and the remote you need then scroll to the bottom of the page and click 'Update'

Hope the above helps

Andrew

Andrew
Absolutely! It's been fun playing with LMCE. I am getting HDHomeRun and a XP-MCE remote this week!
Core/Hybrid: Foxconn N570SM2AA-8EKRS2H (has 2 network ports), ASUS EN6200LE, AMD-X2 4000+, 1GB DDR2-800, 500 GB SATA/300, DVD drive/writer, Sony XL1B3, BTC 9019URF, Gyro Mouse, Gyro Remote, USB-UIRT, MS Win XP Remote, ATI HDTV Wonder, HDHomeRun

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #6 on: October 01, 2007, 04:55:40 pm »
Where you able to get he Vista Remote working? 

if yes which module (mceusb or mceusb2)
and which remote did you choose. 

are all of the buttons working as expected?
any issues that you had to work through, other than not a listed remote.
did you have to update LIRC sources? etc.

If you fill real up to can you post your finding on the wiki.

Thanks,
Rob

MediaMonkey

  • Veteran
  • ***
  • Posts: 61
    • View Profile
Re: Which Microsoft Remote for LinuxMCE Windows XP MCE or Vista?
« Reply #7 on: October 01, 2007, 05:17:14 pm »
Where you able to get he Vista Remote working? 

if yes which module (mceusb or mceusb2)
and which remote did you choose. 

are all of the buttons working as expected?
any issues that you had to work through, other than not a listed remote.
did you have to update LIRC sources? etc.

If you fill real up to can you post your finding on the wiki.

Thanks,
Rob
I am getting XP MCE Remote -- want to stick with proven devices for now!
Core/Hybrid: Foxconn N570SM2AA-8EKRS2H (has 2 network ports), ASUS EN6200LE, AMD-X2 4000+, 1GB DDR2-800, 500 GB SATA/300, DVD drive/writer, Sony XL1B3, BTC 9019URF, Gyro Mouse, Gyro Remote, USB-UIRT, MS Win XP Remote, ATI HDTV Wonder, HDHomeRun