Author Topic: Many Many Duplicate video files for videos I don't have keep appearing  (Read 2566 times)

Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Ok - I have an install which is getting close to what I would consider functional (I finally have it recording TV and I can watch it too :)  However, when I go to Media -> Videos there are a whole bunch of entries for videos that I don't have on any computer in the house and that I never recorded (not to mention never would - even weirder is they are duplicated like a bunch of times - so basically when I select it I have the following as options to watch

First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
First Business:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
General Hospital:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Oprah Winfrey:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Paid Programming:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg
Sign Off:.mpg

etc - it's very weird and they don't want to delete - any idea what's going on here?

Other issues I seem to be having which are as follows (incase you have quick types on them)
Linuxmce box doesn't appear as a network share (and when I try to connect by \\IPADRESS it wont accept my un/pw)
Network booting doesn't work with any of my other machines (one of them gets a perminate ip assigned and reboots - wont get further) and the other goes a log further and gets stuck with at a screen right after it finish running some batch (I don't remember off the top of my head - the computer has gone a long way through the process though and it feels like it should be at the point it's working - but it's hanging there with a ton of network activity (but it's been like 30 minutes at this screen) and it just stays there and the screen flickers for a second every 30 seconds or so - I'm guessing it has something to do with problems starting x or something but haven't the time to really inverstigate further).

Anyways, thanks for any help!

Chy


Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #1 on: September 27, 2007, 10:55:44 am »
I'm sorry I can't help you with the duplicates, but...

What sort of machine is your core running on?
I have a PIV 1.7GHz (single core) 1GB RAM Base 100T ethernet and network booting a machine the first time takes ages (I haven't actually timed it, but up to three hours atleast).
What you are in effect doing is installing LMCE on the machine using the core as a HDD (simplified explenation) and you know how long it took to install LMCE on the Core, and all the read/write to HDD is done over the LAN, so yes it can get "crowded" while installing.

What I do is start a PXE boot before I go to bed or work, when I get back the AV-wizard is waiting for me, I select the options I want and go eat dinner/breakfast. I keep the sound on so that I hear Sarah when she asks if I can "See and hear" her, then plug in the options for this MD and let the MD render screens for all my MDS (unless I plan to add more MDs) this also takes time.

The next time you boot however it's still slower than a local boot (everything goes trough the LAN, so GB LAN is probably faster), but not more than a minute (in my experience).

I have PXE booted, IBMs, Dells, HPs and only hit trouble with the Nvidia driver on an Asus laptop (except for the time)

So 30 minutes isn't near enough time. And yes, it does appear to stall at the running diskless.sh and other points in the process, but there's a reason your LAN is packed (to put it that way)


Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #2 on: September 27, 2007, 12:15:33 pm »
This was on an HP laptop - Dual Core (1.8g each) - 2 gig ram - geforce 7400 go vid card.  I'll give it another shot and leave it going over night - hopefully that works! :)  The other box I tried it on was an HP with a Dual Core athlon - don't happen to remember the speed but it's much newer then the laptop so it should have speed.  However, after about 30sec-1 min - it gets right past the startup dhcp script thing and reboots - can't get it any further then that - not sure what the issue is.  Thanks for the tip though - will give her overnight this time! :)

Chy

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #3 on: September 27, 2007, 01:00:10 pm »
(but it's been like 30 minutes at this screen) and it just stays there and the screen flickers for a second every 30 seconds or so - I'm guessing it has something to do with problems starting x or something but haven't the time to really inverstigate further).
Does this machine have a newer line Nvidia card?
That is the same error I got on the Asus (come to think of it).
It can be resolved though (I haven't had time yet), but do a search on "nvidia" and "nv" drivers on this forum.
I found one possible candidate here
http://forum.linuxmce.org/index.php?topic=2595.0
The thing is that once the Core sees that the machine has an Nvidia card it installs the Nvidia driver, but it's not the newest driver (yet), and some proprietory (Laptop) 7xxx and all 8xxx will have problems with this driver as it does not really support them.
Just a thought that hit me

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #4 on: September 27, 2007, 02:58:44 pm »
I have seen those duplicates as well on some ocasions, I thought it was NAS related but I never got to the bottom of it as I'm just messing with to many things at once.

As for the flickering screen every ~30 seconds that should be solvable by properly configuring the display drivers, see Display_Drivers in the wiki for more information.
"Change is inevitable. Progress is optional."
-- Anonymous


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5479
  • DOES work for LinuxMCE.
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #5 on: September 27, 2007, 03:37:23 pm »
more than likely, it's caused by an open access point, which is exposing a UPnP socket...this is what I experienced when I temporarily opened my firewall for some outside testing of the orbiter software overnight...Other UPnP systems see it, and LinuxMCE goes.. OH, hey, let's import that media....

I had to go in with mysql and delete the offending entries with a DELETE query on the media table with any Path that had /mnt/upnp in it.

so the moral is, please make sure if you expose ports, to close them when you're done.

-Thom
 

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #6 on: September 27, 2007, 03:44:01 pm »
Thanks for the tip, I'll have a look for /mnt/upnp next time I notice this problem.
"Change is inevitable. Progress is optional."
-- Anonymous


Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #7 on: September 27, 2007, 10:33:30 pm »
I have seen those duplicates as well on some ocasions, I thought it was NAS related but I never got to the bottom of it as I'm just messing with to many things at once.

As for the flickering screen every ~30 seconds that should be solvable by properly configuring the display drivers, see Display_Drivers in the wiki for more information.

Ok - I'll give this a shot next - I left it running all night (just incase I wasn't running it long enough) and I still didn't get any further - I get as far as the point it loads Log Daemon [OK] - and doesn't get past that.  Just flickering display.

Thanks!

Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #8 on: September 27, 2007, 10:37:14 pm »
more than likely, it's caused by an open access point, which is exposing a UPnP socket...this is what I experienced when I temporarily opened my firewall for some outside testing of the orbiter software overnight...Other UPnP systems see it, and LinuxMCE goes.. OH, hey, let's import that media....

I had to go in with mysql and delete the offending entries with a DELETE query on the media table with any Path that had /mnt/upnp in it.

so the moral is, please make sure if you expose ports, to close them when you're done.

-Thom
 

That would make sense except a) I am on an internal network with this setup so no outside access b) none of the computers on the network have upnp enabled and c) none of the computers on this network have these files on them!  I could see how I can get the extra populated files from UPNP but I still don't know where the files are comming from to begin with :S

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #9 on: September 27, 2007, 10:58:07 pm »
Can you go to "Files & Media" > "Media Files Sync", and go through the directory tree on the left to see what different directories all these copies are in?  And maybe copy/paste the names of the directories below data/videos in here. 
"Change is inevitable. Progress is optional."
-- Anonymous


Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #10 on: September 27, 2007, 11:18:33 pm »
Are you sure the neighbour isn't piggybacking your WLan  ;)

Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #11 on: September 28, 2007, 12:00:08 am »
Can you go to "Files & Media" > "Media Files Sync", and go through the directory tree on the left to see what different directories all these copies are in?  And maybe copy/paste the names of the directories below data/videos in here. 

I'll do that when i get home from work :)

Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #12 on: September 28, 2007, 12:01:30 am »
Are you sure the neighbour isn't piggybacking your WLan  ;)

They might be but they would have had to crack the WAP encryption on my network and considering that the network hasn't been online for the extent of time with somebody trying to crack it for that duration - I suspect it's unlikely! ;)

Chymmylt

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #13 on: September 28, 2007, 12:26:00 am »
Can you go to "Files & Media" > "Media Files Sync", and go through the directory tree on the left to see what different directories all these copies are in?  And maybe copy/paste the names of the directories below data/videos in here. 

Ok - home on lunch - the directory tree looks like:
> home
    > public
        [ data ]
            > audio
            > documents
            > other
            > pictures
            > samples
            > tts
            > videos

In the video directory I have the following files on disk listed:

 tv_shows_0 
 
 tv_shows_1 
 
 tv_shows_62 

However, I'm not finding any of these files listed anywhere in here?


I also out of curiosity checked to see if it was in /mnt/upnp and I don't seem to have upnp in my /mnt directory?  This keeps getting weirder and weirder :S

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5479
  • DOES work for LinuxMCE.
    • View Profile
Re: Many Many Duplicate video files for videos I don't have keep appearing
« Reply #14 on: September 28, 2007, 03:09:57 am »
you'll need to go into the KDE Desktop, and open up a Konsole

type mysql pluto_media -uroot

then type the following to see if any of the media was found from upnp:

SELECT Path from File WHERE Path LIKE '%upnp%';

did any match?

if so,

DELETE from File WHERE Path LIKE '%upnp%';

and that should get rid of them....

-Thom