Author Topic: xorg.conf on diskless MD reverts to original  (Read 900 times)

eddy67

  • Newbie
  • *
  • Posts: 5
    • View Profile
xorg.conf on diskless MD reverts to original
« on: September 22, 2007, 02:24:14 pm »
Im trying to edit the xorg.conf file on my diskless MD but the changes I have made keeps reverting to the original. Im trying to change from vesa to nVidia....

Is there some other file that I should be editing instead?

//Peter

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: xorg.conf on diskless MD reverts to original
« Reply #1 on: September 23, 2007, 08:44:53 am »
There is a script that rewrites the settings if it detects a change. I haven't found it or how to defeat it but I have managed to change the settings andget them to stick. But I'm not sure what I did that actually did it.

Either editing after killing x (from a terminal run init 3 or you can run /usr/pluto/bin/Stop_X.sh) or ssh in from a remote terminal using Putty (log into the core,  sudo su, ssh (MD's IP address) and edit the xorg.conf. But I'm not sure which.

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: xorg.conf on diskless MD reverts to original
« Reply #2 on: September 28, 2007, 01:18:19 pm »

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: xorg.conf on diskless MD reverts to original
« Reply #3 on: October 11, 2007, 11:50:54 pm »
Check out this page:

http://muse.linuxmafia.org/lost+found/chattr.txt

Actually, if you protect the file LMCE will keep duplicating it and appending a number until you have thousands!

Try this instead (from the wiki):

Add a line containing exit to the top of the /usr/pluto/bin/Xconfigure.sh file.