Author Topic: avi on DVD-ROM  (Read 959 times)

kolaf

  • Newbie
  • *
  • Posts: 4
    • View Profile
avi on DVD-ROM
« on: September 21, 2007, 10:57:55 am »
Hi,

I assume LinuxMCE should be able to recognise a set of .avi files on a dvd or cd ROM when it is inserted and present them for playback?  If this is the case I have yet to get it to work, and would greatly appreciate any help you can give me.  I've tried with several different CDs and DVDs with avi files on them, mostly divx3 content.  The files are recognized and played back from the KDE desktop, but the orbiter only says a CD has been inserted and nothing more.  With audio cds it starts playing the tracks.  I've checked DCERouter.log which gives me this after inserting a cd:
Code: [Select]
Received Message from 26 (Disk Drive / Living Room/Family Room) to Orbiter Plug-in(9), type 1 id  406 Command:Display Message, retry none, parameters: <0x808ceb90>
08      09/21/07 10:43:31.723             Parameter 9(Text): Disc detected in drive. <0x808ceb90>
08      09/21/07 10:43:31.723             Parameter 14(Type):  <0x808ceb90>
08      09/21/07 10:43:31.723             Parameter 50(Name):  <0x808ceb90>
08      09/21/07 10:43:31.723             Parameter 102(Time): 5 <0x808ceb90>
08      09/21/07 10:43:31.723             Parameter 103(List PK Device): 20 <0x808ceb90>
08      09/21/07 10:43:31.728           Received Message from 9 (Orbiter Plug-in / Living Room/Family Room) to OnScreen Orbiter(20), type 1 id  741 Command:Goto Screen, retry none, parameters: <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 9(Text): Disc detected in drive.|||| <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 137(Command Line): ||| <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 159(PK_Screen): 53 <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 163(Description): generic message <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 181(PromptToResetRouter): 0 <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 182(Timeout): 5 <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 183(CannotGoBack): 1 <0xa6933b90>
08      09/21/07 10:43:31.729             Parameter 251(Interruption): 0 <0xa6933b90>
08      09/21/07 10:43:31.730             Parameter 252(Turn On): 0 <0xa6933b90>
08      09/21/07 10:43:31.730             Parameter 253(Queue): 0 <0xa6933b90>
08      09/21/07 10:43:32.849           Received Message from 26 (Disk Drive / Living Room/Family Room) to 27 (External Media Identifier / Living Room/Family Room), type 1 id 314 Command:Identify Media, retry none, parameters: <0xaecd7b90>
08      09/21/07 10:43:32.849             Parameter 2(PK_Device): 26 <0xaecd7b90>
08      09/21/07 10:43:32.849             Parameter 10(ID): 1190364212 <0xaecd7b90>
08      09/21/07 10:43:32.849             Parameter 13(Filename): /dev/cdrom <0xaecd7b90>
08      09/21/07 10:43:32.849             Parameter 201(PK_Device_Related): 26 <0xaecd7b90>
08      09/21/07 10:43:38.909           Received Message from 32 (unknown / ) to Media Plug-in(10), type 1 id  831 Command:Refresh List of Online Devices, retry none, parameters: <0x75efcb90>
05      09/21/07 10:43:39.014           Socket::ReceiveData 0x7770b2b8 failed, bytes left 0 start: 19580000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 148 Incoming_Conn Socket 148 127.0.0.1 <0x75efcb90>
05      09/21/07 10:43:39.015           Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Incoming_Conn Socket 148 127.0.0.1 <0x75efcb90>
05      09/21/07 10:43:39.015           TCPIP: Closing connection to -1003 (Router Dev #0) 0x7770b2b8 m_Socket: -1 <0x75efcb90>
05      09/21/07 10:43:39.015           Router::RemoveAndDeleteSocket 0x7770b2b8 -1003 <0x75efcb90>

This is the one thing I'm lacking from a perfectly usable set up for my living-room media playback, so I'm very eager to get it working.

Darren404

  • Regular Poster
  • **
  • Posts: 17
    • View Profile
Re: avi on DVD-ROM
« Reply #1 on: January 16, 2008, 09:16:07 am »
Wow, I found this old post and was surprised to see someone having the same problem.  If anyone knows why this happens or how to fix it I would love to know.

Thanks
My house runs Linux

alphapenguin

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: avi on DVD-ROM
« Reply #2 on: May 19, 2008, 02:44:17 am »
same issue. Is this just a thing with LinuxMCE? where it cant use the Disc drives for data? (i.e. .avi, mp3 etc)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: avi on DVD-ROM
« Reply #3 on: May 19, 2008, 04:59:24 am »
The Disk Drive device, currently does not support this. We would of course, welcome a patch to do this.

-Thom

alphapenguin

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: avi on DVD-ROM
« Reply #4 on: May 19, 2008, 06:16:55 pm »
thanks for the reply. Now I gotta learn how to do a lil programming so I can actually contribute to this community, instead of just taking.