Author Topic: Blank Screen after LinuxMCE installed Nvidia drivers.  (Read 1576 times)

vastdigital

  • Newbie
  • *
  • Posts: 9
    • View Profile
Blank Screen after LinuxMCE installed Nvidia drivers.
« on: September 20, 2007, 04:05:15 pm »
Installed Kubuntu from CD. All working well.

Installed LinuxMCE from CD, it asks about the nvidia card (8600GT) and offers to install the proprietry video drivers and will need to restart. Select yes and it restarts.

Unfortunatley after it goes through the Kubuntu spalsh screen it then goes blank with just a flashing cursor. Any ideas??

padrino

  • Regular Poster
  • **
  • Posts: 18
    • View Profile
Re: Blank Screen after LinuxMCE installed Nvidia drivers.
« Reply #1 on: October 02, 2007, 04:33:05 am »
I have had the same issue with a 7600GS and to solve the problem I use Envy to install a working set of drivers. This was working until 0704 because I just did a fresh install and now on every reboot t decides to reinstall the non-working nvidia drivers, if you can figure out how to disable the install on reboot you shouldbe all set.

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: Blank Screen after LinuxMCE installed Nvidia drivers.
« Reply #2 on: October 02, 2007, 06:54:18 am »
Have you tried the instructions at http://wiki.linuxmce.org/index.php/AVWizard.

When A/V Wizard starts it always outputs 640x480 on the VGA connector. So, if you are not using the VGA connector, you will likely see a blank, black screen when A/V Wizard starts, even if you previously saw the Kubuntu boot splash. You will know that the A/V Wizard is running because you hear a series of beeps. When you hear those beeps, if you have video, proceed to complete the A/V Wizard.

Thanks,
Rob

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: Blank Screen after LinuxMCE installed Nvidia drivers.
« Reply #3 on: October 02, 2007, 09:07:17 am »
The proprietory Nvidia driver will not work with Gf8xxx cards and some newer Gf7xxx.
You can either use the nv driver (not installing the Nvidia one), or install the newest driver from nvidia, problem is that the av wizard will overwrite your driver...

Rookie

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Blank Screen after LinuxMCE installed Nvidia drivers.
« Reply #4 on: October 23, 2007, 04:06:41 pm »
i am having the EXACT same problem,
when i boot to blank screen i can go through numbers 1-5, with no result other than a beep after each number...  still no video.  all was working wonderfully until linuxmce install. i ran the test and everything showed up perfectly with my 6800gt card.  My first attempt to install linuxmce.

i am installing this on an old pc to see if it is something i can do and would like.
amd64 3000+
bfg 6800gtoc
<dont' rember which mb,  maybe a ad77 infinity dfi board>
1gig ram
200gb hard drive
-----------------

after reading more i wish i was at home, i think i may know how to fix this.  could be that i have video plugged in to wrong output.  but if that was the case, why would kubuntu work perfectly but avwizzard fail?  just curious.....
« Last Edit: October 23, 2007, 04:27:40 pm by Rookie »

Rookie

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Blank Screen after LinuxMCE installed Nvidia drivers.
« Reply #5 on: October 24, 2007, 01:40:54 am »
switched from the vga port to the dmi port with an adapter, all is well with the world.  install is flawless.

mitsus

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Blank Screen after LinuxMCE installed Nvidia drivers.
« Reply #6 on: October 24, 2007, 09:32:22 pm »
I've an NVIDIA Quadro FX 3450/4000 SDI. I've solved the problem of black screen after NVIDIA drivers installation after Linux MCE installation.

There are my steps:

1. Install Ubuntu with basic graphic support.
2. Install NVIDIA drivers (I use Version: 100.14.11 because Version: 100.14.19 don't work well)
See below how.
Exit from X.

sudo apt-get install build-essential
sudo apt-get install linux-headers-$(uname -r)
sudo apt-get install xserver-xorg-dev
sudo apt-get remove --purge nvidia-glx
then
sudo sh ./NVIDIA-Linux-x86-100.14.11-pkg1.run
[/i]

Reboot

If after reboot X server don't start, type CTRL+ALT+F1 and edit /etc/X11/xorg.conf.
And change these lines

In the Section “Device”:

[..]
Driver “nvidia”
[…]

In the Section “Screen”:

[..]
DefaultDepth 24
Option “SLI” “on”
Option “RenderAccel” “True”
Option “AllowGLXWithComposite” “True”
Option “AddARGBGLXVisuals” “True”
SubSection “Display”
[…]

at the end of file, create a new Section”Extensions” così:

Section “Extensions”
Option “Composite” “Enable”
EndSection

Write and exit

Well, now type #startx at prompt.

Your Nviadia cord now work fine.

3. Install Linux MCE with U2 Tranparency