Author Topic: MythTV behaving weird...  (Read 1432 times)

chewi

  • Veteran
  • ***
  • Posts: 69
    • View Profile
MythTV behaving weird...
« on: September 17, 2007, 10:45:37 pm »
My MythTV behaves weird when started from LMCE...
It keeps switching between EPG view and TV-Picture continously until linuxmce reports some problem with the backend...

When i start mythfrontend manually from the kde-desktop, everything works fine...

Does anyone have any idea why that could be ?

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: MythTV behaving weird...
« Reply #1 on: September 18, 2007, 12:12:33 am »
I have been having this same problem on only one of my MD's the other starts fine.  I have been search in the logs, but I have not found anything at this time.

I will keep you posted if I find something.

Thanks,
Rob

chewi

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: MythTV behaving weird...
« Reply #2 on: September 18, 2007, 03:53:02 pm »
Ok, I think I tracked it down a little more...

From what i understand, Mythtv starts. Then LMCE tells it to jump to livetv. MythTV ends up in the EPG-Grid. And then LMCE seems to send or MythTV to process the swith-Command twice, so that MythTV switches to TV and back to the EPG-Grid. Then LMCE queries the current Display and asks for the switch again...
So maybe, the delay before query-Location should just wait a little longer (might be DVB-T specifict, as tuning might take a little loger)...

But can that be configured anywhere ? Where ?

from /var/log/pluto/24_MythTV_Player:
05      09/18/07 15:31:54.759           Going to send command jump livetv <0xb781eb90>
05      09/18/07 15:31:56.019           Connect() failed, Error Code 111 (Connection refused)) <0xb781eb90>
05      09/18/07 15:31:57.019           Connect() failed, Error Code 111 (Connection refused)) <0xb781eb90>
05      09/18/07 15:31:58.019           Connect() failed, Error Code 111 (Connection refused)) <0xb781eb90>
05      09/18/07 15:31:58.019           ClientSocket::Connect() not successful <0xb781eb90>
05      09/18/07 15:31:58.019           void ClientSocket::Disconnect() on this socket: 0x80b7f98 (m_Socket: 8) <0xb781eb90>
01      09/18/07 15:31:58.019           Unable to connect to MythTV client <0xb781eb90>
05      09/18/07 15:31:58.019           MythTV_Player::pollMythStatus no jump livetv  <0xb781eb90>

05      09/18/07 15:31:58.119           Going to send command jump livetv <0xb781eb90>
05      09/18/07 15:32:00.464           Myth Responded: OK <0xb781eb90>
05      09/18/07 15:32:01.463           Going to send command query location <0xb781eb90>
05      09/18/07 15:32:01.516           Myth Responded: GuideGrid <0xb781eb90>
05      09/18/07 15:32:01.516           MythTV_Player::pollMythStatus no playback yet, reported : GuideGrid <0xb781eb90>

05      09/18/07 15:32:04.615           Going to send command jump livetv <0xb781eb90>
05      09/18/07 15:32:06.661           Myth Responded: OK <0xb781eb90>
05      09/18/07 15:32:07.660           Going to send command query location <0xb781eb90>
05      09/18/07 15:32:07.733           Myth Responded: GuideGrid <0xb781eb90>
05      09/18/07 15:32:07.733           MythTV_Player::pollMythStatus no playback yet, reported : GuideGrid <0xb781eb90>

05      09/18/07 15:32:10.832           Going to send command jump livetv <0xb781eb90>
05      09/18/07 15:32:12.872           Myth Responded: OK <0xb781eb90>
05      09/18/07 15:32:13.872           Going to send command query location <0xb781eb90>
05      09/18/07 15:32:13.945           Myth Responded: GuideGrid <0xb781eb90>
05      09/18/07 15:32:13.945           MythTV_Player::pollMythStatus no playback yet, reported : GuideGrid <0xb781eb90>

05      09/18/07 15:32:17.044           Going to send command jump livetv <0xb781eb90>
05      09/18/07 15:32:19.118           Myth Responded: OK <0xb781eb90>
05      09/18/07 15:32:20.128           Going to send command query location <0xb781eb90>
05      09/18/07 15:32:20.149           Myth Responded: GuideGrid <0xb781eb90>
05      09/18/07 15:32:20.149           MythTV_Player::pollMythStatus no playback yet, reported : GuideGrid <0xb781eb90>

Blocks continue until crash of backend is supposed by LMCE

If I don't restart the Backend, it seems to work correctly from that time on...

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: MythTV behaving weird...
« Reply #3 on: September 19, 2007, 04:35:36 am »
Here is my log, it is a little different, but the problem is the same.  I believe that you are right when it times out to quickly with certain cards.  The MD that I am having problems with is the WinTV PVR-USB2 the MD with the 2 PVR250s is fine.

Code: [Select]
Socket::ReceiveData 0x80c2d50 failed, bytes left 0 start: 60000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 8 Plain Socket <0xb67ceb90>
05      09/18/07 21:10:13.199           Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Plain Socket <0xb67ceb90>
01      09/18/07 21:10:13.199           Didn't get reply. <0xb67ceb90>
05      09/18/07 21:10:17.463           Going to send command jump livetv <0xb77d0b90>
05      09/18/07 21:10:18.471           Connect() failed, Error Code 111 (Connection refused)) <0xb77d0b90>
05      09/18/07 21:10:19.475           Connect() failed, Error Code 111 (Connection refused)) <0xb77d0b90>
05      09/18/07 21:10:20.479           Connect() failed, Error Code 111 (Connection refused)) <0xb77d0b90>
05      09/18/07 21:10:20.479           ClientSocket::Connect() not successful <0xb77d0b90>
05      09/18/07 21:10:20.479           void ClientSocket::Disconnect() on this socket: 0x80c4900 (m_Socket: 8) <0xb77d0b90>
01      09/18/07 21:10:20.479           Unable to connect to MythTV client <0xb77d0b90>
05      09/18/07 21:10:20.479           MythTV_Player::pollMythStatus no jump livetv  <0xb77d0b90>
05      09/18/07 21:10:20.579           Going to send command jump livetv <0xb77d0b90>
05      09/18/07 21:10:22.635           Myth Responded: OK <0xb77d0b90>
05      09/18/07 21:10:23.635           Going to send command query location <0xb77d0b90>
05      09/18/07 21:10:25.707           Myth Responded: Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:25.708           MythTV_Player::pollMythStatus no playback yet, reported : Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:28.807           Going to send command jump livetv <0xb77d0b90>
05      09/18/07 21:10:30.847           Myth Responded: OK <0xb77d0b90>
05      09/18/07 21:10:31.847           Going to send command query location <0xb77d0b90>
05      09/18/07 21:10:33.904           Myth Responded: Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:33.904           MythTV_Player::pollMythStatus no playback yet, reported : Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:37.003           Going to send command jump livetv <0xb77d0b90>
05      09/18/07 21:10:39.027           Myth Responded: OK <0xb77d0b90>
05      09/18/07 21:10:40.027           Going to send command query location <0xb77d0b90>
05      09/18/07 21:10:42.080           Myth Responded: Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:42.080           MythTV_Player::pollMythStatus no playback yet, reported : Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:45.179           Going to send command jump livetv <0xb77d0b90>
05      09/18/07 21:10:47.211           Myth Responded: OK <0xb77d0b90>
05      09/18/07 21:10:48.211           Going to send command query location <0xb77d0b90>
05      09/18/07 21:10:50.268           Myth Responded: Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:50.268           MythTV_Player::pollMythStatus no playback yet, reported : Playback ERROR: Timed out waiting for reply from player <0xb77d0b90>
05      09/18/07 21:10:53.371           Going to send command jump livetv <0xb77d0b90>
05      09/18/07 21:10:55.464           Myth Responded: OK <0xb77d0b90>
05      09/18/07 21:10:56.467           Going to send command query location <0xb77d0b90>
05      09/18/07 21:10:56.584           Myth Responded: Playback LiveTV 00:00:00 of 00:00:04 1x 3011 2007-09-18T21:00:00 <0xb77d0b90>

And here is what the logs look like from the MD that starts fine.
Code: [Select]
Going to send command jump livetv <0xb7879b90>
05      09/18/07 21:17:54.601           Connect() failed, Error Code 111 (Connection refused)) <0xb7879b90>
05      09/18/07 21:17:55.601           Connect() failed, Error Code 111 (Connection refused)) <0xb7879b90>
05      09/18/07 21:17:56.617           Connect() failed, Error Code 111 (Connection refused)) <0xb7879b90>
05      09/18/07 21:17:56.617           ClientSocket::Connect() not successful <0xb7879b90>
05      09/18/07 21:17:56.617           void ClientSocket::Disconnect() on this socket: 0x80c2c28 (m_Socket: 8) <0xb7879b90>
01      09/18/07 21:17:56.617           Unable to connect to MythTV client <0xb7879b90>
05      09/18/07 21:17:56.617           MythTV_Player::pollMythStatus no jump livetv  <0xb7879b90>
05      09/18/07 21:17:56.717           Going to send command jump livetv <0xb7879b90>
05      09/18/07 21:17:58.794           Myth Responded: OK <0xb7879b90>
05      09/18/07 21:17:59.793           Going to send command query location <0xb7879b90>
05      09/18/07 21:17:59.878           Myth Responded: Playback LiveTV 00:00:00 of 00:00:02 1x 4005 2007-09-18T21:00:00 <0xb7879b90>

chewi

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: MythTV behaving weird...
« Reply #4 on: September 20, 2007, 02:26:28 pm »
I did have a look into the code on svn.pluto and svn@sourceforge.
If found the code responsible it's MythTV_Player/MythTV_Player.cpp -> void MythTV_Player::pollMythStatus() with m_mythStatus_get() == MYTHSTATUS_STARTUP within the do {...} while Timeout(NULL) < timeout;

But the versions of the code from pluto and sourceforge do not match, and I don't know, what version is current 0704 and what version is svn-head-development... :(

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: MythTV behaving weird...
« Reply #5 on: September 22, 2007, 08:22:03 am »
Sources have to be downloaded from the Mirrors. The SVN is not current at this time.

chewi

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: MythTV behaving weird...
« Reply #6 on: September 24, 2007, 11:13:19 pm »
The 0704-Sources are there as torrent, yes...

But what about the updates that have been released ? Where can I find them ?