Author Topic: Pleeeeassee help with MCE remote :-(  (Read 7917 times)

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Pleeeeassee help with MCE remote :-(
« Reply #15 on: November 30, 2007, 04:57:04 pm »
Pleeeeassee help with adding stuff like that to the wiki... :-(

And as we move closer n closer to 0710 its important to make sure that Wiki information is clearly identified as relating to 0704.... otherwise this could cause all kinds of problems ;-)
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #16 on: November 30, 2007, 05:12:11 pm »
Sorry, but I'm new to LinuxMCE and to Linux as well and I have to work with it for a while to get into it. I will fix it somehow. I made some steps forward but I still have the problem with installing packages as I posted here: http://forum.linuxmce.org/index.php?topic=3319.0
If you could help me with that would be great.

Greets
« Last Edit: November 30, 2007, 05:15:00 pm by AK83 »

Hagen

  • Guru
  • ****
  • Posts: 437
  • LMCE wannabe user
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #17 on: November 30, 2007, 06:38:54 pm »
I am slightly tempted to answer:
Wait for the 710 release instead of doing all this work that is allready done in the next release.
But I woun't ;)

leonja

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #18 on: November 30, 2007, 08:32:42 pm »
AK83
I got your PM.  I wrote down what I did to resolve my MCE remote proble in this thread:

http://forum.linuxmce.org/index.php?topic=3049.0

Let us know if you need more help.

Good luck,
Jaime
Selectron 42 inch LCD TV
AMD Athlon 2800+ on MSI K7N Motherboard
2x512MB DDR400 RAM
PNY Nvidia FX 5700 AGP video card
Hauppauge PVR-150 MCE capture card
Integrated Realtek 5.1 audio

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #19 on: December 01, 2007, 01:46:30 pm »
leonja, thanks a lot!

My problem is that I get this error message
Code: [Select]
configure: error: *** you need to have the Linux kernel source installed for this driverwhen typing this
Code: [Select]
./configure --prefix=/usr --sysconfdir=/etc/conf.d --with-x --with-driver=mceusb2
I read that it has something to do with the kernel headers. As described here http://www.mythtv.org/wiki/index.php/MCE_Remote#Installation_guides uname -a gives me back 2.6.20-16-generic. So I tried to update but it says that it is already the latest version. Any ideas?

Again, thanks a lot for your help!

leonja

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #20 on: December 02, 2007, 04:01:35 am »
AK83
I don't really know what could be wrong with your configuration.  I see you used the latest lirc source code.  One of the threads I read while trying to resolve the MCE remote problem warned about installing the latest lirc beta version, as it could contain code that was not supported under the current LMCE version.  For this reason, I downloaded the same lirc version 0.8.2 (official release) source code used in LMCE 704 and then overlaid the lirc_mceusb2 module source code version 1.37.  Thus, only updating the small part of lirc required to support the MCE remote with the SMK receiver.  Follow the instructions I wrote in my thread.

Again, I am not sure if this is your problem, but this is what worked for me.  Support for the MCE remote and SMK receiver is supposedly included in LMCE 710, as mentioned by several other persons in this forum.  Date for the 710 release is delayed though.

Good luck,
Jaime
Selectron 42 inch LCD TV
AMD Athlon 2800+ on MSI K7N Motherboard
2x512MB DDR400 RAM
PNY Nvidia FX 5700 AGP video card
Hauppauge PVR-150 MCE capture card
Integrated Realtek 5.1 audio

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #21 on: December 03, 2007, 04:13:30 am »
leonja, thanks a lot!

My problem is that I get this error message
Code: [Select]
configure: error: *** you need to have the Linux kernel source installed for this driverwhen typing this
Code: [Select]
./configure --prefix=/usr --sysconfdir=/etc/conf.d --with-x --with-driver=mceusb2
I read that it has something to do with the kernel headers. As described here http://www.mythtv.org/wiki/index.php/MCE_Remote#Installation_guides uname -a gives me back 2.6.20-16-generic. So I tried to update but it says that it is already the latest version. Any ideas?

Again, thanks a lot for your help!

Have you done "apt-get install linux-headers"?
If that doesn't work try "apt-get install kernel-headers" - Can't remember which one it was  :-\

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #22 on: December 03, 2007, 08:23:46 am »
hey!

@leonja: I also tried version 0.8.2 with the latest lirc_mceusb2 drivers. Doesn't work.
@darrenmason: "apt-get install linux-headers [version]" says that I already have the newest version.

What I get now is this:
Code: [Select]
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

I read that I need the GCC (build essential) package to compile. But I can't install that package using the terminal as I am told that it cannot be found. I think that is because of the lmce sources.list. Could I download some kind of .deb-file for this and run it after downloading?

Thanks! 

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #23 on: December 04, 2007, 12:37:43 am »
That error looks like you might not have the C++ compiler.

try 'apt-get install g++'

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #24 on: December 05, 2007, 08:47:54 pm »
Hey!

The Terminal tells me that I already have the latest version of "gcc" (that's what you meant I guess).
Code: [Select]
alex@dcerouter:~$ dpkg -l gcc
...
||/ Name                       Version                    Beschreibung
+++-==========================-==========================-====================================================================
ii  gcc                        4.1.2-1ubuntu1             The GNU C compiler
and
Code: [Select]
alex@dcerouter:~$ dpkg -l make
...
||/ Name                       Version                    Beschreibung
+++-==========================-==========================-====================================================================
ii  make                       3.81-3build1               The GNU version of the "make" utility.

I still get that error:
Code: [Select]
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

I don't know. Do I need something else?

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #25 on: December 05, 2007, 09:11:06 pm »
Ok, sorry. I just read this:
"gcc is first built without the C++ compiler"

What I need is "gcc-c++", but I can't install any packages. The Terminal always tells me that the package cannot be found, doesn't matter which package I choose. Perhaps something went wrong during installation. That's why I asked for a different way to get packages I need.
 :-[

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #26 on: December 05, 2007, 11:47:28 pm »
I am sure the following worked for me....

apt-get update
apt-get install g++

What do you get when you enter these commands?

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #27 on: December 06, 2007, 11:16:10 am »
Code: [Select]
alex@dcerouter:~$ sudo apt-get update
Reading package lists... Done
alex@dcerouter:~$ sudo apt-get install g++
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package g

When I just try "apt-get install g++", I get:
Code: [Select]
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Perhaps LMCE can't update the packages? Is there some kind of log file I could check?

AK83

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #28 on: December 07, 2007, 03:33:16 pm »
Hi!

I don't know, but probably there's something wrong with my sources.list. Would I get an error if "apt-get update" failed? Could someone post his sources.list so I can check if there's anything missing? Would be nice!

rafik24

  • Guru
  • ****
  • Posts: 158
    • View Profile
Re: Pleeeeassee help with MCE remote :-(
« Reply #29 on: December 09, 2007, 08:16:17 pm »
 Hi AK83,

 make sure you have       deb http://archive.ubuntu.com/ubuntu feisty main restricted universe multiverse
in you /etc/apt/sources.list

 i would recommend to comment the line once you have finished downloading packages to avoid dependency  issues if update / upgrade happens from within lmce.

 Rafik