Author Topic: Setting root password - only asks once  (Read 1536 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Setting root password - only asks once
« on: October 08, 2005, 05:13:32 pm »
Hi,

I've just started trying out pluto (looks good so far) but one thing that jumped out at me is, when doing the initial install, you only get asked to type in the root password once. Just about every system that asks you to set a password asks for it twice. This could cause problems (as it has done for me now) if the password is mistyped.

I'm having to try and reset my root password now because it seems I've got fat fingers and mistyped it during the installation! ;)

Not sure if this is part of the debian side of installation, or something that pluto has control over.

Thanks,

Darren.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Setting root password - only asks once
« Reply #1 on: October 10, 2005, 10:26:51 am »
It's from Debian. I'll have to raise the priority of the "verify password" screen so it gets displayed too. I still have to see where that is configured from.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Setting root password - only asks once
« Reply #2 on: October 10, 2005, 12:10:51 pm »
Cheers,

For future reference (ie, someone else with fat fingers!) the easiest way to reset the root password on your server is:

1. Boot from installation CD.
2. Follow the installation through until it starts asking you about disk partitioning (You don't want to go into this, otherwise you lose everything!)
3. Press ALT+F2 to get a console.
4. Mount the root partition (usually /dev/hda1)
     mount /dev/hda1 /tmp
5. cd /tmp/etc
6. nano passwd
7. Remove the x on the line that starts root:x:0:0:
8. Save the file
9. Unmount /dev/hda1
     umount /tmp
10. Reboot without the CD.

The root password should now be blank. Once the server has booted, press ALT+F2 to get a console, login as root, press return for the password.

You can set a new password with the passwd command (this one will ask you twice!)

For remote access (ssh) to work, a password must be set.

HTH,

Darren.