Author Topic: No audio  (Read 2249 times)

Matt

  • Newbie
  • *
  • Posts: 7
    • View Profile
No audio
« on: August 26, 2007, 02:27:03 am »
Hi, I have just installed LinuxMCE 0704 using the Quick Install DVD on my 2nd PC which is using a GA-K8N Pro-SLI which uses a Realtek ALC850 Audio AC'97 Codec sound card. When I booted it up into LMCE there was no sound except for the beep thing (its doing some tunes not just the usual beep I'm ok noise so I am guessing thats LMCE not just the BIOS). I have not had any problems with previous Ubuntu or even PCLinuxOS installs on this machine and tested it on a PCLinuxOS boot disk I had floating around and the sound works fine (although it is coming out of the Rear Speaker Out port rather than Front Speaker Out port).

I stumbled across a control panel in PCLinuxOS that told me I was using a driver called "Intel 82801AA,82901AB,i810,i820,i830,i840,i845,MX440; SiS 7012; Ali 5455 (snd-intel8x0 [ALSA])" however I am not able to find anything in LMCE that will tell me what driver I am using. Could you please help me out? Thanks

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: No audio
« Reply #1 on: August 26, 2007, 04:56:42 pm »
As I know LMCE uses ALSA to for audio. Recently I spent some time to configure SPDIF audio on my Plutohome installation. I found that SMP kernel has old version of ALSA. That's why my sound card was recognized correctly (I saw only analog output not digital). So, you can use the same commands to check your card:

1. aplay -L - display a list of playback hardware devices. Actually, you can find there your card.
2. alsaconfig - console configuration utility for ALSA
3. alsamixer - console mixer for ALSA. Note that SPDIF out is muted by default. To use it run the mixer and unmute it.
4. alsactrl <command> - allows to run some ALSA command, actually you need 'store' to save your configuration.
5. cat /proc/asound/version - display a version of ALSA installed on your PC.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Matt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No audio
« Reply #2 on: August 26, 2007, 08:16:50 pm »
When I run the first command the terminal outputs the following:

Quote
PCM list:
hw {
        @args.0 CARD
        @args.1 DEV
        @args.2 SUBDEV
        @args.CARD {
                type string
                default {
                        @func getenv
                        vars {
                                0 ALSA_PCM_CARD
                                1 ALSA_CARD
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.card'
                        }
                }
        }
        @args.DEV {
                type integer
                default {
                        @func igetenv
                        vars {
                                0 ALSA_PCM_DEVICE
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.device'
                        }
                }
        }
        @args.SUBDEV {
                type integer
                default {
                        @func refer
                        name 'defaults.pcm.subdevice'
                }
        }
        type hw
        card $CARD
        device $DEV
        subdevice $SUBDEV
}
plughw {
        @args.0 CARD
        @args.1 DEV
        @args.2 SUBDEV
        @args.CARD {
                type string
                default {
                        @func getenv
                        vars {
                                0 ALSA_PCM_CARD
                                1 ALSA_CARD
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.card'
                        }
                }
        }
        @args.DEV {
                type integer
                default {
                        @func igetenv
                        vars {
                                0 ALSA_PCM_DEVICE
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.device'
                        }
                }
        }
        @args.SUBDEV {
                type integer
                default {
                        @func refer
                        name 'defaults.pcm.subdevice'
                }
        }
        type plug
        slave.pcm {
                type hw
                card $CARD
                device $DEV
                subdevice $SUBDEV
        }
}
plug {
        @args.0 SLAVE
        @args.SLAVE {
                type string
        }
        type plug
        slave.pcm $SLAVE
}
shm {
        @args.0 SOCKET
        @args.1 PCM
        @args.SOCKET {
                type string
        }
        @args.PCM {
                type string
        }
        type shm
        server $SOCKET
        pcm $PCM
}
tee {
        @args.0 SLAVE
        @args.1 FILE
        @args.2 FORMAT
        @args.SLAVE {
                type string
        }
        @args.FILE {
                type string
        }
        @args.FORMAT {
                type string
                default raw
        }
        type file
        slave.pcm $SLAVE
        file $FILE
        format $FORMAT
}
file {
        @args.0 FILE
        @args.1 FORMAT
        @args.FILE {
                type string
        }
        @args.FORMAT {
                type string
                default raw
        }
        type file
        slave.pcm null
        file $FILE
        format $FORMAT
}
null {
        type null
}
cards 'cards.pcm'
front 'cards.pcm.front'
rear 'cards.pcm.rear'
center_lfe 'cards.pcm.center_lfe'
side 'cards.pcm.side'
surround40 'cards.pcm.surround40'
surround41 'cards.pcm.surround41'
surround50 'cards.pcm.surround50'
surround51 'cards.pcm.surround51'
surround71 'cards.pcm.surround71'
iec958 'cards.pcm.iec958'
spdif 'cards.pcm.iec958'
modem 'cards.pcm.modem'
phoneline 'cards.pcm.phoneline'
default 'cards.pcm.default'
dmix 'cards.pcm.dmix'
dsnoop 'cards.pcm.dsnoop'
spdif_playback {
        type plug
        slave convert48k
}
asym_spdif {
        type asym
        playback.pcm spdif_playback
        capture.pcm plughw:0
}

When I run your second command I get the error message "bash: alsaconfig: command not found".

I hadn't noticed this earlier but on the LinuxMCE Launch Manager on the Audio tab the box next to "Audio driver:" is blank
« Last Edit: August 26, 2007, 08:19:27 pm by Matt »

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: No audio
« Reply #3 on: August 27, 2007, 11:06:19 am »
Well, possible you don't install it. Try apt-get install alsaconf. Check also the rest commands: alsamixer and asound version. Also, it seems that you run aplay -L not aplay -l :)
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Matt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No audio
« Reply #4 on: August 27, 2007, 09:50:07 pm »
I have just rerun all the commands the results are as follows:

aplay -l
Quote
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 2: Intel ICH - IEC958 [NVidia CK804 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

apt-get install alsaconf
Quote
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package alsaconf
I ran apt-get update and repeated the install request and the result was the same

alsactrl store
Quote
bash: alsactrl: command not found

cat /proc/asound/version
Quote
Advanced Linux Sound Architecture Driver Version 1.0.14rc1 (Tue Jan 09 09:56:17 2007 UTC).

fins

  • Making baby steps
  • Posts: 2
    • View Profile
Re: No audio
« Reply #5 on: August 28, 2007, 12:38:36 pm »
Hi!
I'm sitting with the same problem.
I Have a Gigabyte GA-K8NE card with Realtec ALC850 Chip. After trying the solution stated here, It stil didnt give out any sound. Then I installed Linux drivers from Realtec, and sound worked in KUBUNTU/KDE playing DVD and giving sound throu SPDIF, but I cant get it to work in MCE, there I get no sound. The Drivers are ALSA drivers.
All the commands worked after I installed the new drivers.

I hope we can find a solution for this problem.

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: No audio
« Reply #6 on: August 28, 2007, 02:34:26 pm »
I had the same problem, rectified it (in earlier thread) by disabling onboard sound in my bios.

For some reason LMCE was defaulting to using the onboard sound rather than my soundcard, resulting in no sound in LMCE but sound in Kubuntu.

Hit delete on system boot to enter bios, find something that mentions 'Audio' and change it from 'Auto' to 'Disabled'
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

fins

  • Making baby steps
  • Posts: 2
    • View Profile
Re: No audio
« Reply #7 on: August 28, 2007, 04:22:52 pm »
Hi! The thing is, we want to use the onboard sound card, and we don't have any external/PCI sound card...

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: No audio
« Reply #8 on: August 29, 2007, 02:15:45 pm »
Try seeing if your card comes up if you type

sudo asoundconf list

If so, put this in

sudo asoundconf set-default-card yourcard

(where yourcard is the name of the onboard sound that came up under asoundconf list)
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Matt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No audio
« Reply #9 on: August 30, 2007, 08:31:55 pm »
the result of asoundconf list is as follows
Quote
Names of available sound cards:
CK804

when I run the command sudo asoundconf set-default-card CK804 it didn't show any errors so I assume there wasn't one however there is still no sound

Pastor

  • Veteran
  • ***
  • Posts: 58
    • View Profile
Re: No audio
« Reply #10 on: September 02, 2007, 02:40:39 am »
Hi Mat

I am having the same problem as you no sound on my CK804 onboard sound card. I have checked everything, I get a PCM indicator on my receiver but no sound. Did you have any luck fixing the problem?

Thanks

Paul

Matt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No audio
« Reply #11 on: September 02, 2007, 03:25:18 am »
No unfortunately I haven't, I don't have the knowledge to do all that much without a lot of help. I think I might download and install Kubuntu and see if it has the same problems.

madmick

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No audio
« Reply #12 on: September 02, 2007, 03:09:21 pm »
the reason is that this onboard chipset was not supported in linuxmce.
only the normal output should work, but no spdif or coaxial will work.
dont ask me why. i found it somewhere in the forum (developers i think).
i bought a new soundcard, disabled the one oneboard and the problem
was fixed (sound comes now through spdif ).

Matt

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: No audio
« Reply #13 on: September 03, 2007, 02:57:19 pm »
I am trying to use the normal sound output, although I am beginning to think that it might be easier just to buy a new sound card even though its going to have to be a cheapy

geirhoe

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: No audio
« Reply #14 on: September 12, 2007, 08:46:28 pm »
I have managed to get audio out from the optical output  on my onboard CK804 (nvidia) soundcard using aplay and mpeg123. There is, however, no sound from linuxMCE (playing dvd or using the setup wizards).

What I did was (on the MD):

sudo alsactl store

sudo vi /var/lib/alsa/asound.state

<edit control.35 so that the value is 0, not 3 as it is by default>

<save file>

sudo  alsactl restore

If you get an error with " ... Cannot write control  ..." it means that you have software using alsa running. Stop the MD software, and retry the last command.

Test the result using aplay (installed) or mpeg123 (found on the internet).


So, What do I need to do to get linuxMCE to use my working optical output ?