Author Topic: wiimote almost sorted!  (Read 10987 times)

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: wiimote almost sorted!
« Reply #30 on: October 09, 2007, 11:00:10 am »
Yes, sorry,

You can enter jobs to run at specific times in the crontab file (eg, you can run a command every hour or once a day or on every boot automatically (as the '@reboot' bit of my comand)) (http://ubuntuforums.org/showthread.php?t=102626 for examples)

it is a root job list, so I asume all commands are run as root anyway.

edit the file by:

sudo crontab -e

Specifying the locations of wminput and ir_ptr is probably overkill, but just wanted to make sure they were found (since kde isn't actually running while this command is run)

I have other commands running fine in crontab, like my lcdproc server and clients to display on a vfd screen.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: wiimote almost sorted!
« Reply #31 on: November 01, 2007, 02:49:18 pm »
After another long atempt at trying to get the ir and configured buttons to work on boot (and failing) I am starting to think that the xorg.conf (where the wiimote is listed as a input device - required for ir and configured button use) is being ignored by LMCE.

I did wonder as I have been trying to change my screen resolution via the xorg.conf file, with 0 effect.

Does anybody know whether LMCE does in fact ignore xorg.conf and read it's own version of xorg??
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
"Change is inevitable. Progress is optional."
-- Anonymous


gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: wiimote almost sorted!
« Reply #33 on: November 07, 2007, 11:35:09 am »
Cheers Zaerc,
Thought it could have been the answer, but unfortunately did nothing for the wiimote.

Not giving up though  :)
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Ngiri

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: wiimote almost sorted!
« Reply #34 on: November 13, 2007, 10:51:00 pm »
Hi, just thought I'd let everyone know that following the steps in this thread worked nicely for me to get the wiimote functioning and recognized easily on reboot.  Thanks for all the info.

I have to agree that using it isn't as nice as it could be.  Scrolling is nearly impossible.  Also, I seemed to burn through batteries within about 24 hours a set.  Like it keeps the connection live all the time.  I picked up a rechargeable battery pack and charger combo so that shouldn't be so bad now.

Keep up the good work.  If MCE would just included the ability to use the wiimote it would be a very nice "selling" feature.  Of course the average end-user might be at a loss about the whole sensor bar thing too.


gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: wiimote almost sorted!
« Reply #35 on: November 15, 2007, 02:26:30 pm »
Hi, just thought I'd let everyone know that following the steps in this thread worked nicely for me to get the wiimote functioning and recognized easily on reboot. 

Did you manage to get the ir sensing function working on boot?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Ngiri

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: wiimote almost sorted!
« Reply #36 on: November 19, 2007, 06:58:09 pm »
Yes I did.  I set up the cron settings outlined above and used the command line above for running the ir version in daemon mode (launched at boot).

If you'd like me to look up any of the specific settings I will.

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: wiimote almost sorted!
« Reply #37 on: November 19, 2007, 07:19:46 pm »
Hmmm,
I was begining to wonder whether the problem was that the cronjob was starting up before xorg.conf was read (if I enter kde and connect the wiimote the ir function still does not work)

Exactly what do you have in your crontab file?
And also, have you edited any settings in LMCE to do with display / mice / keyboards (apart from during the A/V wizard)?

Cheers
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Ngiri

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: wiimote almost sorted!
« Reply #38 on: November 20, 2007, 09:43:13 pm »
I know I made some changes to the Xorg.conf for the wiimote.  I don't think I made any others.

I can look up cron settings when I get home.

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: wiimote almost sorted!
« Reply #39 on: November 21, 2007, 09:17:55 pm »
Were your xorg changes different to that described in the cwiid howto?

Cheers ngiri
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Ngiri

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: wiimote almost sorted!
« Reply #40 on: November 21, 2007, 10:49:50 pm »
It's been some time, but I don't think they were.

I have a couple wiimotes and apparently I switched them so I've just updated the cron job with the address of the one I'm using and I'm checking to see if it's still working.

Ngiri

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: wiimote almost sorted!
« Reply #41 on: November 21, 2007, 11:18:32 pm »
The behavior I'm seeing is that although I just hit 1+2 on the wiimote to have it connect, the ir doesn't seem to be working.  I swear it was working before...  Did I confuse manually starting it with the boot connect?  I think I might have.