Author Topic: No live TV with PVR-500  (Read 1177 times)

rafin

  • First post!
  • Posts: 1
    • View Profile
No live TV with PVR-500
« on: September 06, 2007, 11:29:08 pm »
Hello,

Just installed LinuxMCE but I can't get liveTV to work. MythTV keeps telling me that all available inputs are already in use. It says literally: "MythTV is already using all available inputs for the channel you are using". Also in the system status it says the tuners are not available.

A couple of days ago I found that using normal Ubuntu and MythTV I had to set the PCI latency timers for the PVR-500 as it will not work with a latency timer setting higher than 32.
So I set the latency timer using "setpci -v -s 03:08.1 latency_timer=20" (20 is hex for 32) in /etc/rc.local. After that Ubuntu and MythTV worked. I tried the same in LinuxMCE but it does not work. I gues the rc.local is not executed by LinuxMCE. Can anyone tell me how to get these command executed during boot time in LinuxMCE?

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: No live TV with PVR-500
« Reply #1 on: September 06, 2007, 11:31:48 pm »
I'm using a PVR-500 with LMCE.  For some reason, by default it sets my two tuners up as capture31 and capture31 (or something very close).  I set them back to capture0 and capture1 in the MythTV setup and it started working.   I'd start there.


dopey

  • Guru
  • ****
  • Posts: 222
    • View Profile
Re: No live TV with PVR-500
« Reply #2 on: September 07, 2007, 05:11:29 am »
By default rc.local is not executed at startup. All you have to do is add a symlink in /etc/rc2.d/ to point to /etc/init.d/rc.local. Make sure it starts with an S and has a number prior to myth starting up. Personally, I named it S19rc.local. But that's because I mount some shares in rc.local and I want to be sure everything that uses them isn't started up until rc.local is started.

In short executing the following command will get rc.local to start at boot.
Code: [Select]
ln -s /etc/init.d/rc.local /etc/rc2.d/S19rc.local

themlruts

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: No live TV with PVR-500
« Reply #3 on: September 23, 2007, 07:18:30 pm »
By default rc.local is not executed at startup. All you have to do is add a symlink in /etc/rc2.d/ to point to /etc/init.d/rc.local. Make sure it starts with an S and has a number prior to myth starting up. Personally, I named it S19rc.local. But that's because I mount some shares in rc.local and I want to be sure everything that uses them isn't started up until rc.local is started.

In short executing the following command will get rc.local to start at boot.
Code: [Select]
ln -s /etc/init.d/rc.local /etc/rc2.d/S19rc.local

How do acutally do this.  I am new i need some step by step directions if possible
Thanks
Mike