Author Topic: LIRC - mceusb2 transmitter issues  (Read 2067 times)

miskaone

  • Newbie
  • *
  • Posts: 7
    • View Profile
LIRC - mceusb2 transmitter issues
« on: September 06, 2007, 03:06:34 am »
I have a HP Z552 that uses the Philip's ehome IR chips. I have the RC6 remote functional and the transmitter is transmitting. I do not believe its sending the right codes. The receiver is a Motorola DCT700 cable box. Any suggestions on how to change the default lirc.conf for the transmitter to correct codes?

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: LIRC - mceusb2 transmitter issues
« Reply #1 on: January 15, 2009, 05:09:08 am »
Did you get anywhere with this?

I got a USB-UIRT and have been trying to get it setup.  I was messing around with the device templates and am pretty sure that I selected "Add device template" listed underneath the "Your model is not in the list? **"

To get the Motorola codes to work, I had to select "Motorola" from the "Manufacturer" list (code 168 appears to the right after selecting)
And, I needed to select "Cable Box < AV" from the "Device Category" list (code 105)

This worked the first time (didn't know it at the time so I messed things up from there) but when I initially had it, when I tested the codes they worked.  (BTW I too have a DCT700 and I used the first of the 3 options- can't seem to get back to it at this point).


So after it worked, I broke it...  I tried following this:  http://wiki.linuxmce.org/index.php/Add_support_for_new_remote_controls#Sample_USB_UIRT_key_codes
but that way is fairly frustrating as that you have to individually press the buttons and create a log file...   cry me a river, right?

So now I'm trying to get back to the original settings.  My USB UIRT 0038 is device 75 and the USB UIRT Embedded Transmit is device 76.  The codes are being transmitted to device 76 which intuitively makes sense, but in reality doesn't work.  Before someone suggests Seth's USB UIRT x86 Fix, it was working when I first got it installed and I didn't need to run that fix.

jimmejames

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: LIRC - mceusb2 transmitter issues
« Reply #2 on: January 24, 2009, 06:17:57 am »
OK-

I got the codes entered-
http://wiki.linuxmce.com/index.php/DCT_700

I can't help but think there is a better way.  Going from Advanced -> Configuration -> Device Templates
I can add "Motorola" as the Manufacturer and "Cable Boxes < AV" as the Device Category.  Then, when I hit "Add device template" and go thru the motions I am able to test the codes and everything works.  That is to say that all I had to do was plug in the USB-UIRT, select the above and test the codes.

Now, where do I go from here?  There are a lot of posts about the USB-UIRT and LIRC, but nothing clear on how once you have the device listed under "A/V Equipment" under "Devices" to get LMCE to use this.

Any ideas?

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: LIRC - mceusb2 transmitter issues
« Reply #3 on: January 24, 2009, 08:55:40 am »
Rerun the avwizard and select the new device and assign the connections



HTH

Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/