Author Topic: Leadtek DTV1000T in MythTV/LMC Problem  (Read 1439 times)

Minotaur

  • Newbie
  • *
  • Posts: 6
    • View Profile
Leadtek DTV1000T in MythTV/LMC Problem
« on: August 17, 2007, 07:03:34 pm »
Howdy
I simply cannot get my DTV1000T card set up properly within MythTV, NOTHING I try works. Can someone please provide a step-by-step guide for what I need to do to get this card working?

I also have a DVICO FusionHDTV-DVBT card which I could put in instead if you think this card would work better.
Thanks.

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Re: Leadtek DTV1000T in MythTV/LMC Problem
« Reply #1 on: August 28, 2007, 06:02:03 am »
Hi,

I set one up last night, so I'll try and help.

Looking through dmesg it looked like it was already detected correctly and loaded module cx88.
See if yours has done the same;
dmesg | grep -i winfast I think
lsmod | grep -i winfast Again, I think from memory

You should get matches for both

I did not have the DVB devices that I expected though (which I discovered from mythtv-setup recognising there was a card there but not able to connect)

Bit of a google suggested loading the modules cx8802, cx88_blackbird(i think) and cx_dvb

modprobe cx8802Seemed to work fine
cx88_blackbirdGave me a module not found - I ignored at this stage
cx_dvbSeemed to work fine

With these modules loaded everything looked a bit better and I had DVB devices and mythtv-setup was happy with the card and scanned for channels OK - so I have not worried about the module not found.

google "winfast DTV1000T linux" for more. There was plenty of info on it.

HTH
Darren

ozmule

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Leadtek DTV1000T in MythTV/LMC Problem
« Reply #2 on: September 30, 2007, 01:05:56 am »
Excellent info provided here Darren, but as a complete newbie, I need some additional help to load the modules you describe. I have EPG data loaded etc, but cannot get a picture with channel scan.

I used the following to get things going http://wiki.linuxmce.org/index.php/Information_for_australian_users

dmesg | grep -i winfast ..... worked and I got a response
lsmod | grep -i winfast ..... did not work (or I got no reply response)

I have read some many posts on various forums that I guess I cannot see the forest for the trees now.

I have spent many hours reading and doing various google's but just can't seem to get this card working. I did for info have it working under XP before (dual boot on this pc).

Can anyone out there provide some simple steps for me to try and report back with?

Regards,

Oz

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4450
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Leadtek DTV1000T in MythTV/LMC Problem
« Reply #3 on: September 30, 2007, 03:04:16 am »
Howdy
I simply cannot get my DTV1000T card set up properly within MythTV, NOTHING I try works. Can someone please provide a step-by-step guide for what I need to do to get this card working?

I also have a DVICO FusionHDTV-DVBT card which I could put in instead if you think this card would work better.
Thanks.

I think the modules you need to make sure are loaded are;

cx88-dvb
dvb-core
cx88-alsa

Do an lsmod to see if there loaded

dvb-core should be loaded already.

Test these as follows;

sudo modprobe cx88-dvb
sudo modprobe cx88-alsa

If you get no errors then add them to /etc/modules and reboot.

Then do to see if your card is now starting up ok.

sudo dmesg | grep DVB

and you see messages about the card being detected and setup etc. It appears that no firmware is needed for this card so that should do it.

Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

ozmule

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Leadtek DTV1000T in MythTV/LMC Problem
« Reply #4 on: September 30, 2007, 04:25:31 am »
Thanks for your reply. I have some more information now.

sudo dmesg | grep DVB

[   56.031255] DVB: registering new adapter (cx88[0]).
[   56.031269] DVB: registering frontend 0 (Conexant CX22702 DVB-T)...

The card works within Kaffeine but not within MythTv ....

lsmod | grep cx
cx88_alsa              13192  0
cx22702                 6404  1
cx88_dvb               15748  5
cx88_vp3054_i2c         4352  1 cx88_dvb
dvb_pll                14468  2 cx88_dvb
video_buf_dvb           6788  1 cx88_dvb
snd_pcm                76680  5 cx88_alsa,snd_emu10k1,snd_ac97_codec,snd_pcm_oss
cx8800                 34060  0
cx8802                 17924  1 cx88_dvb
cx88xx                 66212  4 cx88_alsa,cx88_dvb,cx8800,cx8802
ir_common              30340  1 cx88xx
i2c_algo_bit            7816  2 cx88_vp3054_i2c,cx88xx
tveeprom               14992  1 cx88xx
i2c_core               21648  9 i2c_ec,cx22702,cx88_dvb,cx88_vp3054_i2c,dvb_pll,cx88xx,i2c_algo_bit,tveeprom,nvidia
video_buf              25348  6 cx88_alsa,cx88_dvb,video_buf_dvb,cx8800,cx8802,cx88xx
snd                    51716  21 cx88_alsa,snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_ac97_codec,snd_hwdep,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
compat_ioctl32          1408  1 cx8800
btcx_risc               5000  4 cx88_alsa,cx8800,cx8802,cx88xx
videodev               27136  2 cx8800,cx88xx
v4l2_common            24192  2 cx8800,videodev
v4l1_compat            14340  2 cx8800,videodev

Any further ideas? Appreciate your help.

Oz

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4450
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Leadtek DTV1000T in MythTV/LMC Problem
« Reply #5 on: September 30, 2007, 07:10:26 am »
Thanks for your reply. I have some more information now.

sudo dmesg | grep DVB

[   56.031255] DVB: registering new adapter (cx88[0]).
[   56.031269] DVB: registering frontend 0 (Conexant CX22702 DVB-T)...

The card works within Kaffeine but not within MythTv ....

lsmod | grep cx
cx88_alsa              13192  0
cx22702                 6404  1
cx88_dvb               15748  5
cx88_vp3054_i2c         4352  1 cx88_dvb
dvb_pll                14468  2 cx88_dvb
video_buf_dvb           6788  1 cx88_dvb
snd_pcm                76680  5 cx88_alsa,snd_emu10k1,snd_ac97_codec,snd_pcm_oss
cx8800                 34060  0
cx8802                 17924  1 cx88_dvb
cx88xx                 66212  4 cx88_alsa,cx88_dvb,cx8800,cx8802
ir_common              30340  1 cx88xx
i2c_algo_bit            7816  2 cx88_vp3054_i2c,cx88xx
tveeprom               14992  1 cx88xx
i2c_core               21648  9 i2c_ec,cx22702,cx88_dvb,cx88_vp3054_i2c,dvb_pll,cx88xx,i2c_algo_bit,tveeprom,nvidia
video_buf              25348  6 cx88_alsa,cx88_dvb,video_buf_dvb,cx8800,cx8802,cx88xx
snd                    51716  21 cx88_alsa,snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_ac97_codec,snd_hwdep,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
compat_ioctl32          1408  1 cx8800
btcx_risc               5000  4 cx88_alsa,cx8800,cx8802,cx88xx
videodev               27136  2 cx8800,cx88xx
v4l2_common            24192  2 cx8800,videodev
v4l1_compat            14340  2 cx8800,videodev

Any further ideas? Appreciate your help.

Oz

I'm not a MythTV user so this is a little outside my experience... but if the card is working (dmesg output indicates all is ok) and kaffeine can display a video stream from it then the problem has to be in Myth's setup.

This page on the Wiki looks like it should provide the info you need about the setup inside Myth;

http://wiki.linuxmce.org/index.php/Leadtek_DTV1000T

Hope this gets things working for you :-)
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk