Author Topic: TV keeps crashing!  (Read 9843 times)

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #30 on: September 28, 2007, 11:45:09 pm »
Ok that is interesting totallymaxed. Could be the difference between your systems and mine. Dont suppose you can provide a link to download that version of the firmware can ly seem to find the 0700-03-pref1 version.

Regards

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: TV keeps crashing!
« Reply #31 on: September 29, 2007, 11:14:27 am »
Ok that is interesting totallymaxed. Could be the difference between your systems and mine. Dont suppose you can provide a link to download that version of the firmware can ly seem to find the 0700-03-pref1 version.

Regards

Hi there. I have attached the dvb-usb-dib0700-01.fw file to this post

Hope it helps fix your problems :-)

Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: TV keeps crashing!
« Reply #32 on: September 29, 2007, 11:46:46 am »
Myth Tv works fine for me outside LMCE! And, for that I agree that it must be a myth/LMCE integration fault. I was just wondering whether LMCE disliked the T-500 card since it is not plug and play, but since totallymaxed doesn't have this problem, then I'm sure the card is fine.

One question though, how did you install the drivers for your T-500??
I followed the howto here ->
http://www.mythtv.org/wiki/index.php/Hauppauge_WinTV_Nova-T_500_PCI
Similar to your installation??

The problem has nothing to do with the TV card that you are using in fact but is related to the remote control of Myth by lmce. The version of Myth currently integrated into lmce seems to have some bugs in that area. Hopefully they will get fixed in the next update :-)
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #33 on: September 29, 2007, 12:53:32 pm »
Hi totallymaxed.

If that is the case then how come it works fine on the media direcotrs? Also how come it is working ok for you?

Also I have downloaded and installed that firmware however it does not seem to pick up and channels when I scan. I have tried both mythtv and kaffeine.
I have added the force_lna_activation option in /etc/modprobe.d/options
Any ideas?

Regards

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: TV keeps crashing!
« Reply #34 on: September 29, 2007, 02:43:47 pm »
Hi totallymaxed.

If that is the case then how come it works fine on the media direcotrs? Also how come it is working ok for you?

Also I have downloaded and installed that firmware however it does not seem to pick up and channels when I scan. I have tried both mythtv and kaffeine.
I have added the force_lna_activation option in /etc/modprobe.d/options
Any ideas?

Regards

Hi Fibres,

Well my information is that the remote control protocol in Myth is where the problem is... however we dont use Myth so I am not personally able to verify this. We are using vdr in our installations and we don't see that problem at all.

As to why your T500 is not tuning I am not sure. Are you using the standard modules that were shipped with Kubuntu or are you using modules built by you? That could be the difference as we are using the standard modules shipped with kubuntu. It's working for us in numerous Core's so i know that the firmware I attached is good.

Do:

sudo dmesg | grep dvb

and post the output here.

You should see your T500 get initialised and your firmware get loaded etc. If you do then you have a working T500... then it comes down to possibly signal quality/strength (but if it was working before you swapped to the newer firmware then my guess is that you are not using Modules that are not compatible with the newer firmware in some way)
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

John@TunerUK

  • Regular Poster
  • **
  • Posts: 37
    • View Profile
Re: TV keeps crashing!
« Reply #35 on: September 29, 2007, 07:24:18 pm »
The tuning problem you're having sounds exactly the same one that I had when I first installed the Nova T 500. I couldn't get it to tune at all, dispite showing signal strength well into 80%. Once I followed that wiki page however everything worked as expected.
I am experiencing a MythTV problem however, in that I can open it, and it'll work fine, but I then can't leave MythTV and view a video. They all show up as a garbled mess regardless of the prog I use to view; audio however is fine. Linux mce, Xine, even MythTV stops working from that point.
Warning, total Linux NooB, but willing to learn!

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: TV keeps crashing!
« Reply #36 on: September 29, 2007, 08:05:10 pm »
The tuning problem you're having sounds exactly the same one that I had when I first installed the Nova T 500. I couldn't get it to tune at all, dispite showing signal strength well into 80%. Once I followed that wiki page however everything worked as expected.
I am experiencing a MythTV problem however, in that I can open it, and it'll work fine, but I then can't leave MythTV and view a video. They all show up as a garbled mess regardless of the prog I use to view; audio however is fine. Linux mce, Xine, even MythTV stops working from that point.

I think the problem that Fibres has is that he is not using the current builds of the modules needed for the T500 when using the firmware I posted - that firmware works with the standard required T500 module support built into Kubuntu 7.04 'out of the box'. However as with any firmware update you do need to power-off and boot up to force the firmware to do a 'cold start' and load properly.

As to your problem I'm afraid I can't offer any insight into that.
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #37 on: October 01, 2007, 02:31:52 am »
Hi totallymaxed.

Not had chace to play with it this weekend so dont know the problem yet. Im interested to know how you got vdr working? I have looked into this before and was under the impression that it did not work in linuxmce.

Any guide/info on seting that up would great.

Regards

Bas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: TV keeps crashing!
« Reply #38 on: October 01, 2007, 09:55:50 am »
Hi, I also have the same kind of problem. Myth crashes after 1 minute to 20 minutes of watching TV (hanging image), and sometimes does not even have sound. :| I'm using an analog tuner (PVR-500), and a 7200 graphics card. In KDE the frontend runs perfectly. :|

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: TV keeps crashing!
« Reply #39 on: October 01, 2007, 10:28:05 am »
Hi totallymaxed.

Not had chace to play with it this weekend so dont know the problem yet. Im interested to know how you got vdr working? I have looked into this before and was under the impression that it did not work in linuxmce.

Any guide/info on seting that up would great.

Regards

Hi again,

We're working on integrating VDR into lmce for a product/service that we are planning for the UK market. Currently we have hacked some old code from the Pluto builds. This is working but is still under heavy development. VDR works fine and is rock solid but the code that was written to integrate into Pluto's UI and DCErouter etc is not stable or complete. Our plan is to release this back to lmce so it can be a standard component and an alternative to Myth.

Our lmce based product/service is aimed at the broad non-technical user. and the hardware will be installed/maintained on full commercial basis. But we plan to make all our open source code available to the community here. The main elements that will not be available here will be service & UI related mostly and do not build off any lmce code or indeed any open source code in anyway. But the integration with lmce will be complete in every other way and the sources will be there for people.

Regards

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: TV keeps crashing!
« Reply #40 on: October 02, 2007, 08:55:57 am »
Hi Andrew,

Nice to see that VDR integration is going to be implemented! Did you try to involve German VDR folks - http://www.vdr-portal.de/board/thread.php?threadid=32551&page=14. It'd be good to involve them since they like VDR and want to integrate it into LMCE>
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: TV keeps crashing!
« Reply #41 on: October 02, 2007, 10:24:44 am »
Hi Andrew,

Nice to see that VDR integration is going to be implemented! Did you try to involve German VDR folks - http://www.vdr-portal.de/board/thread.php?threadid=32551&page=14. It'd be good to involve them since they like VDR and want to integrate it into LMCE>

Our main developer is based in Germany and has worked in and around the vdr community there for several years and we have had some contact with them.
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

marv2097

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
    • Reesmarine
Re: TV keeps crashing!
« Reply #42 on: October 10, 2007, 11:25:23 am »
Hi all,

Did anyone find what was causing this problem and is there a way to fix it apart from rewinding at the start of the program?
Hybrid: Shuttle P4 3Ghz - 1GB DDR RAM - 750 GB PATA HD - Nvida 7300 GT AGP (UI2alpha) - 1 NIC

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: TV keeps crashing!
« Reply #43 on: October 10, 2007, 12:30:22 pm »
Nope, none here.

Also, I have the same problem with failing to find channels using the posted firmware. I am using the kubuntu modules for the card, in fact all I did from a fresh install was to add the firmware to /lib/firmware, added options dvb-usb-dib0700 force_lna_activation=1 to /etc/modprobe.d/options and modprobed.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

nosilla99

  • Veteran
  • ***
  • Posts: 120
    • View Profile
Re: TV keeps crashing!
« Reply #44 on: October 10, 2007, 08:52:20 pm »
Same problem with mythtv frontend crashing when watching live TV within LMCE, using HVR-1300 DVB-T card. Top does not show any issues with CPU utilisation.

Had previously been running mythtv on plutohome without any problems.

NOS