Author Topic: TV keeps crashing!  (Read 9719 times)

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
TV keeps crashing!
« on: August 29, 2007, 09:58:22 am »
Everytime I watch TV on LMCE it crashes after a minute or so - it's completely unwatchable! I have to then select 'OFF' from the current media menu to exit.

I have an LCD screen on my case that displays info from mythtv. When I enter TV mode on LMCE, the LCD screen displays the channel and program name, but also has a bar of blocks and I'm not sure what these relate to.

Anyway, when the TV freezes this bar of blocks disappears slowly block by block. Does anyone know what this means??

It's like something is being lost, I thought it may have been signal, but could be a frame buffer that never recovers???

My card is a hauppauge hvr-1100 and only have DVB part of it set up in mythtv (as I have no need for terrestrial). It doesn't have a hardware decoder, which makes me wonder if my cpu/graphics card is struggling to do the decoding??

I don't think my setup is too slow though, I have a athlon x2 4200+ cpu, a gig of ram and a nvidia 7300gt graphics card.

Has anyone else had similar problems? Or know of any way that may resolve this? (maybe in the mythtv configuration?)

Cheers in advance

Searched google for this; seems that the bar on the lcd display is an indicator of how far behind the live broadcast you are. So, since it reduces when my TV crashes my frontend must still be alive, or not completely dead!
« Last Edit: August 29, 2007, 02:21:45 pm by gazlang »
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

savvycenter

  • Regular Poster
  • **
  • Posts: 21
    • View Profile
Re: TV keeps crashing!
« Reply #1 on: August 29, 2007, 07:30:26 pm »
I've similar problem. It sometimes crashes every minute or so and sometimes takes 15 minutes to crash. I'm using nvidia 7050 and homerun capture card. Still couldn't find a solution for it.

Anyone can help us?

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #2 on: August 29, 2007, 08:55:21 pm »
I am experiencing similar problems. It seems to be the front end causing the problem as recordings seem to still run when it crashes. Strangely watching rcordings does not seem to cause the same problem.

Regards

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: TV keeps crashing!
« Reply #3 on: August 29, 2007, 10:01:19 pm »
I read that dvb-t is broadcast in mpeg-2 format and doesn't need decoding. If this is right, I can't see why my computer is having such a hard time playing TV, yet it plays dvd's perfectly.

Anyway, I think a good place to start is the mythtv logs; so, where can I find the mythtv logs?

Perhaps they will give some information about signal or hardware crashes etc???
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: TV keeps crashing!
« Reply #4 on: August 29, 2007, 10:20:43 pm »
Most (if not all) system logs are usually somwhere under /var/log. I'm not sure whether there was a seperate /var/log/mythtv but there is definately a /var/log/pluto, anyway this should find anything with "myth" in the name for you:
Code: [Select]
find /var/log -iname \*myth\*
"Change is inevitable. Progress is optional."
-- Anonymous


gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: TV keeps crashing!
« Reply #5 on: August 30, 2007, 09:06:56 am »
Cheers zaerc, I'm going to have a look at this later.

I found this useful page

http://www.ethics-gradient.net/myth/mythdvb2.html

Close to the bottom details error identification using mythtv logs

Also, it's probably a good idea to run sudo top while mythtv is running to check out cpu and memory use during TV streaming.

I'll let you know how I get on
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: TV keeps crashing!
« Reply #6 on: August 31, 2007, 08:59:54 am »
Well, I tried running myth in kubuntu and the tv runs much better! Never crashes (watched tv all night), although I do get the odd audio pop and screen flicker. Switched back to TV in LMCE and within seconds the screen froze!

This makes me think that either some part of my hardware isn't up to scratch, or the mythtv integration with LMCE isn't very good! I have the ui2 w/ alpha blending interface, but how much more pressure does that put on hardware when the tv is playing? I wouldn't have thought there would be any difference running myth in KDE to running in LMCE (especially since I didn't completely close LMCE while running myth in KDE, it was just minimised)

If my hardware is the problem, what component is the most likely to be letting me down? Or how do I test this?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

lou__reed

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: TV keeps crashing!
« Reply #7 on: September 11, 2007, 03:23:20 am »
I´ve got the same problem... I`m using nova-t usb stick and it worked great before in mythtv. The work around i´m using now in mce is to rewind 5 seconds in to the TV program... and it stays stable...

greatful for a solution for this!

/johan

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: TV keeps crashing!
« Reply #8 on: September 11, 2007, 04:57:08 am »
I read that dvb-t is broadcast in mpeg-2 format and doesn't need decoding. If this is right, I can't see why my computer is having such a hard time playing TV, yet it plays dvd's perfectly.

Anyway, I think a good place to start is the mythtv logs; so, where can I find the mythtv logs?

Perhaps they will give some information about signal or hardware crashes etc???

gazlang - not much help with your issue, but just for clarity .... dvb-t certainly is an mpeg2 transport stream (meaning simple mpeg2 compression which is then encapsulated with some extra headers and multiplexed with the audio, etc which allow it to be transmitted with additional information for TV). But mpeg, like all compression standards, is by definition "encoded". Encoding is when you take a video (and audio) stream and process the data, usually to compress it. Examples would be capturing a video stream from an analogue TV transmission and encoding it into mpeg2, or wmv, etc. Or taking an uncompressed, "raw" digital video stream/file, and encoding it into a compressed format like mpeg2, wmv, etc.

Decoding is the exact opposite - taking an encoded source like the above, and converting it back into an unencoded (usually uncompressed) format. All encoded sources need to have this done before they can be played. So sources such as dvb-t and DVD must be decoded before you can play them. Encoding is the one which requires the real grunt and obviously benefits most from having a hardware encoder, but having a hardware decoder isn't bad either, its just that any reasonably recent PC should be able to decode in software without any difficulty, even HD streams.

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #9 on: September 13, 2007, 01:46:21 am »
Hi I am also experiencing this problem. Has anyone found a solution yet?
I can also run mythfrontend from the kde desktop with lmce running in background and everything is ok.

I have done some digging and found the following.
I have ssh'd into the Hybrid im having problems with and run top while starting mythtv from the orbiter. Mythfrontend.real shows as top and used about 18% cpu whilst running properly. When TV freezes it disappears from the top list but when I check in ps -ax |grep myth it still shows as running.
I am assuming that this is a problem with the wrapper also. Can someone give some pointers on this.


Regards

lou__reed

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: TV keeps crashing!
« Reply #10 on: September 15, 2007, 12:01:55 am »
I´ve found a solution .... but don´t now how....

I Changed a lot of things in mythTV setting, backend and frontend. I will try to find out later what exactly fixed the problem...

/johan

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: TV keeps crashing!
« Reply #11 on: September 15, 2007, 11:35:29 am »
Cheers lou_reed,
would be great if you could find that out!
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #12 on: September 17, 2007, 12:43:18 am »
I have found something interesting with this.

I have installed a media director onto my core and have found that this issue only seems to be affecting the core and not the media director.

I am having problems with jitters video on the remote frontend but nothing related to crashing was watching it for a while last night and no crash at all.

Regards

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: TV keeps crashing!
« Reply #13 on: September 18, 2007, 11:07:53 am »
I tried LMCE on a different system; hardly minimum spec:

athlon x2 5600+ am2
asus M2N-SLI Deluxe
1GB Corsair XMS 800Mhz DDR2
GeForce 7300gt 256mb
Hauppauge Nova-t 500
Samsung SataII 400gb HDD

Still same issue with TV crashing in LMCE. Fine in kubuntu! And dvd's work flawlessly too!
Maybe something to do with LMCE's media wrapper (TV guide etc..)??

Is there a way to disable LMCE's fancy media TV guide (used with gyro mouse etc..)?
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

fibres

  • Guru
  • ****
  • Posts: 306
    • View Profile
    • LinuxMCE 08.10 RC Mirror.
Re: TV keeps crashing!
« Reply #14 on: September 18, 2007, 05:26:54 pm »
Not sure on disabling the wrapper. It seems to be something which is only happening on the hybrid core. As I seem to have it working fine on a second media director without the issues of it crashing all the time. Which is very strange indeed. I am running my Hybrid on a recommended spec using a Asus M2NPV-VM Mainboard with amd x2 processor. Again hardly minimum spec.

Regards