Author Topic: webadmin email setup?  (Read 1969 times)

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
webadmin email setup?
« on: June 08, 2010, 06:21:41 pm »
is it just me, or is the said entry in the webadmin really not working yet?
When I click it, I get his :
{ScriptTRColor}
   
   Not a valid section

los93sol

  • Guru
  • ****
  • Posts: 396
    • View Profile
Re: webadmin email setup?
« Reply #1 on: June 08, 2010, 06:25:54 pm »
Add the mailx device first

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: webadmin email setup?
« Reply #2 on: June 09, 2010, 05:31:13 pm »
okay...I had to search a little...finally found out how to add the mailx-device under interfaces...but now what? So far nothing has changed (did a reload router as requested...)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: webadmin email setup?
« Reply #3 on: June 09, 2010, 07:18:47 pm »
looks like a database entry needs to be added to PageSetup so that the web mail stuff only shows up when the mailx device is installed.

-Thom

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: webadmin email setup?
« Reply #4 on: June 10, 2010, 08:38:32 am »
hmmm....why not give the option to install the mailx device when you want to use the email setup instead?

and how to get on from here now? I installed the mailx-device, but I still cannot use the email-setup.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: webadmin email setup?
« Reply #5 on: June 10, 2010, 11:50:44 pm »
I cannot find the script Configure_Postfix_interactive.sh. Did I miss something?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: webadmin email setup?
« Reply #6 on: June 11, 2010, 07:57:59 am »
Michael,

there is no such script in SVN either.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: webadmin email setup?
« Reply #7 on: June 11, 2010, 08:55:40 am »
That's true. But That script is called from the admin page when email credentials are stored.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: webadmin email setup?
« Reply #8 on: June 11, 2010, 09:03:59 am »

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: webadmin email setup?
« Reply #9 on: June 11, 2010, 10:17:24 am »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: webadmin email setup?
« Reply #10 on: June 11, 2010, 01:43:49 pm »
okay, I admit, I don't get it....
obviously you can configure postfix to use the mailbox of your choice...but what is the mailx device for? Is there something missing in my system, or is it still considered as work in progress?

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: webadmin email setup?
« Reply #11 on: June 11, 2010, 02:36:33 pm »
okay, I admit, I don't get it....
obviously you can configure postfix to use the mailbox of your choice...but what is the mailx device for? Is there something missing in my system, or is it still considered as work in progress?

You need mailx device to use it in scenario. For example, when motion sensor is tripped sent email to specified address with desire subject and body. To be able to do that you should add manually mailx as a top level device to your core. I did that but my problem was with configuration of postfix because I suspected that it should be done using web admin. After fastie81's post the picture is clear for me. So, I just have to configure postfix using script or manually and email notification should work.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: webadmin email setup?
« Reply #12 on: June 11, 2010, 07:49:32 pm »
todays update fixed the webadmin so far...lets see whats what :-)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: webadmin email setup?
« Reply #13 on: June 12, 2010, 12:07:29 pm »
todays update fixed the webadmin so far...lets see whats what :-)

Nothing changed after update :( Anyway, I followed by instructions from the wiki. But have some problem with TLS:
Code: [Select]
TLS is required, but our TLS engine is unavailableAll packages are installed. So, I have no idea how to fix that.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: webadmin email setup?
« Reply #14 on: June 12, 2010, 09:24:10 pm »
after the said update the error I reported initially is gone now...I got the email-setup