Author Topic: Internal Network problem  (Read 1118 times)

pauld

  • Newbie
  • *
  • Posts: 7
    • View Profile
Internal Network problem
« on: August 14, 2007, 09:53:07 pm »
I have a problem with the network scanning of LMCE for some reason when scanning my internal network LMCE manages to kill the network connection on my Technomate 9100 satellite box. As soon as LMCE is running the network connection goes down.

Is there a way to stop LMCE from scanning a set network address?

Thanks

Paul

jimmah6786

  • Regular Poster
  • **
  • Posts: 17
    • View Profile
Re: Internal Network problem
« Reply #1 on: August 14, 2007, 09:54:02 pm »
Whats the network card make/model piz?

if onboard, what mobo you got?

pauld

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Internal Network problem
« Reply #2 on: August 14, 2007, 10:17:56 pm »
I am using the onboard lan of a MSI K8N Neo board. The board uses a nVIDIA nFORCE3 chipset.

Thanks

dopey

  • Guru
  • ****
  • Posts: 222
    • View Profile
Re: Internal Network problem
« Reply #3 on: August 15, 2007, 01:15:16 am »
It sounds like LinuxMCE is trying to take an IP address that's already in use. Have you verified the IP addresses in your network?

Also, it seems like you aren't setting this up to be your dhcp server (only one NIC). By default LinuxMCE is going to try to bring on the DHCP server and take over your network... that would fail if miserably if 192.168.*.1 (192.168.80.1 by default) is used and half work if there is another DHCP server on the network subnet (very bad). At that point it can assign an IP address to one device that another device is already using... effectively killing your network.

pauld

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Internal Network problem
« Reply #4 on: August 15, 2007, 08:16:10 am »
My network is set up like this.

Internal network uses the onboard lan with ip address as 192.168.0.1. I also have a Netgear lan card in the machine which is used for the outside network this uses the ip address 192.168.1.1 and connects directly to my router 192.168.1.254.

LMCE is my only DHCP device on my network & is set to give addresses for LMCE devices of 192.168.0.50 to 192.168.0.75 and for non LMCE devices 192.168.0.100 to 192.168.0.150. My Technomate satellite box has the ip address of 192.168.0.215.

Even if I turn off the both the DHCP servers for both LMCE devices and non LMCE devices I still get the same problem.

Paul

dopey

  • Guru
  • ****
  • Posts: 222
    • View Profile
Re: Internal Network problem
« Reply #5 on: August 19, 2007, 10:29:09 pm »
Hmm, that looks like it would work.

Try manually bringing down each interface:
Code: [Select]
ifdown eth0
ifdown eth1

Then bring them back up one at a time and ping a known address on that interface with:
Code: [Select]
ifup eth0 //or eth1
ping %known address%

If that succeded then next manually launch the filewall script:
Code: [Select]
/usr/pluto/bin/Network_Firewall.sh

That will let us know if the problem is with one particular interface/network driver or a problem with the firewall script.