Author Topic: Port Forwarding  (Read 1058 times)

hobbes487

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Port Forwarding
« on: September 25, 2007, 07:12:19 am »
Can someone please explain to me how to forward ports to other computers on my network?  I want to be able to access my NAS admin site from outside the network so I set it up to accept port 85.  I am able to access it by going to 192.168.80.235:85 so I know that part works.  Now I went to the firewall settings on the pluto admin site and did the following:

protocol: tcp
source port: 85 to 85
Destination port: 85
Destination IP: 192.168.80.235 (ip of NAS)
Rule Type: port_forward
Limit to IP: [blank]

With these settings I can't access the NAS from outside the network by going to www.myaddress.com:85.  I also tried reloading the router and that didn't work.

Any ideas?


PS:  I am also having trouble with the ports needed for torrentflux installed on the core, but I want to get the NAS ports working first.
« Last Edit: September 25, 2007, 07:16:08 am by hobbes487 »

jriofrio

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Port Forwarding
« Reply #1 on: September 28, 2007, 05:41:48 pm »
Hello hobbes487..

I just want to explain why it does not work the way you set it up...

You have a router at your home, which it has 2 connections, an internal with the 192.xxx.xxx.xxx that is your privite network address and an external IP address which i do not know.

Intenet<---public IP address--->router<-----private IP---->Home PC

Well, when you are outside of your network, you can not see the Private Network (because you use a NAT), the IP address you can see will be you outside IP address (which i will call it public). Only the public IP address is publish and therfore you can see it.

The private IP address is not publish, so you can not see it.

In order to access your router, you need to create A VPN (or telnet) to you Public IP address.

Read about  VPN (virtual private network) connection and you will know what to do.

Good luck
Juan

NOTE: IP address 192.168.xxx.xxx (among other ones) are not public, are reserve to be use for private networks.


colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Port Forwarding
« Reply #2 on: September 28, 2007, 05:50:07 pm »
You don't need a VPN, that's overkill. All you need to do is setup a double NAT (PAT actually) which is the port forwarding being talked about here.

Your Internet broadband router needs the first one forwarding the public IP address on port 85 to port 85 on the IP address of your LMCE external NIC. Then set up a second forward from Pluto to do the same again to the internal LAN - sounds like you have already done this. So you just need to make a 5 min change on your broadband router.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4413
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Port Forwarding
« Reply #3 on: September 28, 2007, 06:16:04 pm »
Can someone please explain to me how to forward ports to other computers on my network?  I want to be able to access my NAS admin site from outside the network so I set it up to accept port 85.  I am able to access it by going to 192.168.80.235:85 so I know that part works.  Now I went to the firewall settings on the pluto admin site and did the following:

protocol: tcp
source port: 85 to 85
Destination port: 85
Destination IP: 192.168.80.235 (ip of NAS)
Rule Type: port_forward
Limit to IP: [blank]

With these settings I can't access the NAS from outside the network by going to www.myaddress.com:85.  I also tried reloading the router and that didn't work.

Any ideas?


PS:  I am also having trouble with the ports needed for torrentflux installed on the core, but I want to get the NAS ports working first.


Hi the missing part is that you need to allow port 85 through the firewall on your externally facing router. That should do the trick.
« Last Edit: September 28, 2007, 06:25:02 pm by totallymaxed »
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

teedge77

  • Addicted
  • *
  • Posts: 591
    • View Profile
Re: Port Forwarding
« Reply #4 on: September 28, 2007, 06:21:15 pm »
its exactly like colin and totallymaxed said...it needs to go like this


www.myaddress.com goes to-->external wan ip on broadband router-->external ip on linuxmce-->internal ip on linuxmce-->ends at webadmin


make sure port 85 is open through your router and the linuxmce firewall if its on.

please correct me if this is wrong or doesnt display it accurately.
AMD Athlon 64 X2 6000+
Asus M2V Via AM2 ATX
Lite-On LH-20A1S SATA DVD Burner
80GB  SATA-150
EVGA GeForce 7300 GT 512MB DDR2 PCI Express
Sound Blaster Audigy SE
Kingston 2 GB PC6400 DDR2 800MHz
Ultra X-Finity 800-Watt
ZCU000
Cisco 7970
TDM400P