Author Topic: diskless media directors working as only mythtv frontends without being slave ba  (Read 1268 times)

deffcon

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Hello linuxmce users,

I have one core/hybrid in my livingroom, and two diskless mediadirectors with ui2, the only thing i really don't understand about this config is that the mythtv player and plugin of linuxmce are slave backends, so in other words the mythtv "players"are so configures they expect an tuner card in the diskless media directors. For me this really no option because i have al my two tuner cards  ( pvr-500 mce ) in my core machine in the livingroom, can i fix this the source package or do i have to wait when this "only"frontend end player of mythtv player becomes avaible for all linuxmce users?

One other thing with this same situation is that when i connect with the frontend mythtv player from a diskless media director uis that i have i black screen and not live tv, with my laptop an nc8430 from hp with an ati radeon x1600 video card i connect with only a frontend to the core backend and i have live tv, also i tried an live cd from knoppmytht for only test purposes for frontend live tv and also this works >>> again live tv capabilties, now i can say that this problem relies in the pluto linuxmce mythtv installation, on my core hybrid i have live tv with nearly same hardware config as diskless media director but also here i have problems, that when i watch tv on my core hybrid machine that after some minutes, one time after 1 one minute and sometimes after 30 seconds or sometimes after 15 minutes, so random it freezes the screen, and the only thing i can do, is going to main screen options of live tv in ui2 and turn off live tv and then restart i have this all the time, but with the same machine but diffrent harddisk with ubuntu feisty with backend / frontend and also this works perfectly.

Please can someone help with this problems.

Thnx in Advance,

Dave

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 890
  • Living with LMCE
    • View Profile
Hi,

I'm not sure if this is of some use, but some time ag Pluto system had similar problem. Mythbackend is started by default also on MDs, but shouldn't be if there is no capture card in MD. But I'm not sure if this was fixed or not. If not, you can search and prevent mythbackend from starting on mds...

HTH,

regards,

Bulek.
Thanks in advance,

regards,

Bulek.

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
My understanding is that the Mythbackend on an MD needs to be there for communications or some such. You don't need tuners on the MD's. I have an HDHomeRun in the network and can watch its output using the MythFrontEnd on any MD.

Which version of LMCE are you using?

deffcon

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Hi,

I'm using the latest version 1.1 Final


Thnx Dave

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
I think you can safely disable the backend process on startup for any MD without capture cards.
It is intended only to have a distributed setup where MDs have their own cards but can share the others as well.

I have two cards in the core and one MD with a card so I only need two backends running. The core one is the master and the MD one is a slave.

All MDs will run MythFrontend (plus my desktop in the study which runs Ubuntu).