Author Topic: Error: Orbiter failed to initialize OpenGL  (Read 5581 times)

snubbel

  • First post!
  • Posts: 1
    • View Profile
Error: Orbiter failed to initialize OpenGL
« on: August 05, 2007, 10:12:27 am »
I've encountered a little problem after running the MCE installer. At the first boot it starts configuring the system and it loops at this message. I get to click OK, but it just keeps trying to initialize OpenGL.

Help, anyone? :-)

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #1 on: August 05, 2007, 08:09:29 pm »
This is a known problem, with different soloutions.
First off you should start with reading similaer forum topics, then post your setup What hardware you have like
Graphicsboard

-k84

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Error: Orbiter failed to initialize OpenGL
« Reply #2 on: August 06, 2007, 03:08:15 pm »
Possible your graphical card isn't supported by Linux. Try to use UI1 (you can choose it on the media director page). From my experience  I can say that nVidia 6200 works fine with Alpha Blended UI2. The rest cards - nVidia 7XXX and 8XXX, a several ATI cards are failed.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

cyf4746

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #3 on: August 20, 2007, 05:43:56 am »
The pop up window "Error: Orbiter failed to initialize OpenGL" keep poping up. And, no whereelse you can go. How to change the setting to UI1?

smeg

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #4 on: August 20, 2007, 07:24:16 am »
If there is a pause in between theses screens. If you see the linuxMCE window click video and click reset resolution. This will reset your pc, and ask you to do the graphics and sound setup again. when you get to the interface options set it on low; then finish the setup. It also helps if you chose not to start LinuxMCE automatically until you get your settings working.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #5 on: August 20, 2007, 08:41:05 am »
The pop up window "Error: Orbiter failed to initialize OpenGL" keep poping up. And, no whereelse you can go. How to change the setting to UI1?

Edit /etc/pluto.conf (can be done from the launchmanager) change "AVWizardOverride = 0" to "AVWizardOverride = 1" and reboot, that should take you to the AVWizard where you can select UI1.
"Change is inevitable. Progress is optional."
-- Anonymous


nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Error: Orbiter failed to initialize OpenGL
« Reply #6 on: August 20, 2007, 09:21:38 am »
The pop up window "Error: Orbiter failed to initialize OpenGL" keep poping up. And, no whereelse you can go. How to change the setting to UI1?

The easiest way is go to media director page in admin site and chose UI1 there. After that the orbiter will be automatically re-generated with UI1.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

cyf4746

  • Veteran
  • ***
  • Posts: 63
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #7 on: August 20, 2007, 10:35:27 am »
I had set Linux MCE run on top og kubuntu. So, when my pc boot up it will immediately go to Linux MCE. I really cannot go to kubuntu and execute the launch manager. Please help me.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #8 on: August 20, 2007, 11:33:13 am »
I had set Linux MCE run on top og kubuntu. So, when my pc boot up it will immediately go to Linux MCE. I really cannot go to kubuntu and execute the launch manager. Please help me.
The launch manager should be the first thing that is opened.  If that fails, press ALT-F2, log in, and you can edit it there with: sudo nano /etc/pluto.conf

nite_man: as far as I know, those options were removed in the latest version.
"Change is inevitable. Progress is optional."
-- Anonymous


nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Error: Orbiter failed to initialize OpenGL
« Reply #9 on: August 20, 2007, 11:50:25 am »
cyf4746: bad luck! you can follow by Zaec instructions or use admin web interface from another PC :)

Zaerc: well, if it's impossible to chose UI from MD page I suspect that it's still possible to do from the Orbiter page. IMHO, it isn't so efficient run AVWizard to change just a type of UI. Moreover, for ordinary user who doesn't have Linux administration experience is much easier to set some properties via web interface than do something in the console mode.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #10 on: August 20, 2007, 12:17:51 pm »
You're right nite_man, the orbiter page still has an option to change the UI.
"Change is inevitable. Progress is optional."
-- Anonymous


delta_9

  • Regular Poster
  • **
  • Posts: 25
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #11 on: August 21, 2007, 01:22:01 pm »
cyf4746 had a similar problem till i updated to the correct driver for my video card. found out how to do it on the Ubuntu forums.good luck 

technoboy

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #12 on: October 05, 2007, 12:08:58 am »
The pop up window "Error: Orbiter failed to initialize OpenGL" keep poping up. And, no whereelse you can go. How to change the setting to UI1?
I'd like an answer to this too - I have exactly the same problem. The first time I installed I chose the third option and got a similar pop up window. So I re-installed all over again and chose option 2. Still get an error. So much for an easy install. I didn't expect the problems to start at this point  :(

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5496
  • DOES work for LinuxMCE.
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #13 on: October 05, 2007, 07:18:15 pm »
these problems are well known, and they basically come down to "drivers not there" or "drivers not new enough" on the installation media...and they are able to be fixed.

-Thom

toyohtadude

  • First post!
  • Posts: 1
    • View Profile
Re: Error: Orbiter failed to initialize OpenGL
« Reply #14 on: October 09, 2007, 05:52:40 am »
The pop up window "Error: Orbiter failed to initialize OpenGL" keep poping up. And, no whereelse you can go. How to change the setting to UI1?
I'd like an answer to this too - I have exactly the same problem. The first time I installed I chose the third option and got a similar pop up window. So I re-installed all over again and chose option 2. Still get an error. So much for an easy install. I didn't expect the problems to start at this point  :(

I have the same issue.  I chose UI2 first... no luck.  Onboard ATI Radeon Express 200 video.  I added an ATI x1300 PCI-E card.  Same error.  Reinstalled with UI2 - Same error.  I am now reinstalling with the on-board graphics and selecting UI1....  More to come.  It appears that ATI and MCE just do not get along.  I intend to find an nVidia card on the cheap to install at a later date and try UI2 and maybe 3.