Author Topic: AVerTVHD MCE A180 capture card in RC1  (Read 1083 times)

pkrey

  • Making baby steps
  • Posts: 3
    • View Profile
AVerTVHD MCE A180 capture card in RC1
« on: July 28, 2007, 09:51:09 pm »
RC1 loaded perfectly unlike previous versions of LinuxMCE (Yay!)
The only thing that didn't load was my AVerTVHD MCE A180. I bought this card because it is suppose to be one of the best HD video capture cards for MythTV. I was surprised when RC1 could not recognize it for install. Any suggestions? I have found the MythTV wiki page on this card and I don't know enough linux to make it work. I'm not even sure if it contains the information I need. If anyone could give me the steps to make this card work, I would appreciate it.

The card shows up in the PCI KInfoCenter. It seems to have the position 02:01.0
Clearly I'm a newbie to Linux.

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: AVerTVHD MCE A180 capture card in RC1
« Reply #1 on: July 29, 2007, 05:25:56 am »
Follow this guide to setup the Avermedia A180 card:
http://www.jnewcastle.com/blog/2006/10/06/install-avermedia-a180-on-ubuntu/

From there you will need to manually run mythtv setup from the Orbiter: Advanced->Computing->MythTV setup
Select DVB DTV capture card (v3.x).

You should be good to go.


pkrey

  • Making baby steps
  • Posts: 3
    • View Profile
Re: AVerTVHD MCE A180 capture card in RC1
« Reply #2 on: July 30, 2007, 06:55:08 am »
No luck so far.

I completely reinstalled Kubuntu/LinuxMCE RC1 twice to make sure I didn't miss anything.
I did the following with no ultimate success:

Sudo apt-get install linux-doc-2.6.20
cd /usr/share/doc/linux-doc-2.6.20/Documentation/dvb
sudo gzip –d get_dvb_firmware.gz
sudo chmod +x get_dvb_firmware
sudo ./get_dvb_firmware nxt2004
sudo cp dvb-fe-nxt2004.fw /lib/firmware
sudo modprobe saa7134-dvb
add blacklist saa7134 to /etc/modprobe.d/blacklist
add saa7134-dvb to /etc/modules

(All of these steps appeared to work without errors.)

Then I ran mythtv setup and selected DVB DTV capture card (v3.x)
This time I got “Frontend ID: Nextwave NXT200x VSB/QAM  Frontend subtype: ATSC (This was encouraging.)

Then I rebooted.
I checked mythtv setup and it had forgotten my capture card selection.
I reset it and tried to scan channels, I got: “Scan Type- Failed to open card”
My card showed up as capture card “DVD:0 DVBInput -> (None)  –which disappears as soon as I leave Myth setup.

I feel like I’m so close… and yet…

Does the A180 have to be used with an analog capture card to work? I hear that's the way it is with Windows MCE. Do I have to set up something else? It seems like it should be working now.

Help!
Linux Newbie

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: AVerTVHD MCE A180 capture card in RC1
« Reply #3 on: July 30, 2007, 05:02:14 pm »
That's strange.  I've installed the A180 5 or 6 different times with each release of LMCE and I never saw that problem.  Here are a couple of things to try:

Are you sure the myth backend isn't running when you try to run mythtv setup?
Check the permissions on the device: ls -l /dev/dvb/adapter0

It's a new card right?  I'd make sure it actually works by testing it outside of Myth.  Try accessing it using VLC.  It's been a while since I've done that, so I don't recall exactly how you set it up.  I believe you need to point VLC to /dev/dvb/adapter0/.  The tricky part is finding a valid channel within VLC.

I recently purchased an HDHomeRun so I'm not currently using my A180 with RC1.


pkrey

  • Making baby steps
  • Posts: 3
    • View Profile
Re: AVerTVHD MCE A180 capture card in RC1
« Reply #4 on: July 31, 2007, 05:44:35 pm »
Thanks for your help cckrobison!

I ended up loading LinuxMCE without doing the dedicated Media Center option. Then I entered the MythTV setup from the Kubuntu menu after adding the A180 driver. This insured no part of the media center was running while in setup and everything worked as it should have. (I apparently had trouble turning everything off when I was in dedicated MC mode.)

I’m so excited. Thanks again for your help!