Author Topic: Problem with LIRC solved  (Read 1024 times)

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Problem with LIRC solved
« on: August 18, 2007, 06:16:39 pm »
I was having a lot of issues with getting a Windows MCE IR receiver working.  In the past is was automatically install once you selected the mceusb2 Receiver from admin site but since 704 I could not get it install I kept getting lirc_mceusb2 module not found. 

It turns out that I had to manually do a depmod -ae then modprobed lirc_mceusb2 and finally it started working. 

I am not sure exactly why I had to do that, but I did and it worked. 

Thanks,

Rob

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Problem with LIRC solved
« Reply #1 on: August 18, 2007, 06:28:36 pm »
If you have to do that after every reboot, you can add the name of the module to the "/etc/modules" file so that it will be loaded during boot.
"Change is inevitable. Progress is optional."
-- Anonymous


rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: Problem with LIRC solved
« Reply #2 on: August 18, 2007, 07:22:31 pm »
I do not suspect that will be the case, as it appears to be an issue where the installed packages did not update the modules.  I found that the modules where loaded the entire time, but that depmod -ae needed to be run so that Kubuntu was aware of the modules.  I have everything working pretty well right now, so I am going to hold off on rebooting until I need, but I will keep posting if there is any problems

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: Problem with LIRC solved
« Reply #3 on: August 19, 2007, 07:23:40 am »
Survived reboot without any need for command line magic.  I am getting ready to add a second MD, so I will report as to it's success as it will be using the Windows MCE IR receiver.  Now I just need to get the IR Blaster working with LinuxMCE.  I have it configured to change channels with Mythtv via an external script, but I have no idea where to begin with LinuxMCE with regards to adding new Blaster Support.  It would be nice as it has two transmitters.  Anyway, I am getting off topic

Thanks,

Rob