Author Topic: RC1: USB ports switch ON/OFF continuously  (Read 3673 times)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
RC1: USB ports switch ON/OFF continuously
« on: July 28, 2007, 03:14:33 pm »
I installed LinuxMCE RC1 yesterday. At the first view it works fine except some strange problem with USB ports. I have a USB hub connected to the one USB port. so, after start LinuxMCE I see that all LEDs are blinking continuously. It looks like the power ON/OFF on the USB ports. Without  LinuxMCE everything fine.

Any ideas why it happens?
« Last Edit: August 03, 2007, 09:07:45 am by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

schaferj

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: RC1: USB ports switch ON/OFF continuously
« Reply #1 on: July 31, 2007, 12:03:11 pm »
Michael,
I had this problem with pluto.  Solution was to move the usb hub to a windows box to serve the media files.
joseph

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: RC1: USB ports switch ON/OFF continuously
« Reply #2 on: July 31, 2007, 01:16:09 pm »
Michael,
I had this problem with pluto.  Solution was to move the usb hub to a windows box to serve the media files.
joseph

Thanks for your answer, Joseph. if I understand clearly by some reason LinuxMCE  doesn't support USB hubs? I was planning to use PC with LinuxMCE for others tasks as well.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

espace

  • Making baby steps
  • Posts: 2
    • View Profile
Re: RC1: USB ports switch ON/OFF continuously
« Reply #3 on: July 31, 2007, 04:28:31 pm »
Hi Michael,
I don't know any reason for LinuxMCE to not support USB hubs, because it is based on Kubuntu.
It will help to find out if Kubuntu has this problem too. It is possible to report the problem to them and we can get a fix in one of their updates.
Let us know if you have this problem before installing LinuxMCE RC1.
Thanks,
espace

Michael,
I had this problem with pluto.  Solution was to move the usb hub to a windows box to serve the media files.
joseph

Thanks for your answer, Joseph. if I understand clearly by some reason LinuxMCE  doesn't support USB hubs? I was planning to use PC with LinuxMCE for others tasks as well.

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: RC1: USB ports switch ON/OFF continuously
« Reply #4 on: July 31, 2007, 04:40:50 pm »
Guys, I am also having this problem with my USB hub.  For further information, I am using a USB KVM to switch my keyboard and mouse and haven't had any issues with those.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: RC1: USB ports switch ON/OFF continuously
« Reply #5 on: July 31, 2007, 05:41:13 pm »
2espace: The problem with USB hub appears only when LinuxMCE is run. Without it Kubuntu works fine with that hub. After starting LinuxMCE all hub LEDs are blinking continiusly as I already mention. I have D-Link 4 Ports USB 2.0 (DUB-H4).
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

kir

  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: RC1: USB ports switch ON/OFF continuously
« Reply #6 on: July 31, 2007, 05:46:57 pm »

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: RC1: USB ports switch ON/OFF continuously
« Reply #7 on: July 31, 2007, 09:16:11 pm »
I see those messages into /var/log/message:
Code: [Select]
Jul 31 21:58:15 dcerouter kernel: [ 3080.976463] usb 4-2: new high speed USB device using ehci_hcd and address 74
Jul 31 21:58:15 dcerouter kernel: [ 3081.495808] usb 4-2: new high speed USB device using ehci_hcd and address 75
Jul 31 21:58:18 dcerouter kernel: [ 3084.208410] usb 4-2: new high speed USB device using ehci_hcd and address 76
Jul 31 21:58:18 dcerouter kernel: [ 3084.751668] usb 4-2: new high speed USB device using ehci_hcd and address 77
Jul 31 21:58:19 dcerouter kernel: [ 3085.294930] usb 4-2: new high speed USB device using ehci_hcd and address 78
Jul 31 21:58:20 dcerouter kernel: [ 3085.814287] usb 4-2: new high speed USB device using ehci_hcd and address 79
Jul 31 21:58:22 dcerouter kernel: [ 3088.530806] usb 4-2: new high speed USB device using ehci_hcd and address 80
Jul 31 21:58:23 dcerouter kernel: [ 3089.074141] usb 4-2: new high speed USB device using ehci_hcd and address 81
Jul 31 21:58:23 dcerouter kernel: [ 3089.617446] usb 4-2: new high speed USB device using ehci_hcd and address 82
Jul 31 21:58:24 dcerouter kernel: [ 3090.136765] usb 4-2: new high speed USB device using ehci_hcd and address 83
Jul 31 21:58:27 dcerouter kernel: [ 3092.865288] usb 4-2: new high speed USB device using ehci_hcd and address 84
Jul 31 21:58:27 dcerouter kernel: [ 3093.408601] usb 4-2: new high speed USB device using ehci_hcd and address 85
Jul 31 21:58:28 dcerouter kernel: [ 3093.951917] usb 4-2: new high speed USB device using ehci_hcd and address 86
Jul 31 21:58:28 dcerouter kernel: [ 3094.471226] usb 4-2: new high speed USB device using ehci_hcd and address 87

And in dmesg:
Code: [Select]
[ 3232.031406] usb 4-2: new high speed USB device using ehci_hcd and address 65
[ 3232.438864] usb 4-2: device not accepting address 65, error -32
[ 3235.031608] usb 4-2: new high speed USB device using ehci_hcd and address 66
[ 3235.143417] usb 4-2: device descriptor read/64, error -32
[ 3235.359149] usb 4-2: device descriptor read/64, error -32
[ 3235.574876] usb 4-2: new high speed USB device using ehci_hcd and address 67
[ 3235.686812] usb 4-2: device descriptor read/64, error -32
[ 3235.902457] usb 4-2: device descriptor read/64, error -32
[ 3236.118190] usb 4-2: new high speed USB device using ehci_hcd and address 68
[ 3236.525634] usb 4-2: device not accepting address 68, error -32
[ 3236.637588] usb 4-2: new high speed USB device using ehci_hcd and address 69
[ 3237.044974] usb 4-2: device not accepting address 69, error -32
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: [SOLVED] RC1: USB ports switch ON/OFF continuously
« Reply #8 on: August 01, 2007, 09:03:37 pm »
Finally I managed to solve that problem. I boot Kubuntu with option apic=off and my hight speed USB devices started work properly. Once I already faced with strange result of apic mode. My working Fedora didn't return from the standby mode. After I switched apic off Fedora works fine.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: [SOLVED] RC1: USB ports switch ON/OFF continuously
« Reply #9 on: August 03, 2007, 09:09:42 am »
Finally I managed to solve that problem. I boot Kubuntu with option apic=off and my hight speed USB devices started work properly. Once I already faced with strange result of apic mode. My working Fedora didn't return from the standby mode. After I switched apic off Fedora works fine.

Recently the problem appear again. Switch off APIC mode doesn't help anymore. But I suspect that this is Kubuntu problem. So, I'll post that problem to kubuntu forum as well.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: RC1: USB ports switch ON/OFF continuously
« Reply #10 on: August 03, 2007, 07:55:03 pm »
Here is my workaround:
1. Adding following kernel option to the boot process didn't help solve that problem: acpi=routeirq, acpi=nobios, acpi=off, acpi=noirq, pci=noacpi, noapic
2. That hack helped me but it turned UBS to 1.1:

Code: [Select]
$ sudo modprobe -rv ehci_hcd
To make it permanently just add "blacklist ehci_hcd" to the end of the file /etc/modprobe.d/blacklist:
Code: [Select]
$ sudo echo "blacklist ehci_hcd" >> /etc/modprobe.d/blacklist
So USB 2.0 is faster but 1.1 is better than nothing.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Re: RC1: USB ports switch ON/OFF continuously
« Reply #11 on: August 03, 2007, 08:05:35 pm »
Thanks for working this issue.  If you figure out a way to keep 2.0 high speed operation, please let us know.

-Pete

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: RC1: USB ports switch ON/OFF continuously
« Reply #12 on: August 11, 2007, 08:19:02 pm »
Finally (again ;)) I found that the problem was in the USB 2.0 controller. It seems that it was broken. So I installed a PCI USB 2.0 controller and it was recognized by Kubuntu and LinuxMCE without any problems.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru