Author Topic: Unable to initiate LMCE 1.1_b2 install  (Read 1553 times)

boing

  • Newbie
  • *
  • Posts: 4
    • View Profile
Unable to initiate LMCE 1.1_b2 install
« on: June 19, 2007, 10:59:07 pm »
What have I done so far?
 - dl Kubuntu 7.04 from kubuntu.org.
 - dl LMCE 1.1b2 via torrent from tpb
 - Clean install of kubuntu on clean harddisk (wd 120 Gb)
 - Mounted the LMCE packages CD on /media/cdrom
 - Installed the mce-installer deb from kubuntu package-menu.
 - Got the "install linux mce" icon on my desktop
 - clicked it - and entered password in kdesu
 - The "Hybrid or core" box appears, I select "Core"
 - The "Nvidia-drivers" box pops up - I select "opensource"
 - The Installer say: "The driver has been changed, and the installer will now exit."
 - And so it does....

No logs are created anywhere.

I have actually tried all possible combinations of drivers / hybrid / core etc, but it ends there every time.
 Looking in /tmp i find that the installer has created and populated the selfext-xxxx dir, and it looks as if it does this twice every time I try a new install.
(Creating 2 selfext dirs.)

 I've spent 2 evenings already trying to resolve this. I'm considering Pluto ATM, but I'd really like the option of KDE over Nx on this server. So I'm crying out to you guys for help. :)

 Hardwareinfo:
 - dual Xp1900+ on an Asus mobo
 - 2 Gb ram
 - Nvidia Riva Tnt2   (will be removed - going to run the core headless)
 - 120 Gb WD. 

 Any Ideas?

 Regards
    Anders

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Unable to initiate LMCE 1.1_b2 install
« Reply #1 on: June 20, 2007, 03:05:49 am »
Its probably in a loop since you are installing the open source driver. Its designed to use the proprietary driver. The Open source driver doesn't support the transparency features.

boing

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Unable to initiate LMCE 1.1_b2 install
« Reply #2 on: June 20, 2007, 08:43:09 am »
Well - when I first tried to install I selected the proprietary driver. The pc rebooted - and nothing. Actually it screwed up my Xorg, and X didn't even start. Had to revert to the generic nv-driver to get X back. This on a Riva Tnt2 16 mb.
 Why does it need another nv-driver on the core anyway? I'm going to run it headless as a dedicated core, so the displaydriver doesn't matter anyway. The only usage of KDE and X on the core itself will be via Nx.

 

1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: Unable to initiate LMCE 1.1_b2 install
« Reply #3 on: June 20, 2007, 09:40:56 am »
I ran into a permissions nightmare that came from using the same name for Kubuntu and for LMCE. It caused a number of mysterious problems, including video setup. The only fix I know is to reinstall unfortunately. You should be able to select the nv driver or the vesa driver and just go forward.  UI2 won't work but not important for a core. Skip the driver setup and see what happens. I'm not sure the nvidia driver will work on that card. You might need the legacy driver to get it to work and 16 Mb is not enough for video.

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: Unable to initiate LMCE 1.1_b2 install
« Reply #4 on: June 20, 2007, 10:18:10 am »
@boing
i think that there are 3 possible solutions to your problem:
1. install nvidia-glx-legacy before starting the installer (nvidia legacy supports riva tnt, the last nvidia driver does not)
2. before starting the installer, in xorg.conf, section driver, write nvidia instead of nv to trick the installer (it will think that you already have the official drivers  ;D)
3. before nvidia installation step, once you already started the installer go to /tmp/selfextract*/ and do echo > mce-installer-NvidiaDrivers.sh.
« Last Edit: June 20, 2007, 02:59:50 pm by sharlee_angelo »
Read the F****** Logs!!!

boing

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Unable to initiate LMCE 1.1_b2 install
« Reply #5 on: June 20, 2007, 11:25:12 am »
thx.
 Here's what I'll do:
 - Swap the TnT2 for a Geforce5 128mb for the install. (Will be removed later)
 - Install a new, clean Kubuntu straight off the CD
 - Start the install, and apply sharlee's fixes
 - See where it takes me....

I'll report back with the results. :-)

 Regards
   Anders

boing

  • Newbie
  • *
  • Posts: 4
    • View Profile
And the report....
« Reply #6 on: June 22, 2007, 08:19:12 am »
With sharlee's tip to simply change the driver in xorg.conf, I've been able to install LMCE2b2 core on my server.
The core runs ok, the routing works, but that's about it.
Status is as follows:

- The orbiter-generation hangs at stage 2 for every orbiter I try to generate.
- Booting MD stops at "announcing myself", but nothing happens on my winXP orbiter on my laptop. Thus I am unable to install MD's.
- The routing / dns-lookups are slooooooow. I've had to enter static dns's for the routing to work at all.
- Adding child-device (Web orbiter) under the core does not work. (No way to submit information).
- My dynalink ISDN card(hisax) does not show up - and cannot be used as a device in asterisk.
- My Cx88 (Msi Tv@nywhere) tv-card is not autodetected by LinuxMCE.
(Both works perfectly in kubuntu 7.04.

I'll try a couple of more things, but I'm left without much hope. If I am unable to get this to work in a couple of tries - I'll try Pluto. :-)
 


sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: Unable to initiate LMCE 1.1_b2 install
« Reply #7 on: June 22, 2007, 10:09:23 am »
regarding the tv tuner, it must appear in setup wizard > media player setup. also, you can add it in web admin. go to show devices tree > add top level device. there, pick device template, select at manufacturer msi, press apply filter then choose at device template your tuner.
for ISDN card and asterisk i've found this http://voip-manager.net/asterisk-isdn.php.
« Last Edit: June 22, 2007, 11:14:10 am by sharlee_angelo »
Read the F****** Logs!!!