Author Topic: nVidia playback problem  (Read 1792 times)

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
nVidia playback problem
« on: June 01, 2007, 05:07:23 pm »
Since installing 1.1 and Kubuntu 7.04, I've noticed that I'm having difficulty getting smooth video playback. It doesn't matter what type of content I try to play.  SD and HD material display the same symptom.  There's a lot of tearing in the image and playback is jumpy.  The problem exists using both xv and xvmc/xxmc, but the problem is worse when using xvmc.  I did some investigation and isolated the problem to the Composite extension in the xorg.conf file. 

Section "Extensions"
Option "Composite" "Disable"
EndSection

If I set Composite to "Disable" the playback is smooth.  It appears to be an nVidia driver issue with either KDE or Ubuntu 7.04, but I'm not sure which.  People are having tons of issues with the current nVidia drivers and Ubuntu over at the nvNews forums.  The most recent nVidia drivers have exhibit this problem on my box.  I've tried 9755, the latest legacy driver, and the 100.xx nVidia beta driver.   The catch is that disabling Composite prevents me from using UI2 with alpha-blending.  I can still run UI2 with Masking however, so all is not lost.

I wanted to point this out in case others are seeing playback issues with nVidia cards.  Here are my system specs.

Athlon64 3500+
6600GT (AGP)
2GB dual channel RAM
nVidia 9755 driver (same issue with beta 100.xx beta driver)
Avermedia A180 ATSC\QAM card
Olevia 532H HDTV connected via DVI


1audio

  • Addicted
  • *
  • Posts: 552
    • View Profile
Re: nVidia playback problem
« Reply #1 on: June 01, 2007, 10:54:01 pm »
I have noticed similar problems with the nVidia driver in LMCE and in Pluto. And on the same files in Windows suggesting its a core issue with their processing. I will try the alternative masking option.

Did the nVidia beta driver (100. . .) do anything else better? Is it worth switching?

ddamron

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 962
    • View Profile
    • My LinuxMCE User Page
Re: nVidia playback problem
« Reply #2 on: June 01, 2007, 11:39:33 pm »
I too am using Nvidia 7700... will try to test it out...
The only intuitive interface is the nipple.  After that it's all learned.
My other computer is your windows box.
I'm out of my mind.  Back in 5 minutes.
Q:  What's Red and smells like blue paint?

A:  Red Paint.

norcal

  • Regular Poster
  • **
  • Posts: 38
    • View Profile
Re: nVidia playback problem
« Reply #3 on: June 02, 2007, 12:21:44 am »
I have noticed this issue as well. I will try to disable the composite output in xorg.conf when i get home from work. Will post the results here. Cheers and thanks for the tip ;)

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: nVidia playback problem
« Reply #4 on: June 02, 2007, 04:41:11 am »
Did the nVidia beta driver (100. . .) do anything else better? Is it worth switching?

Not that I could tell.  I get the impression that the majority of the changes to the drivers are to support new cards and not to improve performance.  It's a shame.

norcal

  • Regular Poster
  • **
  • Posts: 38
    • View Profile
Re: nVidia playback problem
« Reply #5 on: June 02, 2007, 05:00:54 pm »
Hmm, i tried the suggested fix and after a reboot it showed a black screen error. Might have a go at it again later today. Cheers.

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: nVidia playback problem
« Reply #6 on: June 03, 2007, 01:42:06 am »
You will only be able to run UI2 with masking if you disable Composite.  UI2 with alpha-blending won't work.

bart

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: nVidia playback problem
« Reply #7 on: June 03, 2007, 01:47:57 am »
I've spent the last days trying to figure out how to get vertical sync. This did the trick! Thanx very much.

norcal

  • Regular Poster
  • **
  • Posts: 38
    • View Profile
Re: nVidia playback problem
« Reply #8 on: June 03, 2007, 02:03:32 am »
@ cckrobinson The message had something to do with the overlays so i assumed it was something to do with running alpha blending. Thanks for the tip ;)