Author Topic: eth0:0 and how to stop it  (Read 1556 times)

niick

  • Making baby steps
  • Posts: 3
    • View Profile
eth0:0 and how to stop it
« on: May 29, 2007, 03:31:25 pm »
For some reason known only to itself, linuxmce always creates this(eth0:0) which promptly stops all networking and causes the install to fail.

At the start of the install linuxmce asks me if my networking information is correct. It is and I tell it to continue. Later it asks if I want to run a DHCP server. I already have a server doing that for my network so I say no. A console window then appears and packages start being fetched and installed. It is at this point linuxmce decides its had enough of a working network connection and promptly disables it by adding a reference to eth0:0 in /etc/network/interfaces.

Why does it do this and how can I stop it? >:(
« Last Edit: May 29, 2007, 03:34:04 pm by niick »

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: eth0:0 and how to stop it
« Reply #1 on: May 29, 2007, 03:53:45 pm »
you have only one network card. i saw this to another user who's experiencing the "creation" of an eth0:0 but it doesn't have any problem with internet connection.
Read the F****** Logs!!!

niick

  • Making baby steps
  • Posts: 3
    • View Profile
Re: eth0:0 and how to stop it
« Reply #2 on: May 29, 2007, 03:58:27 pm »
I know I only have one networking card, thats all I installed.

niick

  • Making baby steps
  • Posts: 3
    • View Profile
Re: eth0:0 and how to stop it
« Reply #3 on: May 29, 2007, 04:32:58 pm »
I looked around and found this is an old issue newbielink:http://forum.linuxmce.com/index.php?topic=1281.0 [nonactive]

The problem is that it tries to use the same ip address as my server 192.168.2.1. To stop this at the point where it asks if I want to run a dhcp server I selected no and left the ip setting to 192.168.80. It is still not working though. How can I can stop eth0:0 being created or at least set it to have a sane ip address?

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: eth0:0 and how to stop it
« Reply #4 on: May 29, 2007, 04:55:03 pm »
try this: when the eth0:0 is created type ifdown eth0:0 to shut down this interface. maybe it works.
Read the F****** Logs!!!

BeKli

  • Making baby steps
  • Posts: 3
    • View Profile
Re: eth0:0 and how to stop it
« Reply #5 on: May 29, 2007, 06:29:50 pm »
I looked around and found this is an old issue newbielink:http://forum.linuxmce.com/index.php?topic=1281.0 [nonactive]

The problem is that it tries to use the same ip address as my server 192.168.2.1. To stop this at the point where it asks if I want to run a dhcp server I selected no and left the ip setting to 192.168.80. It is still not working though. How can I can stop eth0:0 being created or at least set it to have a sane ip address?

The workaround at the end of this topic newbielink:http://forum.linuxmce.com/index.php?topic=1281.0 [nonactive] worked for me.
Maybe some additional hints:
I chose to set the network manually, asked the network manager for the current dhcp ip given by my router.
I set this as static ip, and filled in the routers ip as gateway and dns.
I chose no when asked to run a dhcp server, and typed a different three digit ip to my home network (in my case home network has 192.168.1, i wrote 192.168.0).

Installation is still running with no more network problems.

excuse my bad english.
« Last Edit: May 29, 2007, 06:34:46 pm by BeKli »