Author Topic: Is it possible to switch network interfaces between internal and external? How?  (Read 2029 times)

Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Hi!

I have a LMCE 1.1 Beta 2 installed. On this box I have a Netgear wireless card and a ethernet card. Thus ath0 (wireless) and eth0 (wired 10/100 mbps).

At install I made the mistake having ath0 as the default gateway and communication to router and internet. That made ath0 external network device in LMCE. And eth0 became internal.

How do I switch them around so that ath0 is internal and eth0 is external instead?

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile
Point a browser to your core to get the admin interface.
Under Advanced->Network->Network Settings there should be a button called "swap interfaces"

HTH
Darren

Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Point a browser to your core to get the admin interface.
Under Advanced->Network->Network Settings there should be a button called "swap interfaces"

HTH
Darren

I am sorry to report that the button "swap interfaces" is nowhere to be found under Advanced > Network > Network Settings.
Does one have to take it down to offline or something like that in order for that button to appear?

*shrug*

PeteK

  • Guru
  • ****
  • Posts: 408
    • View Profile
Cryoniq--

What does that page contain in your setup?  Does the line "Number of network adapters: 2" appear?  Does it list both adapters and their current settings (i.e. DHCP or Static IP info)?

I attached a screen shot of the configuration page as it looks in my setup.

Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Cryoniq--

What does that page contain in your setup?  Does the line "Number of network adapters: 2" appear?  Does it list both adapters and their current settings (i.e. DHCP or Static IP info)?

I attached a screen shot of the configuration page as it looks in my setup.

"Number of network adapters: 2" is there.
Both adapters are listed and their current settings:
ath0 is set to DHCP, areas below are empty. Guess those are not filled in since it is DHCP on the interface.
eth0 is set to static IP 192.168.1.151, subnet 255.255.255.0

DHCP Server on Core is: Disabled.

I enabled the DHCP Server on Core just to see if that button showed up, and it didn't. =/

Edit:
Hmm I think I might found something here..

Under: Automation > Device Status there is a list over all devices and their status.
On one line it says:
CORE             192.168.1.151 

If one click on CORE a page comes up and in that page there is a text box left of the heading "Network interfaces". In that box is the following:
ath0,dhcp|eth0,192.168.1.151,255.255.255.0

I wonder what will happen if I alter it to?
eth0,192.168.1.151,255.255.255.0|ath0,dhcp

My thinking is that the order of those two interfaces in that line determine the order of the interfaces, this making eth #1 and ath #2 instead.

Any knowledge about this? :)


« Last Edit: May 29, 2007, 09:55:09 am by Cryoniq »

Cj_MaN

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
You must login in Web Admin with a Master User (can modify configuration)( see if u're user is Master or not in WIzard -> Basic Info -> Users) to be able to modify your network settings from Advanced -> Network -> Network Settings

Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
You must login in Web Admin with a Master User (can modify configuration)( see if u're user is Master or not in WIzard -> Basic Info -> Users) to be able to modify your network settings from Advanced -> Network -> Network Settings

Only one user in system which have:  Master User (can modify configuration)? *ENABLED*

So that is not the problem either. =/

darrenmason

  • Addicted
  • *
  • Posts: 529
    • View Profile

I wonder what will happen if I alter it to?
eth0,192.168.1.151,255.255.255.0|ath0,dhcp


I don't think that will do much. Don't you really want to change the ath0/eth0 around so that eth0(your wired card) gets an external address from your IP providers DHCP and ath0(internal wireless) is fixed to an internal address.

Are you just trying to operate this as a standalone hybrid? If so, the I would pull the wireless card/adapter out and reconfigure with single wired network card. From memory (with Pluto, not linuxMCE but probably hasn't changed) the setup will allocate two interfaces on the one card.

Do you intend to have an internal network attached to your Core?


Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile

I wonder what will happen if I alter it to?
eth0,192.168.1.151,255.255.255.0|ath0,dhcp


I don't think that will do much. Don't you really want to change the ath0/eth0 around so that eth0(your wired card) gets an external address from your IP providers DHCP and ath0(internal wireless) is fixed to an internal address.

Are you just trying to operate this as a standalone hybrid? If so, the I would pull the wireless card/adapter out and reconfigure with single wired network card. From memory (with Pluto, not linuxMCE but probably hasn't changed) the setup will allocate two interfaces on the one card.

Do you intend to have an internal network attached to your Core?

I intend to have media streamed from file server connected to the wireless router on other internal side of the place to the core/media over the 108 mbps wireless card ath0. And then plugin in the wired card eth0 to the second 100 mbps full duplex plugg going to the external and access to the internet (since it is that interface that will RSS auto download TV shows through bittorrent during nights ;P and store temporarily on the cores storage area).

Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Submitted this to bug report, but bringing it up here also.

I tried installing LMCE 1.1 Beta 2 with just a Wireless NIC in the box. Had it setup via Knetwork manager for WPA-TKIP and everything was working flawlessly. I figured I maybe only needed 1 NIC and skip the wired ethernet instead. Thus was my thought that LinuxMCE would set it up as ath0 and ath0:0.

Problem is, during install Knetworkmanager is screwed up (which I resolved the other time by reinstalling it after setup) and even if using the cache cd and packages cd so no downloads would be needed, the install still tried download something with security in the URL. This failed of course because it was after Knetworkmanager been pushed out. The install however continued after telling unable to resolve hos for 15 minutes and told me to reboot. So I did...

But.. upon reboot, console bootup screen would start blinking between trying to samba and connect to SQL server. And.. so it went on.. in a loop.. and wouldn't let go of it all. I tried to switch to another console and check network settings, thinking local host might been screwed up as well, but it wouldn't let me. The install clearly was a failure of major disaster.

Anyone might have any suggestions about this, or experienced the same and resolved it, but as it seem, Knetworkmanager or something it depends on have to be left alone for wireless NIC setups.