Author Topic: pxelinux.0 ...error:  (Read 2192 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
pxelinux.0 ...error:
« on: June 17, 2005, 02:50:08 am »
Hello,

Whenever I try to network boot my MD it says:

Searching for server (DHCP)...
..Me: 192.168.80.2, Server: 192.168.80.1, Gateway 192.168.80.1
Loading 192.168.80.1:/tftpboot/pxelinux.0 ...error: not a valid image
Unable to load file.
<sleep>
I
 should add that originally this motherboard was only capable of an RPL boot, I had to flash the BIOS to give me the PXE option.

Thanks in advance,
Brandon

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
pxelinux.0 ...error:
« Reply #1 on: June 17, 2005, 06:05:18 pm »
Well, after doing some searching I found that it is etherboot that is flashed into the BIOS. And there may be problems that occur when etherboot tries to boot a pxe image. I found this error in a troubleshooting section of Skolelinux

When I use etherboot the ROM loads fine. However, when the ROM gets the kernel image from the server it then says "Loading 192.168.0.254:/tftpboot/lts/pxelinux.0 ...error: not a valid image"

If you have configured the thin client by it's hardware address in the Webmin server DHCP config, the likelihood is that the ‘Boot filename’ parameter just below the Hardware Address is set to "/tftpboot/lts/pxelinux.0". This is a PXE specific kernel image and is invalid for etherboot. For etherboot, set this parameter to "None" and save the changes (not forgetting to apply changes at the bottom of the DHCP server page).

Does anyone know how to set the parameter to "none" for etherboot?

I'm about to save me some headaches and just buy some NIC's that are pxe capable? Any suggested brand names?

Thank You,
Brandon

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
pxelinux.0 ...error:
« Reply #2 on: June 18, 2005, 03:38:52 am »
Problem solved, I went to newbielink:http://rom-o-matic.net/ [nonactive] created a  network boot floppy disk for now.

Brandon

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
pxelinux.0 ...error:
« Reply #3 on: June 19, 2005, 10:23:49 am »
I never heard of this, but then all our test systems do pxe boot.  Did you have to "set the parameter to "none" for etherboot?"  Or just created the network boot floppy disk and left all the settings on the core alone?

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
pxelinux.0 ...error:
« Reply #4 on: June 19, 2005, 07:12:55 pm »
I made no changes, just went to above site created my rom with the correct NIC drivers, Rawrite it onto a floppy and had me a pc that could network boot off the core. If you guys could give some advice on certain hardware used for MD's i.e. NIC's - i know pxe enabled now  :) , video cards, i know ya suggest audigy sound card, DVD's, things like that I would greatly appreciate it.

Thanks,
Brandon