Author Topic: LinuxMCE installation failed: pluto errors  (Read 2455 times)

juster

  • Newbie
  • *
  • Posts: 6
    • View Profile
LinuxMCE installation failed: pluto errors
« on: March 31, 2007, 08:01:17 pm »
Hi

I'm trying to install LinuxMCE but I always get some Pluto errors. Here's the log:

Quote
MESSAGE: Seting Up Networking
SIOCSIFFLAGS: Cannot assign requested address
MESSAGE: Setting up APT Package Manager
ln: creating symbolic link `/etc/apt/apt.conf.d/99offline' to `/usr/pluto/var/apt.conf.offline': File exists
MESSAGE: Preseeding debconf options
Ign file: ./ Release.gpg
Ign file: ./ Translation-en_GB
Ign file: ./ Release
Ign file: ./ Packages
Get: 1 http://archive.ubuntu.com edgy Release.gpg [191B]
Ign http://archive.ubuntu.com edgy/main Translation-en_GB
Ign http://archive.ubuntu.com edgy/restricted Translation-en_GB
Ign http://archive.ubuntu.com edgy/multiverse Translation-en_GB
Ign http://archive.ubuntu.com edgy/universe Translation-en_GB
Get: 2 http://archive.ubuntu.com edgy-security Release.gpg [191B]
Ign http://archive.ubuntu.com edgy-security/main Translation-en_GB
Ign http://archive.ubuntu.com edgy-security/restricted Translation-en_GB
Ign http://archive.ubuntu.com edgy-security/multiverse Translation-en_GB
Ign http://archive.ubuntu.com edgy-security/universe Translation-en_GB
Get: 3 http://archive.ubuntu.com edgy-updates Release.gpg [191B]
Ign http://archive.ubuntu.com edgy-updates/main Translation-en_GB
Ign http://archive.ubuntu.com edgy-updates/restricted Translation-en_GB
Ign http://archive.ubuntu.com edgy-updates/multiverse Translation-en_GB
Ign http://archive.ubuntu.com edgy-updates/universe Translation-en_GB
Hit http://archive.ubuntu.com edgy Release
Get: 4 http://archive.ubuntu.com edgy-security Release [50.9kB]
Ign http://linuxmce.com ./ Release.gpg
Ign http://linuxmce.com ./ Translation-en_GB
Hit http://archive.ubuntu.com edgy-updates Release
Ign http://linuxmce.com ./ Release
Hit http://archive.ubuntu.com edgy/main Packages
Hit http://archive.ubuntu.com edgy/restricted Packages
Hit http://archive.ubuntu.com edgy/multiverse Packages
Hit http://archive.ubuntu.com edgy/universe Packages
Get: 5 http://archive.ubuntu.com edgy-security/main Packages [76.1kB]
Ign http://linuxmce.com ./ Packages
Get: 6 http://archive.ubuntu.com edgy-security/restricted Packages [5678B]
Get: 7 http://archive.ubuntu.com edgy-security/multiverse Packages [3786B]
Get: 8 http://archive.ubuntu.com edgy-security/universe Packages [35.2kB]
Errhttp://linuxmce.com ./ Packages
  404 Not Found
Hit http://archive.ubuntu.com edgy-updates/main Packages
Hit http://archive.ubuntu.com edgy-updates/restricted Packages
Hit http://archive.ubuntu.com edgy-updates/multiverse Packages
Hit http://archive.ubuntu.com edgy-updates/universe Packages
Failed to fetch http://linuxmce.com/ubuntu/./Packages.gz  404 Not Found
Fetched 172kB in 27s (6349B/s)
Reading package lists...
E: Some index files failed to download, they have been ignored, or old ones used instead.
MESSAGE: Generating Default Config File
MESSAGE: Configuring Network Information Service (NIS)
Mounting CD
MESSAGE: Caching LinuxMCE CD on the harddrive
MESSAGE: Installing LinuxMCE Base Software
Ign file: ./ Release.gpg
Ign file: ./ Translation-en_GB
Ign file: ./ Release
Ign file: ./ Packages
Get: 1 http://archive.ubuntu.com edgy Release.gpg [191B]
Ign http://archive.ubuntu.com edgy/main Translation-en_GB
Ign http://archive.ubuntu.com edgy/restricted Translation-en_GB
Ign http://archive.ubuntu.com edgy/multiverse Translation-en_GB
Ign http://archive.ubuntu.com edgy/universe Translation-en_GB
Get: 2 http://archive.ubuntu.com edgy-security Release.gpg [191B]
Ign http://archive.ubuntu.com edgy-security/main Translation-en_GB
Ign http://archive.ubuntu.com edgy-security/restricted Translation-en_GB
Ign http://archive.ubuntu.com edgy-security/multiverse Translation-en_GB
Ign http://archive.ubuntu.com edgy-security/universe Translation-en_GB
Get: 3 http://archive.ubuntu.com edgy-updates Release.gpg [191B]
Ign http://archive.ubuntu.com edgy-updates/main Translation-en_GB
Ign http://archive.ubuntu.com edgy-updates/restricted Translation-en_GB
Ign http://archive.ubuntu.com edgy-updates/multiverse Translation-en_GB
Ign http://archive.ubuntu.com edgy-updates/universe Translation-en_GB
Hit http://archive.ubuntu.com edgy Release
Hit http://archive.ubuntu.com edgy-security Release
Hit http://archive.ubuntu.com edgy-updates Release
Hit http://archive.ubuntu.com edgy/main Packages
Hit http://archive.ubuntu.com edgy/restricted Packages
Hit http://archive.ubuntu.com edgy/multiverse Packages
Hit http://archive.ubuntu.com edgy/universe Packages
Hit http://archive.ubuntu.com edgy-security/main Packages
Hit http://archive.ubuntu.com edgy-security/restricted Packages
Hit http://archive.ubuntu.com edgy-security/multiverse Packages
Hit http://archive.ubuntu.com edgy-security/universe Packages
Hit http://archive.ubuntu.com edgy-updates/main Packages
Hit http://archive.ubuntu.com edgy-updates/restricted Packages
Hit http://archive.ubuntu.com edgy-updates/multiverse Packages
Hit http://archive.ubuntu.com edgy-updates/universe Packages
Ign http://linuxmce.com ./ Release.gpg
Ign http://linuxmce.com ./ Translation-en_GB
Ign http://linuxmce.com ./ Release
Ign http://linuxmce.com ./ Packages
Errhttp://linuxmce.com ./ Packages
  404 Not Found
Failed to fetch http://linuxmce.com/ubuntu/./Packages.gz  404 Not Found
Fetched 3B in 18s (0B/s)
Reading package lists...
E: Some index files failed to download, they have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
pluto-dcerouter is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up pluto-system-database (1.0) ...


Setting up system database.
****This may take a long time****
This involves merging all the changes from the
central database back into your local copy.
Please be patient.......
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
This program is distributed according to the terms
of the Pluto Public License, available at:
 http://plutohome.com/index.php?section=public_license
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the Pluto Public License for more details.

-------

Database host:localhost user:root pass: name:pluto_main port:3306
Users:
01   03/31/07 19:43:46.410      Connect failed Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) <0xb7b736b0>
01   03/31/07 19:43:46.410      Connect failed Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) <0xb7b736b0>
***ERROR*** Cannot connect to database.
Please modify the configuration settings and restart sqlCVS.
dpkg: error processing pluto-system-database (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pluto-std-plugins:
 pluto-std-plugins depends on pluto-system-database (>= 1.0); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-system-database (<< 1.1); however:
  Package pluto-system-database is not configured yet.
dpkg: error processing pluto-std-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pluto-dcerouter:
 pluto-dcerouter depends on pluto-std-plugins (>= 1.0); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-std-plugins (<< 1.1); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-system-database (>= 1.0); however:
  Package pluto-system-database is not configured yet.
 pluto-dcerouter depends on pluto-system-database (<< 1.1); however:
  Package pluto-system-database is not configured yet.
dpkg: error processing pluto-dcerouter (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pluto-system-database
 pluto-std-plugins
 pluto-dcerouter
E: Sub-process /usr/bin/dpkg returned an error code (1)

ERROR : Failed to install and configure the base software


can you help me?

Thx

ralphiex

  • First post!
  • Posts: 1
    • View Profile
Re: LinuxMCE installation failed: pluto errors
« Reply #1 on: March 31, 2007, 10:26:36 pm »
I had that same problem.  What I did was reinstall Edgy and before trying to reinstall MCE, I installed vim.

$ sudo apt-get install vim

Everything worked perfect after that.  There are a few other threads that have this info in it, but removing vim initially did not work for me.  With the clean install it worked fine.

Good Luck


juster

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: LinuxMCE installation failed: pluto errors
« Reply #2 on: April 01, 2007, 10:58:05 am »
I've tried to intall vim. Here's what I get:

Quote
Setting up system database.
****This may take a long time****
This involves merging all the changes from the
central database back into your local copy.
Please be patient.......
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
 Copyright (C) 2004 Pluto, Inc., a Florida Corporation
 www.plutohome.com
 Phone: +1 (877) 758-8648
This program is distributed according to the terms
of the Pluto Public License, available at:
 http://plutohome.com/index.php?section=public_license
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the Pluto Public License for more details.

-------

Database host:localhost user:root pass: name:pluto_main port:3306
Users:
01      04/01/07 10:43:21.311           Connect failed Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) <0xb7b3a6b0>
01      04/01/07 10:43:21.312           Connect failed Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) <0xb7b3a6b0>
***ERROR*** Cannot connect to database.
Please modify the configuration settings and restart sqlCVS.
dpkg: error processing pluto-system-database (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pluto-std-plugins:
 pluto-std-plugins depends on pluto-system-database (>= 1.0); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-system-database (<< 1.1); however:
  Package pluto-system-database is not configured yet.
dpkg: error processing pluto-std-plugins (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pluto-dcerouter:
 pluto-dcerouter depends on pluto-std-plugins (>= 1.0); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-std-plugins (<< 1.1); however:
  Package pluto-std-plugins is not configured yet.
 pluto-dcerouter depends on pluto-system-database (>= 1.0); however:
  Package pluto-system-database is not configured yet.
 pluto-dcerouter depends on pluto-system-database (<< 1.1); however:
  Package pluto-system-database is not configured yet.
dpkg: error processing pluto-dcerouter (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pluto-system-database
 pluto-std-plugins
 pluto-dcerouter
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now I'm gonna reinstall Edgy...

Rtax

  • Making baby steps
  • Posts: 2
    • View Profile
Re: LinuxMCE installation failed: pluto errors
« Reply #3 on: April 12, 2007, 07:13:48 pm »
I'm getting the same error:

Quote
dpkg: error processing pluto-dcerouter (--configure):
 dependency problems - leaving unconfigured
Setting up pluto-boot-scripts (1.0) ...

Setting up pluto-createdevice (1.0) ...

Setting up pluto-confirm-dependencies (1.0) ...
Setting up pluto-install-scripts (1.0) ...
Setting up pluto-website-admin (1.0) ...
ln: creating symbolic link `/usr/pluto/orbiter/floorplans' to `/home/pluto/floorplans': File exists
dpkg: error processing pluto-website-admin (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 pluto-database-settings
 pluto-sqlcvs
 pluto-media-database
 pluto-security-database
 pluto-telecom-database
 pluto-local-database
 pluto-system-database
 pluto-std-plugins
 pluto-dcerouter
 pluto-website-admin
E: Sub-process /usr/bin/dpkg returned an error code (1)

ERROR : Failed to install and configure the base software

Tried uninstalling vim, not sure what that is supposed to do or how it would affect it, but I have ubuntu already running with mythtv etc, so I don't want to reinstall edgy...

Any ideas??

Bionic

  • First post!
  • Posts: 1
    • View Profile
Re: LinuxMCE installation failed: pluto errors
« Reply #4 on: April 15, 2007, 12:41:32 am »
I had to downgrade vim-common to 1:7.0-035 before I could get vim to install.
Going to give MCE another shot now ::crosses fingers::

Rtax

  • Making baby steps
  • Posts: 2
    • View Profile
Re: LinuxMCE installation failed: pluto errors
« Reply #5 on: April 16, 2007, 06:33:58 pm »
Got further...

Stuck now, I'm getting dependency errors installing pluto-dcerouter because of a failure in pluto-website-admin. So those two packages aren't installing. Any ideas?

deffcon

  • Veteran
  • ***
  • Posts: 94
    • View Profile
Re: LinuxMCE installation failed: pluto errors
« Reply #6 on: May 06, 2007, 10:12:28 pm »
dpkg --configure pluto-website-admin
dpkg --configure pluto-dcerouter

then reboot, if all goes well you can have an up and running LinuXmce

Greetz,,


Deffcon