Author Topic: Unmet dependencies for pluto-dcerouter - Broken Package  (Read 3167 times)

funzoh

  • Newbie
  • *
  • Posts: 6
    • View Profile
Unmet dependencies for pluto-dcerouter - Broken Package
« on: April 26, 2007, 05:15:46 pm »
Hi there,

I have kind of a problem while installing LinuxMCE.
I am running Ubuntu 7.04, changes some settings and file links. After that the Installer started successfully. Sadly enough, the installation dies with the following message:

*******************
The following packages have unmet dependencies:
  pluto-dcerouter: Depends: pluto-confirm-dependencies (>= 1.0) but it is not going to be installed
                   Depends: pluto-confirm-dependencies (< 1.1) but it is not going to be installed
                   Depends: pluto-createdevice (>= 1.0) but it is not going to be installed
                   Depends: pluto-createdevice (< 1.1) but it is not going to be installed
                   Depends: pluto-install-scripts (>= 1.0) but it is not going to be installed
                   Depends: pluto-install-scripts (< 1.1) but it is not going to be installed
                   Depends: pluto-local-database (>= 1.0) but it is not going to be installed
                   Depends: pluto-local-database (< 1.1) but it is not going to be installed
                   Depends: pluto-orbitergen (>= 1.0) but it is not going to be installed
                   Depends: pluto-orbitergen (< 1.1) but it is not going to be installed
                   Depends: pluto-std-plugins (>= 1.0) but it is not going to be installed
                   Depends: pluto-std-plugins (< 1.1) but it is not going to be installed
                   Depends: pluto-system-database (>= 1.0) but it is not going to be installed
                   Depends: pluto-system-database (< 1.1) but it is not going to be installed
                   Depends: pluto-website-admin (>= 1.0) but it is not going to be installed
                   Depends: pluto-website-admin (< 1.1) but it is not going to be installed
                   Depends: pluto-boot-scripts (>= 1.0) but it is not going to be installed
                   Depends: pluto-boot-scripts (< 1.1) but it is not going to be installed
                   Depends: mce-diskless-tools (>= 1.0) but it is not going to be installed
                   Depends: mce-diskless-tools (< 1.1) but it is not going to be installed
                   PreDepends: ssh
                   PreDepends: vim but it is not going to be installed
                   PreDepends: samba but it is not going to be installed
                   PreDepends: bind9 but it is not going to be installed
E: Broken packages
*******************


Does anybody know what I can do about it?

Kind regards,

Funzoh.

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #1 on: April 26, 2007, 05:40:44 pm »
install by hand ssh, vim, samba and bind.
Read the F****** Logs!!!

funzoh

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #2 on: April 26, 2007, 09:02:04 pm »
I have tried to do so by using the following command after logging in using su:

1. "apt-get install ssh"
result 1a:

The following packages have unmet dependencies:
  ssh: Depends: openssh-server but it is not going to be installed


After that I used the command "apt-get install openssh-server"...
result 1b:

The following packages have unmet dependencies:
  openssh-server: Depends: openssh-client (= 1:4.3p2-5ubuntu1) but 1:4.3p2-8ubuntu1 is to be installed


After this I used the command "apt-get install openssh-client"
result 1c:

openssh-client is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The same thing for vim: first vim, then vim-common, which results in the latest version already being installed.
The same thing for samba: first samba, then samba-common, which results in the latest version already being installed.
The same thing for bind9: first bind9, then libisccfg1/libisc11/libisccc0, which all result in the latest version already being installed.

Could this have anything having to do with Ubuntu version 7.04 being used as host-OS in stead of 6.10, or am I doing something wrong here?

Funzoh.

funzoh

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #3 on: April 27, 2007, 09:30:27 am »
OK, I have "read the F****** Logs!!!" and I found a topic in which the installation solution was stated.
I will repeat it for those that might have problems finding the same topics...

First I removed openssh-client, samba-common, libisccfg1, libisc11, libisccc0 and vim-common. by using the command "apt-get remove name of the service.
Second I installed the correct version by using the command apt-get install name of the service.
When I completed these actions, I was able to succesfully complete the installation.
If I'm not mistaking, there were 2 other services which failed, but I was able to find them in the mce installation log and completed the same actions as stated above.

I will be configuring LinuxMCE soon and I think I will enjoy it once it is up and running!  :)

LordK1

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #4 on: April 27, 2007, 12:41:09 pm »
Same problem here.

I follow the instructions, and here is the new log :

MESSAGE: Seting Up Networking
There is already a pid file /var/run/dhclient.pid with pid 9726
removed stale PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit newbielink:http://www.isc.org/sw/dhcp/ [nonactive]

Listening on LPF/eth0/00:16:17:c1:eb:55
Sending on   LPF/eth0/00:16:17:c1:eb:55
Sending on   Socket/fallback
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.104 -- renewal in 36814 seconds.
MESSAGE: Setting up APT Package Manager
ln: création d'un lien symbolique `/etc/apt/apt.conf.d/99offline' vers `/usr/pluto/var/apt.conf.offline': Le fichier existe.
MESSAGE: Preseeding debconf options
Ign file: ./ Release.gpg
Ign file: ./ Translation-fr
Ign file: ./ Release
Ign file: ./ Packages
Réception de : 1 newbielink:http://archive.ubuntu.com [nonactive] edgy Release.gpg [191B]
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/main Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/restricted Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/multiverse Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/universe Translation-fr
Réception de : 2 newbielink:http://archive.ubuntu.com [nonactive] edgy-security Release.gpg [191B]
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/main Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/restricted Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/multiverse Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/universe Translation-fr
Réception de : 3 newbielink:http://archive.ubuntu.com [nonactive] edgy-updates Release.gpg [191B]
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/main Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/restricted Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/multiverse Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/universe Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy Release
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security Release
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates Release
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/main Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/restricted Packages
Ign newbielink:http://linuxmce.com [nonactive] ./ Release.gpg
Ign newbielink:http://linuxmce.com [nonactive] ./ Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/multiverse Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/universe Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/main Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/restricted Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/multiverse Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/universe Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/main Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/restricted Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/multiverse Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/universe Packages
Ign newbielink:http://linuxmce.com [nonactive] ./ Release
Ign newbielink:http://linuxmce.com [nonactive] ./ Packages
Atteint newbielink:http://linuxmce.com [nonactive] ./ Packages
3o réceptionnés en 1s (2o/s)
Lecture des listes de paquets...
MESSAGE: Generating Default Config File
MESSAGE: Configuring Network Information Service (NIS)
Mounting CD
MESSAGE: Caching LinuxMCE CD on the harddrive
MESSAGE: Installing LinuxMCE Base Software
Ign file: ./ Release.gpg
Ign file: ./ Translation-fr
Ign file: ./ Release
Ign file: ./ Packages
Réception de : 1 newbielink:http://archive.ubuntu.com [nonactive] edgy Release.gpg [191B]
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/main Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/restricted Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/multiverse Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/universe Translation-fr
Réception de : 2 newbielink:http://archive.ubuntu.com [nonactive] edgy-security Release.gpg [191B]
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/main Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/restricted Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/multiverse Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-security/universe Translation-fr
Réception de : 3 newbielink:http://archive.ubuntu.com [nonactive] edgy-updates Release.gpg [191B]
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/main Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/restricted Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/multiverse Translation-fr
Ign newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/universe Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy Release
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security Release
Ign newbielink:http://linuxmce.com [nonactive] ./ Release.gpg
Ign newbielink:http://linuxmce.com [nonactive] ./ Translation-fr
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates Release
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/main Packages
Ign newbielink:http://linuxmce.com [nonactive] ./ Release
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/restricted Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/multiverse Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy/universe Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/main Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/restricted Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/multiverse Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-security/universe Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/main Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/restricted Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/multiverse Packages
Atteint newbielink:http://archive.ubuntu.com [nonactive] edgy-updates/universe Packages
Ign newbielink:http://linuxmce.com [nonactive] ./ Packages
Atteint newbielink:http://linuxmce.com [nonactive] ./ Packages
3o réceptionnés en 1s (2o/s)
Lecture des listes de paquets...
Lecture des listes de paquets...
Construction de l'arbre des dépendances...
Lecture de l'information d'état...
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  pluto-dcerouter: Dépend: pluto-orbitergen (>= 1.0) mais ne sera pas installé
                   Dépend: pluto-orbitergen (< 1.1) mais ne sera pas installé
                   Dépend: mce-diskless-tools (>= 1.0) mais ne sera pas installé
                   Dépend: mce-diskless-tools (< 1.1) mais ne sera pas installé
E: Paquets défectueux

ERROR : Failed to install and configure the base software



Sorry, ism French, so it's all in french :)

I also tried to apply some others solution found in thoses pages, but no probing result yet.

Can somebody help a poor froggy lost in linux?


[edit]Entire log as you want it[/edit]
« Last Edit: April 27, 2007, 12:45:06 pm by LordK1 »

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #5 on: April 27, 2007, 12:43:17 pm »
please post the whole log.
Read the F****** Logs!!!

LordK1

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #6 on: April 27, 2007, 12:48:40 pm »
Post edited.

Thank for helping so fast.

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #7 on: April 27, 2007, 01:09:36 pm »
it seems that temporarily the packages are not on the servers or there are some problems with network connection. try later.
Read the F****** Logs!!!

Provide

  • Regular Poster
  • **
  • Posts: 24
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #8 on: April 28, 2007, 05:59:16 pm »
I believe I have found a workaround for this issue.

1) Install a fresh Ubuntu 6.10. Once installed, go right into installing MCE. DO NOT UPDATE ANYTHING.
2) Install MCE.

Before, I would try to install MCE after fully updating 6.10 but pluto-dcerouter wouldn't install, causing the MCE installer to error out. I am currently installing MCE without any updates and there haven't been any issues yet.

funzoh

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Unmet dependencies for pluto-dcerouter - Broken Package
« Reply #9 on: April 29, 2007, 08:13:42 pm »
To solve that same problem, I had to remove the "netbase" component by using the "apt-get remove netbase"-command.
After that I manually installed the following components:

i.   Libsdl1.2debian-all
ii.   Pluto-orbitergen
iii.   Netbase

by using the "apt-get install component"-command.
After this, my installation succeeded.

Greetings,

Funzoh.