Author Topic: Network boot times out, Cant access Admin, Network Places...  (Read 1505 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Have yet to successfully get pluto to run a media director so here is what I did and here is my problem. I ran the installation wizard and setup a media director d/led the kickstart cd and installed on a dedicated pc. Installation seemed to go fine the screen is currently telling me Running and accepting connections. The media director is set to network boot, it attempts to however never receives instructions and just boots xp normally. I cannot access the Pluto Admin Site. I also cannot see pluto in My Network Places. Ok this is how I have it connected. Incoming hardline to the core. From the core hardline to the media director. Any help to resolve this would be apprechiated I'm going a little bonkers.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Network boot times out, Cant access Admin, Network Places...
« Reply #1 on: June 02, 2005, 07:23:28 pm »
It sounds like the cables are perhaps not setup.  Let's do a quick check.

First, from on the core, press Alt+F2, and login as root with the root password you chose during installation.  At the command prompt type "ifconfig".

You wrote: "Incoming hardline to the core. From the core hardline to the media director."  So I assume that means you have 2 network cards.  You should see an eth0 and an eth1.  One will be the 'external' network card that gets the internet connection, the other the internal one that all the other devices (like media directors) connect to.

Type:
ping -I eth0 plutohome.com
(let it try to 'ping' our web site a few times and press ctrl+c to abort) then:
ping -I eth1 plutohome.com

one should report that it successfully pinged plutohome.com.  The other that it didn't.  The one that did ping plutohome.com is the external, the other one is the internal.  Going back to ipconfig, the internal network should be IP address 192.168.80.1.

If your other PC is connected to the internal network, check that it got an IP addrss in the 192.168.80.x range, and you can access pluto admin at newbielink:http://192.168.80 [nonactive].1   If your other pc is connected to the external network first disable the firewall by typing this:
iptables -P INPUT ACCEPT
then go to http:// plus whatever ip address you saw on ipconfig for the external.

If you got this far, your cables are ok.  Confirm the media director is plugged into a switch that is also plugged into the *internal* network.  Type:

ps aux | grep dhcp

you shoud see:

/usr/sbin/dhcpd3 -q eth0

(or eth1).  Confirm that eth0/1 is the internal network.  Now, type:

tail -f /var/log/syslog

You'll see system messages scrolling by on the screen.  Turn on the media director.  If it's connected, you will see a DHCP request message in the log scroll by, and it will have the mac address of the media director, and the IP address it was given (usually 192.168.80.2, or .3., or .4, etc).

Then you will see the log saying it offered a network boot image.

You can stop tailing the system log by pressing Ctrl+c.

If you get stuck, let me know what happened or how your system deviates from what I've described.  Network boot has been stable for a long time, so it's probably something really simple.

Aaron