Author Topic: Samba shares and updatemedia  (Read 692 times)

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 857
    • View Profile
Samba shares and updatemedia
« on: February 16, 2018, 07:12:49 pm »
Both have suddenly stopped working. Today I had to reboot my server and since then I am unable to access the fileshares from my windowsbox. it always asks for my credentials. The samba logs say that it found a misconfigured server role and exits

While checking around I also saw that updatemedia is producing a segfault. there seems to be an error in libstdc++.6.0.19

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3647
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Samba shares and updatemedia
« Reply #1 on: February 17, 2018, 11:31:17 am »
Just as a headsup: I am on trusty i386, and things are humming along nicely. My UpdateMedia process had something like 17000 minutes of runtime, before I for kicks disabled it just now, and reenabled it afterwards.

Check the files you added recently, and see if removing them again, make your problem go away.

If that works, add one by one again, and see which one is causing the issues.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 857
    • View Profile
Re: Samba shares and updatemedia
« Reply #2 on: February 17, 2018, 01:20:29 pm »
I had a little chat yesterday with Tschak and he asked me to get an output from gdb for that and create a ticket.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3647
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Samba shares and updatemedia
« Reply #3 on: February 17, 2018, 05:16:08 pm »
I know. If you want to get further, I would suggest following my questions.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 857
    • View Profile
Re: Samba shares and updatemedia
« Reply #4 on: February 18, 2018, 12:54:56 pm »
Thanks for the advice...I tried, but it didn't really help so far...maybe I need to do some more digging. I also found out that it seems to have "forgotten" a lot of my audio files, for they were not in the database and they were not new either.

darkwizard864

  • Veteran
  • ***
  • Posts: 107
    • View Profile
Re: Samba shares and updatemedia
« Reply #5 on: February 18, 2018, 03:15:23 pm »
maverick0815
are you using 14.04? if you are I had same probem when I did apt-get update and upgrade.
i got to work by reinstalling updatemedia package.
also see if your media drives are online.