Author Topic: Won't work on Ubuntu Feisty  (Read 6421 times)

medeshago

  • First post!
  • Posts: 1
    • View Profile
Won't work on Ubuntu Feisty
« on: April 12, 2007, 05:21:59 pm »
medeshago@nosotros:/usr/share/mce-installer$ sh mce-installer.sh

Linux MCE Installer Starting ... please wait

./mce-installer: error while loading shared libraries: liboobs-1.so.2: cannot open shared object file: No such file or directory

I have liboobs-1-3. Don't know what to do.

sharlee_angelo

  • Guru
  • ****
  • Posts: 316
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #1 on: April 12, 2007, 06:10:30 pm »
mce-installer was built with a previous version of liboobs. if you want to install it, you must downgrade the liboobs package.
Read the F****** Logs!!!

zagnoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #2 on: April 13, 2007, 11:21:44 am »
I've resolved creating liboobs-1.so.2 -> liboobs-1.so.3 softlink.
Code: [Select]
cd /usr/lib
ln -s liboobs-1.so.3 liboobs-1.so.2




lucasvo

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #3 on: April 15, 2007, 01:18:50 pm »
I've resolved creating liboobs-1.so.2 -> liboobs-1.so.3 softlink.
Code: [Select]
cd /usr/lib
ln -s liboobs-1.so.3 liboobs-1.so.2


I did the same, however, the installation still failed because of dependency  problems:

Code: [Select]

The following packages have unmet dependencies:
  pluto-dcerouter: Depends: pluto-confirm-dependencies (>= 1.0) but it is not going to be installed
                   Depends: pluto-confirm-dependencies (< 1.1) but it is not going to be installed
                   Depends: pluto-createdevice (>= 1.0) but it is not going to be installed
                   Depends: pluto-createdevice (< 1.1) but it is not going to be installed
                   Depends: pluto-install-scripts (>= 1.0) but it is not going to be installed
                   Depends: pluto-install-scripts (< 1.1) but it is not going to be installed
                   Depends: pluto-local-database (>= 1.0) but it is not going to be installed
                   Depends: pluto-local-database (< 1.1) but it is not going to be installed
                   Depends: pluto-orbitergen (>= 1.0) but it is not going to be installed
                   Depends: pluto-orbitergen (< 1.1) but it is not going to be installed
                   Depends: pluto-std-plugins (>= 1.0) but it is not going to be installed
                   Depends: pluto-std-plugins (< 1.1) but it is not going to be installed
                   Depends: pluto-system-database (>= 1.0) but it is not going to be installed
                   Depends: pluto-system-database (< 1.1) but it is not going to be installed
                   Depends: pluto-website-admin (>= 1.0) but it is not going to be installed
                   Depends: pluto-website-admin (< 1.1) but it is not going to be installed
                   Depends: pluto-boot-scripts (>= 1.0) but it is not going to be installed
                   Depends: pluto-boot-scripts (< 1.1) but it is not going to be installed
                   Depends: mce-diskless-tools (>= 1.0) but it is not going to be installed
                   Depends: mce-diskless-tools (< 1.1) but it is not going to be installed
                   PreDepends: ssh
                   PreDepends: vim but it is not going to be installed
                   PreDepends: samba but it is not going to be installed
                   PreDepends: bind9 but it is not going to be installed
EDIT: I tried to install samba:
Code: [Select]
lucasvo@lama:~$ sudo apt-get install samba
Password:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  samba: Depends: samba-common (= 3.0.22-1ubuntu4.1) but 3.0.24-2ubuntu1 is to be installed
E: Broken packages


« Last Edit: April 15, 2007, 01:21:05 pm by lucasvo »

lithorus

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #4 on: April 15, 2007, 03:01:55 pm »
I just tried installing it aswell and can only STRONGLY warn about not installing it on Feisty unless you know excactly what you're doing. It seems to replace the sources.llist with stuff for edgy only. Can severally break your system. I'm quite astonished it doesn't even make a backup of the original sources.list.

Edit:
After the failed installation apt was broken. I found out that it also inserts some apt.conf.d files with some rather bad settings.

/etc/apt/apt.conf.d/30pluto contains the option
Code: newbielink:javascript:void(0); [nonactive]
Apt::Cache-Limit "12582912"; which is too low for my setup.
I have to admit I'm quite dissapointed how the installer is so careless.

Btw for the missing liboobs-1.so.2 you can just install the liboobs-1.2 package instead
« Last Edit: April 15, 2007, 03:13:31 pm by lithorus »

lucasvo

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #5 on: April 15, 2007, 03:40:12 pm »
Well, the problem is, that the linux mce packages require specific versions of the packages from ubuntu main. So it only works with edgy. too bad. I don't really want to downgrade.

 I wonder when it will be fixed.

lithorus

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #6 on: April 15, 2007, 03:47:30 pm »
Sure only supporting 1 distro is one thing, but hardcoding the sources.list is something completely different.

Apt/dpkg is there to handle dependencies. If it's already built around Ubuntu only there is no reason not to use it for the installation process.

lucasvo

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #7 on: April 15, 2007, 05:22:13 pm »
Yes, changing without backup is not a very good thing to do.

Did anyone succeed in installing it on feisty?

zagnoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #8 on: April 16, 2007, 03:12:34 pm »
I've installed, with success, on feisty!
after relink the library liboobs I have encoutered installation dependecy problem.
To solve this problem I've removed all package predepends and then reinstall pluto-dcerouter.

lucasvo

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #9 on: April 16, 2007, 07:44:21 pm »
Ok, I'll try to change the dependencies of the packages. I just have to figure out how to do it. thanks

lucasvo

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #10 on: April 16, 2007, 09:06:25 pm »
zagnoni, could you please give me a quick how2?

zagnoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #11 on: April 17, 2007, 03:05:25 pm »
before restart apt-get install pluto-dcerouter, try to remove ssh, vim, samba and bind9 packages with
apt-get remove ssh vim samba bind9.
If all is done! restart mce installer



thynk

  • Regular Poster
  • **
  • Posts: 41
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #12 on: April 17, 2007, 09:21:53 pm »
Zargoni, congrats on getting this working!  Maybe for the rest of us that don't dabble under the hood as much, could you give a detailed step by step of what you've done?  I'm not clear on what steps you took from start to finish.

Stu


zagnoni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #13 on: April 19, 2007, 06:04:20 pm »
This is the procedure.
Remember that to install Linuxmce on Feisty you must downgrade some package to Edgy version!
When you run mce-installer, the source.list of apt will be updated with repository of Edgy!! because it was built on ubuntu 6.10.

Code: [Select]
sudo sh +x /usr/share/mce-installer/mce-installer.sh
 
Linux MCE Installer Starting ... please wait
 
./mce-installer: error while loading shared libraries: liboobs-1.so.2: cannot open shared object file: No such file or directory

Code: [Select]
sudo ln -s /usr/lib/liboobs-1.so.3 /usr/lib/liboobs-1.so.2
sudo sh +x /usr/share/mce-installer/mce-installer.sh

The following packages have unmet dependencies:
  pluto-dcerouter: Depends: pluto-confirm-dependencies (>= 1.0) but it is not going to be installed
                   Depends: pluto-confirm-dependencies (< 1.1) but it is not going to be installed
                   Depends: pluto-createdevice (>= 1.0) but it is not going to be installed
                   Depends: pluto-createdevice (< 1.1) but it is not going to be installed
                   Depends: pluto-install-scripts (>= 1.0) but it is not going to be installed
                   Depends: pluto-install-scripts (< 1.1) but it is not going to be installed
                   Depends: pluto-local-database (>= 1.0) but it is not going to be installed
                   Depends: pluto-local-database (< 1.1) but it is not going to be installed
                   Depends: pluto-orbitergen (>= 1.0) but it is not going to be installed
                   Depends: pluto-orbitergen (< 1.1) but it is not going to be installed
                   Depends: pluto-std-plugins (>= 1.0) but it is not going to be installed
                   Depends: pluto-std-plugins (< 1.1) but it is not going to be installed
                   Depends: pluto-system-database (>= 1.0) but it is not going to be installed
                   Depends: pluto-system-database (< 1.1) but it is not going to be installed
                   Depends: pluto-website-admin (>= 1.0) but it is not going to be installed
                   Depends: pluto-website-admin (< 1.1) but it is not going to be installed
                   Depends: pluto-boot-scripts (>= 1.0) but it is not going to be installed
                   Depends: pluto-boot-scripts (< 1.1) but it is not going to be installed
                   Depends: mce-diskless-tools (>= 1.0) but it is not going to be installed
                   Depends: mce-diskless-tools (< 1.1) but it is not going to be installed
                   PreDepends: ssh
                   PreDepends: vim but it is not going to be installed
                   PreDepends: samba but it is not going to be installed
                   PreDepends: bind9 but it is not going to be installed
E: Broken packages
 
ERROR : Failed to install and configure the base software

Code: [Select]
sudo apt-get remove ssh openssh-client vim vim-runtime vim-common samba bind9 netbase samba-common  libisccfg1 libisc11 libisccc0 apache2-utils apache2-common apache2-mpm-prefork samba* libsdl1.2debian-all
sudo apt-get autoremove
sudo apt-get install libsdl1.2debian-all

sudo sh +x /usr/share/mce-installer/mce-installer.sh

That's all.




sandos

  • Regular Poster
  • **
  • Posts: 36
    • View Profile
Re: Won't work on Ubuntu Feisty
« Reply #14 on: April 19, 2007, 10:02:23 pm »
I know Debian does not officially support downgrading of packages at all, I'm sure Ubuntu doesn't either :)

Just a little useless warning ;)