Author Topic: Video Card Recommendations?  (Read 845 times)

cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Video Card Recommendations?
« on: February 15, 2017, 03:05:38 pm »

I am still working on getting my new diskless MD to work at 1080i with my Sony CRT TV. In an earlier post I reported that the install would not complete with an older nVidia Geforce 7300 card, apparently because of incompatibility with current drivers. I am also having difficulty with my onboard Intel graphics, which I believe to be specific to my MB. I would like to try a new nVidia card. Before I purchase, I thought it would be good to get a recommendation from the community. I know a lot of compatibility information used to be in the wiki but it is hard to discern what is current.

My options are:

GeForce 8400
GeForce GT 710
GeForce 210

All are low end cards, costing about $30 before rebates, $15 to $20 after.

The most important thing for me to be able to set the video mode to 1080i using xorg.conf, overriding EDID information, as I have with my core that uses Intel graphics. I tried an ATI card yesterday but this does not seem possible with the proprietary driver that is installed by default. I did try to create my own EDID file, using info from another monitor, as advised in various forms, without success. At this point I just want something that is known to work.

Is anyone setting video modes using xorg.conf with one of the cards listed above? Otherwise what are recommendations?

Thanks,

CDM



posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3598
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Video Card Recommendations?
« Reply #1 on: February 15, 2017, 07:27:45 pm »
Maybe Raspberry Pis are an option:

http://elinux.org/RPi_Screens

cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: Video Card Recommendations?
« Reply #2 on: February 15, 2017, 10:00:22 pm »

Well, I went and bought the GT 710 card. It doesn't work. This chipset was released in early 2016.

Does anyone have an nVidia card working under 14.04? Which one?

CDM


cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: Video Card Recommendations?
« Reply #3 on: February 15, 2017, 10:26:45 pm »

For reference..

Code: [Select]

root@dcerouter:/usr/pluto/diskless/82/usr/pluto/bin# cat /usr/pluto/diskless/82/var/log/pluto/nvidia-install.log
== Begin NVidia driver installation (Wed Feb 15 16:07:22 EST 2017) ==
Card Detected: 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208 [GeForce GT 710B] [10de:128b] (rev a1)
PCI_Id Detected: 128b
LMCE prefers driver nvidia-352
installing NEW driver nvidia-352!
== End NVidia driver installation (Wed Feb 15 16:14:42 EST 2017) ==
root@dcerouter:/usr/pluto/diskless/82/usr/pluto/bin#


cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: Video Card Recommendations?
« Reply #4 on: February 15, 2017, 10:39:21 pm »
To clarify, the symptom is the same as before, failure to reboot the second time during the diskless MD install. Could this be a problem with the install script? is there a way to see which packages are actually installed midway through the install process?

CDM
« Last Edit: February 15, 2017, 10:40:59 pm by cafedumonde »

ardirtbiker

  • Guru
  • ****
  • Posts: 287
    • View Profile
Re: Video Card Recommendations?
« Reply #5 on: February 16, 2017, 03:03:26 am »
I've modified the nvidia-install.sh in /usr/pluto/bin folder.  I've got a card that only works with the nvidia-304 driver.  In the file, any reference to nvidia-xxx was changed to nvidia-304.  This procedure got me up and running

Sent from my SM-G900V using Tapatalk


cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: Video Card Recommendations?
« Reply #6 on: February 16, 2017, 03:08:10 am »
Much progress!!

I went back and read Phenegma's earlier advice to change the driver version in nvidia-install.sh. and tried once again with my original GeForce 7300 card. I figured if the GT 710 wasn't working then the problem is not the card. This time, I used the nvidia-304 driver. The system completes the diskless install and AVWizard functions as it should.

and now the next challenge...

When I select the Composite output, 1080i does not appear in the resolution choices.  However, HD480p and HD720p do. Selecting 480p, I am able to complete the wizard and LMCE works fine with my old video card and TV. It looks OK but I want 1080i. (BTW I *have* made 1080i visible in Resolutions.conf. )

Adding the exit line to Xconfigure.sh, I *am* able to input the modeline for 1080i in xorg.conf and the TV syncs up fine. However, the orbiter is not the correct size. I have tried running AVWizard with Xconfigure turned off but I am unable to generate a 1920x1080 orbiter.

It seems there are two possible solutions:

1: Allow 1080i to be selected in combination with a composite output in AV Wizard. (preferred)

2: Use xorg.conf to force the 1080i video mode and find a way to resize the orbiter.

Please help. Any feedback on which path to follow would be greatly appreciated.

CDM




cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: Video Card Recommendations?
« Reply #7 on: February 16, 2017, 03:10:06 am »

Thanks for the reply artdirtbiker. Your post came in just as I was typing the update. Indeed the nvidia-304 driver was the way to go. Any advice on how to resize the orbiter?

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1712
    • View Profile
Re: Video Card Recommendations?
« Reply #8 on: February 16, 2017, 03:10:51 pm »
The orbiter size can be selected in webadmin and then the orbiter can be regen'd.

J.

cafedumonde

  • Veteran
  • ***
  • Posts: 112
    • View Profile
Re: Video Card Recommendations?
« Reply #9 on: February 16, 2017, 07:33:52 pm »


All is working now, thanks to help from darkwizard. :-)

S4Howie

  • Regular Poster
  • **
  • Posts: 25
    • View Profile
Re: Video Card Recommendations?
« Reply #10 on: March 13, 2017, 09:48:16 pm »
I just want to say i have never had problems with any nvidia card install at either core ore client setup. I used old ones like 7300 and 7600GT. I use a GT210 atm in 1 MD which installed without any problems at first setup,screen was a PhillipsTV 1080i,in Audio/Video Wizard i set HDMI/1920x1080/60Hz in Audio Section choose HDMI too,there will be no sound then but its ok,later there is no isuess with sound, just mythtv needs some audio setting adjustments.

Another MD i have has Intel Graphic Chipset on board,setup was also no problem. Boot up for the first time into A/V Wizard,choose the wanted resolution,and everythings fine. Its running UI2 in 1080i aswell.

On my Core/Hybrid i have a intel Server Mainboard with a Matrox Graphic Chipset,even this showd me a picture from the very first install. Its just UI1 but it runs,resolution is 800x600 cause i dont really use it as an MD.

So i can advice everybody with a generic pc setup as md choose a nvidia 7600GT and newer over any other card if you want it working without issues. Or choose a mainboard with Intel Graphics onboard if you want a budget UI2 out of the box.

Howie