Author Topic: Installing Diskless MDs  (Read 3273 times)

cafedumonde

  • Veteran
  • ***
  • Posts: 111
    • View Profile
Re: Installing Diskless MDs
« Reply #15 on: February 11, 2017, 12:35:46 am »

OK. I had a look at the script and there is a variable defined as follows:

Code: [Select]
LogFile="/var/log/pluto/nvidia-install.log";

The script apples logic based on the kind of nvidia card that is detected so, I need to know which version code is associated with my card. I am assuming that it would be logged in the log file. However, the log file does not exist in /var/log/pluto. I am guessing that it may have been nuked when I rebuilt the MD without the nvidia card in the machine.

I am happy to put the card back in and have a look to see if the file is created. Is that the right approach? Is there another way to figure out which code would be returned by my card so that I can discern the right part of the script.

Sorry for the newbie question.

CDM

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1711
    • View Profile
Re: Installing Diskless MDs
« Reply #16 on: February 11, 2017, 12:38:31 am »
I wouldn't worry about the id for your card yet.  Find the bit where it determines the driver and set them all to nvidia-340. 

Sent from my Nexus 5 using Tapatalk


cafedumonde

  • Veteran
  • ***
  • Posts: 111
    • View Profile
Re: Installing Diskless MDs
« Reply #17 on: February 11, 2017, 02:07:53 am »

Which one should I edit? There are two options:

/usr/pluto/diskless/82/usr/pluto/bin/nvidia-install.sh
/usr/pluto/bin/nvidia-install.sh

I am guessing that the diskless one will get nuked if I rebuild the MD again.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1711
    • View Profile
Re: Installing Diskless MDs
« Reply #18 on: February 11, 2017, 02:08:53 am »
The one on the MD, under the diskless directory.  Moon 82.

Sent from my Nexus 5 using Tapatalk


cafedumonde

  • Veteran
  • ***
  • Posts: 111
    • View Profile
Re: Installing Diskless MDs
« Reply #19 on: February 11, 2017, 09:59:21 pm »

No luck. I made the change to the file, reinstalled the card, and rebuilt the MD in webadmin. The system failed to boot the second time during the install process. Then, I pulled the card, rebuilt again and got to the AV wizard, as before. At this point, I'll just use the HDMI to component converter box.

Thanks for the help nonetheless.

CDM

maverick0815

  • wants to work for LinuxMCE
  • **
  • Posts: 835
    • View Profile
Re: Installing Diskless MDs
« Reply #20 on: April 02, 2017, 02:40:24 pm »
guys, I have quite a similar problem. After performing an update on my md (asrock ion330) it wouldn't boot anymore. So I too rebuilt the image, which resultet in "45/initrd.img" not being found.
So I rans "usr/pluto/bin/Diskless_CreateTBZ.sh", which ran without detecting any issues, but it seemed quite fast...usually it takes around an hour- this was done after 25 Minutes
I deleted the MD and let it create a new one, which gave me "77/initrd.img" not found.
So what do I do now? Please advise.

Running on 12.04
Cheers
Mario


-------------
I found out that initrd.img points to initrd.img-3.13.0-105-generic and vmlinuz to vmlinuz-3.13.0-105-generic
for both files there ias however a 3.16.0-77 present
« Last Edit: April 02, 2017, 02:45:19 pm by maverick0815 »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5544
  • DOES work for LinuxMCE.
    • View Profile
Re: Installing Diskless MDs
« Reply #21 on: April 02, 2017, 05:54:43 pm »
Looks like you had a kernel mismatch happen. The easiest ways to resolve this are:

* Delete the MD in the web admin, and let it reinstall.
* symlink the default initrd and vmlinuz image to your media director's image.

-Thom

maverick0815

  • wants to work for LinuxMCE
  • **
  • Posts: 835
    • View Profile
Re: Installing Diskless MDs
« Reply #22 on: April 02, 2017, 08:48:54 pm »
Unfortunately its not that easy. I tried deleting the orbiter and reinstall it. It boots up fine the first time, but then installs the nvidia-drivers and reboots. That is when the shit hits the fan. I followed the symlinks from /tftpboot down to the orbiter...none of them are broken. I assume there are supposed to be only two links in /tftpboot/86/ one for vmlinuz and one for initrd.img. The kernel-version on the core and the md are different- I don't know if that is of significance.
Other than that, I have no idea, why 86/initrd.img not found is being reported. I also verified the permissions and that seems to be okay too.
I'm stumped

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3596
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Installing Diskless MDs
« Reply #23 on: April 02, 2017, 08:57:29 pm »
As you seem to have issues with your IRC connection, here are a couple of hints:

* ls -l the relevant directories (tftpboot, diskless/xx, diskless/xx/boot, and paste output in here.
* cut the relevant log information, and paste in here.

darkwizard864

  • Veteran
  • ***
  • Posts: 97
    • View Profile
Re: Installing Diskless MDs
« Reply #24 on: April 02, 2017, 09:26:12 pm »
Maverick0815 i have seen that problem before make sure your kernel image has 0644 permission.

maverick0815

  • wants to work for LinuxMCE
  • **
  • Posts: 835
    • View Profile
Re: Installing Diskless MDs
« Reply #25 on: April 03, 2017, 09:37:28 pm »
I don't know...1&1 seemed to have some issues with me yesterday
here ist the content of /usr/pluto/diskless/86/boot
Quote
total 44188
-rw-r--r-- 1 root root  1214709 Jun 28  2016 abi-3.16.0-77-generic
-rw-r--r-- 1 root root   176220 Jun 28  2016 config-3.16.0-77-generic
lrwxrwxrwx 1 root root       56 Apr  2 19:51 initrd.img -> /usr/pluto/diskless/86/boot/initrd.img-3.16.0-77-generic
-rw-r--r-- 1 root root 34468576 Apr  2 19:14 initrd.img-3.16.0-77-generic
-rw-r--r-- 1 root root   176500 Mär 12  2014 memtest86+.bin
-rw-r--r-- 1 root root   178176 Mär 12  2014 memtest86+.elf
-rw-r--r-- 1 root root   178680 Mär 12  2014 memtest86+_multiboot.bin
-rw-r--r-- 1 root root      843 Apr  3 21:30 pastebinit
-rw-r--r-- 1 root root  2795312 Jun 28  2016 System.map-3.16.0-77-generic
lrwxrwxrwx 1 root root       53 Apr  2 19:52 vmlinuz -> /usr/pluto/diskless/86/boot/vmlinuz-3.16.0-77-generic
-rw-r--r-- 1 root root  6034368 Jun 28  2016 vmlinuz-3.16.0-77-generic
this is diskless/86
Quote
total 80
drwxr-xr-x   2 root root  4096 Apr  2 13:51 bin
drwxr-xr-x   2 root root  4096 Apr  3 21:30 boot
drwxr-xr-x   3 root root  4096 Apr  2 13:50 dev
drwxr-xr-x 144 root root 12288 Apr  2 19:15 etc
drwxr-xr-x   4 root root  4096 Apr  2 13:48 home
lrwxrwxrwx   1 root root    33 Apr  2 13:37 initrd.img -> boot/initrd.img-3.16.0-77-generic
drwxr-xr-x  22 root root  4096 Apr  2 19:09 lib
drwxr-xr-x   2 root root  4096 Apr  2 13:48 media
drwxr-xr-x   3 root root  4096 Apr  2 13:40 mnt
drwxr-xr-x   2 root root  4096 Apr  2 13:33 opt
drwxr-xr-x   2 root root  4096 Apr 11  2014 proc
drwx------   6 root root  4096 Apr  2 13:43 root
drwxr-xr-x  14 root root  4096 Apr  2 13:48 run
drwxr-xr-x   2 root root  4096 Apr  2 19:10 sbin
drwxr-xr-x   2 root root  4096 Apr  2 13:33 srv
drwxr-xr-x   2 root root  4096 Mär 13  2014 sys
drwxrwxrwt   5 root root  4096 Apr  2 19:14 tmp
drwxr-xr-x  11 root root  4096 Apr  2 13:34 usr
drwxr-xr-x  14 root root  4096 Apr  2 13:48 var
lrwxrwxrwx   1 root root    30 Apr  2 13:37 vmlinuz -> boot/vmlinuz-3.16.0-77-generic
this is tftpboot/86
Quote
total 0
lrwxrwxrwx 1 root root 33 Apr  2 19:06 initrd.img -> /usr/pluto/diskless/86/initrd.img
lrwxrwxrwx 1 root root 30 Apr  2 19:06 vmlinuz -> /usr/pluto/diskless/86/vmlinuz

so far so good...what logs do I need to check?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3596
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Installing Diskless MDs
« Reply #26 on: April 03, 2017, 11:33:59 pm »
Your list is strange.

Your initrd image is 34468576 bytes big. It is named initrd.img-3.16.0-77-generic, but initrd.img-3.16.0-77-generic on my system is only 28213576 bytes. However, a new kernel (initrd.img-4.4.0-62-generic)  is around 34 million bytes.

This looks like something got screwed.

See what happens when you a reinstall of linux-image-3.16.0-77-generic, ie.
Code: [Select]
chroot /usr/pluto/diskless/86
apt-get install --reinstall linux-image-3.16.0-77-generic
exit

and try booting again.

The maximum size our current tftp server supports is <32MB

maverick0815

  • wants to work for LinuxMCE
  • **
  • Posts: 835
    • View Profile
Re: Installing Diskless MDs
« Reply #27 on: April 04, 2017, 07:03:53 pm »
What happened is this and the result is the same
Quote
dcerouter_1047595:/home/linuxmce# chroot /usr/pluto/diskless/86
root@dcerouter:/# apt-get install --reinstall linux-image-3.16.0-77-generic
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_TIME = "de_DE.UTF-8",
        LC_MONETARY = "de_DE.UTF-8",
        LC_ADDRESS = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_NUMERIC = "de_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
grep: /proc/cpuinfo: No such file or directory
This kernel does not support a non-PAE CPU.
dpkg: error processing archive /var/cache/apt/archives/linux-image-3.16.0-77-generic_3.16.0-77.99~14.04.1_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.16.0-77-generic_3.16.0-77.99~14.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@dcerouter:/#

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3596
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Installing Diskless MDs
« Reply #28 on: April 04, 2017, 08:59:27 pm »
Google for chroot mounting dev and proc  - do that outside the chroot, and try again.

maverick0815

  • wants to work for LinuxMCE
  • **
  • Posts: 835
    • View Profile
Re: Installing Diskless MDs
« Reply #29 on: April 08, 2017, 02:01:23 pm »
Sorry for the delay. I did my googling and this is the outcome so far:
Quote
login as: linuxmce
linuxmce@dcerouter's password:
Welcome to Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-115-generic i686)

 *
linuxmce@dcerouter:~$ sudo su
[sudo] password for linuxmce:
dcerouter_1047595:/home/linuxmce# mount --bind /proc /usr/pluto/diskless/86/proc
dcerouter_1047595:/home/linuxmce# mount --bind /dev /usr/pluto/diskless/86/dev
dcerouter_1047595:/home/linuxmce# mount --bind /sys /usr/pluto/diskless/86/sys
dcerouter_1047595:/home/linuxmce# chroot /usr/pluto/diskless/86
root@dcerouter:/# apt-get install --reinstall linux-image-3.16.0-77-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libglamor0 libllvm3.4
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/15.6 MB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  linux-image-3.16.0-77-generic
Authentication warning overridden.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_TIME = "de_DE.UTF-8",
        LC_MONETARY = "de_DE.UTF-8",
        LC_ADDRESS = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_NUMERIC = "de_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
E: Can not write log (Is /dev/pts mounted?) - openpty (2: No such file or directory)
(Reading database ... 116678 files and directories currently installed.)
Preparing to unpack .../linux-image-3.16.0-77-generic_3.16.0-77.99~14.04.1_i386.deb ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Done.
Unpacking linux-image-3.16.0-77-generic (3.16.0-77.99~14.04.1) over (3.16.0-77.99~14.04.1) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
Setting up linux-image-3.16.0-77-generic (3.16.0-77.99~14.04.1) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Not updating initrd symbolic links since we are being updated/reinstalled
(3.16.0-77.99~14.04.1 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(3.16.0-77.99~14.04.1 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
update-initramfs: Generating /boot/initrd.img-3.16.0-77-generic
cryptsetup: WARNING: failed to detect canonical device of 192.168.80.1:/usr/pluto/diskless/86
cryptsetup: WARNING: could not determine root device from /etc/fstab
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
run-parts: executing /etc/kernel/postinst.d/update-symlinks 3.16.0-77-generic /boot/vmlinuz-3.16.0-77-generic
chmod: cannot operate on dangling symlink '/boot/initrd.img'
chmod: cannot operate on dangling symlink '/boot/vmlinuz'
chmod: cannot operate on dangling symlink '/boot/initrd.img'
chmod: cannot operate on dangling symlink '/boot/vmlinuz'
/ /
/
root@dcerouter:/#