Author Topic: Samba woes.  (Read 1907 times)

armakaryk

  • Newbie
  • *
  • Posts: 7
    • View Profile
Samba woes.
« on: April 09, 2007, 02:26:22 am »
so im having some serious samba trouble. the linux mce machine appears on the windows network from a windows machine but the message "The Server service has not started" comes up and i cant pint the linux machine from the doze. now on the other side when i enter into the network neighborhood not even the workgroup comes up but i can ping the doze machine from the linux. at this point i have a mega headache.
here is a dump of my smb.conf file maybe you guys can see something im missing?

[global]
        workgroup = WIREDHOME
        server string = DCERouter
        security = SHARE
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
        username map = /etc/samba/usermap.txt
        log level = 2
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        smb ports = 139
        dns proxy = No
        invalid users = root

[public]
        comment = public files
        path = /home/public/data
        read only = No
        create mask = 0777
        directory mask = 0777
        guest ok = Yes

[home]
        comment = shared home files
        path = /home
        force user = root
        force group = root
        read only = No
        guest ok = Yes

[alexander]
        comment = alexander's private files
        path = /home/user_1
        read only = No
        create mask = 0770
        directory mask = 0770

armakaryk

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Samba woes.
« Reply #1 on: April 09, 2007, 06:09:46 am »
Alrighty kids i've figured out the cause and now i have the cure.
apparently linux mce's firewall blocks port 139. now samba uses port 139 fairly exclusively ( you can change it but thats alot of hassle) so if your having network trouble go into the firewall settings from the pluto admin page and add port 139 to allowed ports list. problem solved. if you concerned about security you can restricted the port to access from certain IPs. so there you ahve it. took me all day to figure out a 30 second fix.

efiniti

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: Samba woes.
« Reply #2 on: April 13, 2007, 03:27:59 am »
Thanks for the info, got my port forwarded.  However, I'm running into some samba issues as well and I hope its ok to just add this to your thread instead of just making a new one.  I want to be able to write to any folder within my public folder. 

I started taking a look at the smb.conf file.  So far I've added the 'guest ok = yes' option under [public] and i've changed 'security = user' to 'security = share'.  I then restarted the samba daemon.  But apparently I still can't drop files from my Suse 10.2 box to my LinuxMCE box.  Its giving me an "Error "Access Denied" while copying ..." Has anyone run into this before?  Here's my smb.conf:

## @FileType: Pluto Sectioned Config File ##
## @Version: 1 ##
## @KeepSections: ##
## @RemoveSections: ##

[global]
## BEGIN : Domain and Hostname

        workgroup = LinuxMCE
        server string = DCERouter
        netbios name = DCERouter

## END : Domain and Hostname
        smb ports = 139
        log level = 2
        invalid users = root
        log file = /var/log/samba/log.%m
        max log size = 1000
        syslog = 0
        encrypt passwords = true
        socket options = TCP_NODELAY
        dns proxy = no
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spa$
        username map = /etc/samba/usermap.txt
        unix extensions = yes
        security = share

[public]
        comment = public files
        browseable = yes
        writable = yes
        create mask = 0777
        directory mask = 0777
        path = /home/public/data
        public = yes
        guest ok = yes

[home]
        comment = shared home files
        browsable = yes
        writable = yes
        path = /home
        public = no
        guest ok = no
        force user = root
        force group = root

## BEGIN : User Shares

## END : User Shares

armakaryk

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Samba woes.
« Reply #3 on: April 15, 2007, 01:44:27 am »
yeah i think i know want your problem is. i ran into this a while ago when i made a debian server. all you gotta do is sudo chmod 777 /home/public/data...... with the ..... representing all the sub-folders in the data file. if that doesnt work see if you can ping the computers from each other. if you cant then theres still a firewall problem. post your results when your done.

efiniti

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: Samba woes.
« Reply #4 on: April 15, 2007, 04:22:16 am »
yeah i couldn't ping the computer.  i turned off the firewall and i can ping it now, but when i try to drop the file in there it still gives me that error.

efiniti

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: Samba woes.
« Reply #5 on: April 15, 2007, 04:25:52 am »
yay!  i tried changing the permissions recursively again and this time it worked.  I think i typed in a different permission earlier..  thank you!!

oh btw, i forgot what the command was to list the contents of the current directory with the permissions for each file and folder.  anyone happen to remember it?  i thought ls could do that, but maybe i'm wrong. 

wierdbeard65

  • Guru
  • ****
  • Posts: 449
    • View Profile
    • My Quest
Re: Samba woes.
« Reply #6 on: April 15, 2007, 09:30:22 am »
I think you are looking for
Code: [Select]
ls -lor, if you want hidden files as well (those beginning with a ".")
Code: [Select]
ls -alHTH
Paul
If you have the time to help, please see where I have got to at: http://wiki.linuxmce.org/index.php/User:Wierdbeard65

efiniti

  • Regular Poster
  • **
  • Posts: 23
    • View Profile
Re: Samba woes.
« Reply #7 on: April 15, 2007, 03:20:56 pm »
ah yes!  thanks!