Author Topic: 12.04 update on fresh install  (Read 1544 times)

ardirtbiker

  • Guru
  • ****
  • Posts: 308
    • View Profile
12.04 update on fresh install
« on: January 28, 2016, 12:53:55 am »
Gentlemen,

I did a fresh 12.04 install on a new SSD drive.  Once installed, I ran Diskless_CreateTBZ.  It failed with the following:
Code: [Select]
The following packages have unmet dependencies:
 lmce-md-meta : Depends: pluto-boot-scripts (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-boot-scripts (< 2.0.0.47) but it is not going to be installed
                Depends: pluto-confirm-dependencies (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-confirm-dependencies (< 2.0.0.47) but it is not going to be installed
                Depends: lmce-install-scripts (>= 2.0.0.46) but it is not going to be installed
                Depends: lmce-install-scripts (< 2.0.0.47) but it is not going to be installed
                Depends: pluto-orbitergen (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-orbitergen (< 2.0.0.47) but it is not going to be installed
                Depends: pluto-avwizard (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-avwizard (< 2.0.0.47) but it is not going to be installed
                Depends: lmce-launch-manager (>= 2.0.0.46) but it is not going to be installed
                Depends: lmce-launch-manager (< 2.0.0.47) but it is not going to be installed
                Depends: pluto-hald (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-hald (< 2.0.0.47) but it is not going to be installed
                Depends: pluto-orbiter (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-orbiter (< 2.0.0.47) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
./Diskless_CreateTBZ.sh: line 170: /tmp/TeeMyOutputExitCode_26444: No such file or directory


So, poking around, I did an apt-get update followed by an apt-get upgrade:
Code: [Select]
cerouter_1047429:/usr/pluto/bin# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  lmce-diskless-tools lmce-install-scripts pluto-boot-scripts pluto-hald
  pluto-orbitergen pluto-system-database pluto-website-admin
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
dcerouter_1047429:/usr/pluto/bin#

showing 7 not upgraded.... will not let me upgrade any of them:
Code: [Select]
dcerouter_1047429:/usr/pluto/bin# apt-get install lmce-diskless-tools
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lmce-diskless-tools : Depends: pluto-boot-scripts (>= 2.0.0.46.201601231149.f3a444c0bc) but 2.0.0.46.16010131783 is to be installed
                       Depends: pluto-plutodhcp (>= 2.0.0.46.201601231149.f3a444c0bc) but 2.0.0.46.16010531792 is to be installed
E: Unable to correct problems, you have held broken packages.
dcerouter_1047429:/usr/pluto/bin#

what I see as the possible problem is the version info not being met.  Im no pro, but it looks like the date/time section is missing the '20' in front of the 16.


anyone got any resolutions?

Thanks,
Dennis


posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3668
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 12.04 update on fresh install
« Reply #1 on: January 28, 2016, 06:49:28 am »
The main issue is not the century in front, but the dot behind the date/time. I'll see to it today.

ardirtbiker

  • Guru
  • ****
  • Posts: 308
    • View Profile
Re: 12.04 update on fresh install
« Reply #2 on: January 29, 2016, 01:40:24 am »
You for sure would know more about that than I.   But i figured it had to be something to do with the version info.

Thanks for your efforts.

Dennis

zekis

  • First post!
  • Posts: 1
    • View Profile
Re: 12.04 update on fresh install
« Reply #3 on: January 29, 2016, 02:27:33 am »
Hi Posde,

I have been getting similar errors running Diskless_CreateTBZ.sh but with 14.04 straight out of the box LMCE-1404-20160101124031783-i386 DVD install.

It may be related.
Except apt-get install lmce-diskless-tools runs with no errors.


Code: [Select]
Fri Jan 29 03:15:13 AEDT 2016 - Installing lmce-md-meta for device 28
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lmce-md-meta : Depends: pluto-boot-scripts (>= 2.0.0.47) but it is not going to be installed
                Depends: pluto-boot-scripts (< 2.0.0.48) but it is not going to be installed
                Depends: pluto-confirm-dependencies (>= 2.0.0.47) but it is not going to be installed
                Depends: pluto-confirm-dependencies (< 2.0.0.48) but it is not going to be installed
                Depends: lmce-install-scripts (>= 2.0.0.47) but it is not going to be installed
                Depends: lmce-install-scripts (< 2.0.0.48) but it is not going to be installed
                Depends: pluto-orbitergen (>= 2.0.0.47) but it is not going to be installed
                Depends: pluto-orbitergen (< 2.0.0.48) but it is not going to be installed
                Depends: pluto-avwizard (>= 2.0.0.47) but it is not going to be installed
                Depends: pluto-avwizard (< 2.0.0.48) but it is not going to be installed
                Depends: lmce-launch-manager (>= 2.0.0.47) but it is not going to be installed
                Depends: lmce-launch-manager (< 2.0.0.48) but it is not going to be installed
                Depends: pluto-hald (>= 2.0.0.47) but it is not going to be installed
                Depends: pluto-hald (< 2.0.0.48) but it is not going to be installed
                Depends: pluto-orbiter (>= 2.0.0.47) but it is not going to be installed
                Depends: pluto-orbiter (< 2.0.0.48) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

From what i can tell lmce-md-meta is looking for 2.0.0.47 which according to aptitude is currently the installed version but I feel that create disk is trying to source the files from somewhere else, instead of using the ones already installed.

Zekis

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1747
    • View Profile
Re: 12.04 update on fresh install
« Reply #4 on: January 29, 2016, 05:35:57 am »
Keep in mind everyone that we have just switched from SVN to Git for our source control system.  This means that our package versioning has changed significantly.  The DVDs you are installing are from the old versioning system.  Our package builder is using incorrect versions for forcing depends, the issue is being worked on.  Please follow: http://wiki.linuxmce.org/index.php/LinuxMCE-1204/1404_Updates to see when changes are made and try again.  Thank you for reporting the issues you are having.

J.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1747
    • View Profile
Re: 12.04 update on fresh install
« Reply #5 on: February 01, 2016, 07:56:05 pm »
The repository has been fixed up.

J.