Author Topic: none of my phones register...  (Read 2273 times)

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
none of my phones register...
« on: November 10, 2015, 06:50:56 pm »
for a while now my phones don't work anymore. I'm sorry, but I cannot exactly say which update killed it. Just today I restarted asterisk.
This is what /var/log/pluto/Asterisk.log contained:
Quote
05   11/10/15 7:49:28.098      Going to rotate logs... <0xb65ffb40>
05   11/10/15 17:26:13.056      Got a reload command from 0  <0xb65ffb40>
05   11/10/15 17:26:13.522      void ClientSocket::Disconnect() on this socket: 0x9804248 (m_Socket: 6) <0xb6f66700>
Return code: 2
2   11/10/15 17:26:13   17 (spawning-device)   Device requests restart... count=1/50 dev=17
Tue Nov 10 17:26:13 CET 2015 Restart
========== NEW LOG SECTION ==========
1   11/10/15 17:26:21   17 (spawning-device)   Starting... 1
1   11/10/15 17:26:21   17 (spawning-device)   Found /usr/pluto/bin/Asterisk
05   11/10/15 17:26:22.595      Connect() failed, Error Code 111 (Connection refused)) <0xb6f76700>
05   11/10/15 17:26:23.596      Connect() failed, Error Code 111 (Connection refused)) <0xb6f76700>
05   11/10/15 17:26:24.597      Connect() failed, Error Code 111 (Connection refused)) <0xb6f76700>
05   11/10/15 17:26:27.607      Server IP: 127.0.0.1 <0xb6f76700>
05   11/10/15 17:26:27.646      Trying to connect to Asterisk daemon to see if is running. <0xb6f76700>
05   11/10/15 17:26:27.646      Creating child 50 <0xb6f76700>
05   11/10/15 17:26:27.646      Note: Device manager has attached a device of type 1734 that this has no custom event handler for.  It will not fire events. <0xb6f76700>
05   11/10/15 17:26:27.646      Note: Device manager has attached a device of type 1734 that this has no custom handler for.  This is normal for IR. <0xb6f76700>
05   11/10/15 17:26:27.646      Creating child 51 <0xb6f76700>
05   11/10/15 17:26:27.646      Note: Device manager has attached a device of type 1734 that this has no custom event handler for.  It will not fire events. <0xb6f76700>
05   11/10/15 17:26:27.647      Note: Device manager has attached a device of type 1734 that this has no custom handler for.  This is normal for IR. <0xb6f76700>
05   11/10/15 17:26:27.685      NotifyCallsStatus status:
No such command 'iax2 show peers' (type 'core show help iax2 show' for other possible commands)
 <0xb5bffb40>
01   11/10/15 18:41:47.476      Error occured while receiving token. Disconnecting. <0xb5bffb40>

I'm using 12.04. My phones are two Gigaset 610IP Phones.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3669
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: none of my phones register...
« Reply #1 on: November 10, 2015, 10:05:08 pm »
The pluto log won't be of much help.

Turn off your phone
connect to your asteriisk by running asterisk -cr on the core
Type core set verbose 3
Turn on your phone
See what happens

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1749
    • View Profile
Re: none of my phones register...
« Reply #2 on: November 16, 2015, 07:25:20 pm »
The command to reload configuration files changed with the asterisk upgrade.  Look for this to be fixed in the next update.

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: none of my phones register...
« Reply #3 on: November 17, 2015, 08:44:06 pm »
fixed :-) great work

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1749
    • View Profile
Re: none of my phones register...
« Reply #4 on: November 17, 2015, 09:16:04 pm »
Awesome!  Thanks for the feedback!

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: none of my phones register...
« Reply #5 on: November 20, 2015, 04:31:32 pm »
No Problem, however...and I truly hate myself for saying this,...reboot of dcerouter still requires reboot of asterisk in my case.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1749
    • View Profile
Re: none of my phones register...
« Reply #6 on: November 20, 2015, 06:50:39 pm »
Well that just sucks.  Question, when you say reboot dcerouter do you mean rebooting the core pc or reloading the dcerouter?  Anytime we re-write the dial-play asterisk reloads its' configuration.  I guess we need to trace the boot process specifically in relation to asterisk.  Thanks for the feedback.  Let me know if you find anything else out.  I'll gander some more over the weekend and see what I can see.

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: none of my phones register...
« Reply #7 on: November 20, 2015, 08:31:12 pm »
tell me about it :-) anyways...reboot means completely rebooting the core. realoading dcerouter is no issue. re/booting however needs me to restart asterisk.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1749
    • View Profile
Re: none of my phones register...
« Reply #8 on: November 20, 2015, 10:03:10 pm »
ok, I've got something I'd like you to try, before I commit something.

Code: [Select]
asterisk -r -x "core reload"
can you add that line to /etc/init.d/linuxmce  after the line
Code: [Select]
StartService "Starting MySQL Server" "service mysql start" and let me know if that fixes things for you.

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: none of my phones register...
« Reply #9 on: November 22, 2015, 07:08:14 pm »
I've got a new problem....a phonecall arrives and upon hanging up, I get a reload router...
On the other hand...I will be away for a few days, so I can't do anything until this weekend.
« Last Edit: November 22, 2015, 07:10:06 pm by maverick0815 »

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1749
    • View Profile
Re: none of my phones register...
« Reply #10 on: November 22, 2015, 07:17:55 pm »
Can you be more specific on the 'on hanging up'.  Did this go to voicemail or was this a received call?  There are a bunch of actions that could lead to 'hanging up'.  :)

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: none of my phones register...
« Reply #11 on: November 23, 2015, 07:16:17 am »
In this particular case I accidentally placed a call from my cellphone to my landline. I cancelled the call on my cell, but the phone kept ringing, so I picked up and hung up again.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1749
    • View Profile
Re: none of my phones register...
« Reply #12 on: November 23, 2015, 02:18:08 pm »
Ick.  Okay.  I'm not sure what would be causing that.

J.