Author Topic: Joggler setup lmce-disked-mid-joggler  (Read 3847 times)

garagevibes

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Joggler setup lmce-disked-mid-joggler
« on: October 16, 2015, 08:45:01 pm »
Im having a few issues setting up a new joggler.
 I noticed the wiki has changed stating that a full stack can be installed with the following package: lmce-disked-mid-joggler but I get a dependancy error when I try to install this package on the latest squeezeos image of trusty.

I traced the dependancy issue to a Deb called lmce-core-locator so I checked the Deb.linuxmce.org source and found this package missing in the trusty image but I did see it in the precise image so I manually installed it from there instead.

The whole lmce-disked-mid-joggler Deb seemed to then install fine but when I try to boot the joggler it hangs at the squeeze is splash.
If I press esc it shows mounting errors but if I press S multiple times to skip this I eventually get to the announced ourselves to the router message but nothing seems to happen from there.

I can't see any new devices created in my core and the joggler will just sit there for hours.

Does anyone know of a fix for this? I'm currently running 12.04 on my core but the joggler is 14.04 not sure if this could be the issue.

Any help would be greatful cheers.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1752
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #1 on: October 16, 2015, 10:44:15 pm »
Hey, since I am the one responsible for creating all that (and our new firstboot process) I'll try to help.  :)

The long and short of it is that the trusty repository is not kept up to date the way the precise repo is.  We have a second repository that we use for development. 
Code: [Select]
deb http://deb.linuxmce.org/ trusty main

Try adding that to the sources.list prior to installing your packages.  The joggler has to announce itself to the router before it will be able to create devices.  Be sure your networking is setup properly prior to installing packages.  Once the joggler announces itself to the router the mounts (and other permissions) will be in place to boot, but not before.  The core-locater is necessary to locate the core's ip, without it nothing will work.

This new firstboot process is still working through a few bugs but the above should get you working.  Feel free to jump in to IRC for some real-time help as well.

Running your 1404 joggler on 1204 is not an issue, they are effectively fully compatible.  I run precise, trusty, wheezy, jessie in i386, amd64 & armhf all together.  :)

J.
« Last Edit: October 16, 2015, 11:18:31 pm by phenigma »

garagevibes

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #2 on: October 18, 2015, 02:56:31 pm »
Thanks you so much for the quick and detailed reply.

I've noticed all the work you've put in over the last few months the install process seems to be far easier now which is a great help as I had to reinstall my core last week.

Unfortunately this jogger booting still isn't working, it's a shame as I got really excited when I saw the wiki updated to allow a full stack to be installed something I've tried to do manually before but with a lot of effort.

I can always use the old manual orbiter instructions so please don't put to much work in to this I'm sure it will fix itself down the line when you get to it but to help with debugging I'll try and walk trough the issue now.

So your recommendation to change the source worked a treat and I had no dependancy issues installing the packages this time. The steps I took were flash a usb stick with squeeze os 303-trusty, then first I tried using wifi so I set this up in squeeze os, then rebooted and ssh to the joggler so I knew the networking was all set up fine, I then changed the source, updated and then installed the lmce-disked-mid-joggler package all went through fine and rebooted.

It then just hang on the squeeze os splash but by pressing esc I could see there was an error mounting so I skipped through these errors and got to the announced ourselves to the router message but looking at the string sent to the core the IP address was just that of an internal address so obviously the wifi connection hadn't connected so then I tried the above again but this time I used an Ethernet connection to set up squeezeos then installed the lmce-disked-mid-joggler package again with no errors and rebooted. This time the mounts still failed so I pressed s to skip through them again and got to the announced ourselves to the router message. The string that was sent to the core then had an IP address and my other orbiters then show a message about a joggler being discovered. I select the room the joggler is in and the joggler then runs some scripts and reboots.

Now though I again get it hanging at the splash screen due to mount errors so I skip through them and it goes back to the announced ourselves to the router message and another joggler gets added to the system and this goes in a loop, looking at the string sent to the core the MAC address is randomising each item and not holding like it should.

This is strange though as it worked fine in squeeze os, so any ideas would be greatful.

Many thanks again for everything

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1752
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #3 on: October 18, 2015, 08:31:39 pm »
Thanks for the detailed descriptions.  I have a really good idea as to what the issues are.

It looks like we need to move the MID/joggler firstboot scripts into the correct locations for the new firstboot methods in the general linuxmce stack.  Looking back it was the joggler setup that initiated the whole re-jig of pkgs and we need to bring the MID/joggler stuff up to par with the way the general lmce stack works now.  It'll take a day or so to changeover and test.  I'll try to have a look at it soon.  Until then you can certainly set things up the 'old' way.

The MAC address issue you talk about is a huge bug in the squeezeplay OS that doesn't manifest itselft until the squeezeplay os scripts are shut down.  There is a fix for that in our scripts, but they are not running correctly at the moment it seems.

It would be really great if you could create a trac ticket for this so that it shows up on my list of things to do.  ;)

J.

garagevibes

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #4 on: October 20, 2015, 04:09:48 pm »
Thanks for getting back to us,

I know the whole joggler MAC address thing is crazy I have no idea what O2's motive was when they made it duplicate the wifi adapter address and leave the network cards mac address blank, seems a bit crazy to me.

But anyway thanks for looking into it I even tried with another joggler that I flashed the eeprom on the network card with a real mac address previously and it has the same issue so its creating a fake address ok its just not saving it for the next boot.

I'm really sorry I've tried to create a ticket for this but I don't seem to have a log in for trac that or Im going mad and just cant log on :-[

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1752
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #5 on: October 20, 2015, 06:15:22 pm »
http://forum.linuxmce.org/index.php?topic=13696.0 this topic tells you the information we need to setup a trac account for you. 

J.

garagevibes

  • Regular Poster
  • **
  • Posts: 42
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #6 on: October 30, 2015, 01:36:23 pm »
Hi Phenigma,

sorry it took so long but I'm all setup now and I've created a ticket for this issue #2517

cheers again

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1752
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #7 on: October 30, 2015, 11:02:31 pm »
Thank you!

J.

cfernandes

  • Guru
  • ****
  • Posts: 359
    • View Profile
    • my company web site
Re: Joggler setup lmce-disked-mid-joggler
« Reply #8 on: November 05, 2015, 03:48:48 pm »
Hi Phenigma,

you had time to check this ?   

I  need to reinstall joggler.

and "old"  way  clock to work

Carlos

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1752
    • View Profile
Re: Joggler setup lmce-disked-mid-joggler
« Reply #9 on: November 05, 2015, 06:35:00 pm »
I have not had a chance to look extensively at it yet.

J.