Author Topic: 12.04 network card lost configuration  (Read 2892 times)

cfernandes

  • Guru
  • ****
  • Posts: 357
    • View Profile
    • my company web site
12.04 network card lost configuration
« on: July 27, 2015, 01:20:58 pm »
if  a hit  update button  on Admin Advanced->Network->Network Settings

and reboot  the  network card  is not configured.

  on table  Device_DeviceData  is inserted a empty config on end  like this

eth0,10.1.1.199,255.255.255.0,10.1.1.253,10.1.1.253,10.1.1.55|eth0:1,192.168.80.1,255.255.255.0|,,



pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1105
    • View Profile
Re: 12.04 network card lost configuration
« Reply #1 on: July 27, 2015, 07:03:21 pm »
Hi cfernandes,

Did you try a cold boot? (power supply off/wait 30 seconds/power supply on)

Cheers.

Alblasco1702

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: 12.04 network card lost configuration
« Reply #2 on: August 06, 2015, 12:39:27 pm »
Hello cfernandes,

How many network interfaces does your system have?
i'm extending the interface logic to accept more interfaces, seems something is wrong with the logic i worked out.
kan you provide me the output of ifconfig please?

Cheers,

-FR-

cfernandes

  • Guru
  • ****
  • Posts: 357
    • View Profile
    • my company web site
Re: 12.04 network card lost configuration
« Reply #3 on: August 06, 2015, 01:15:54 pm »
my ifconfig

eth0      Link encap:Ethernet  HWaddr 00:1e:c9:20:1c:1b
          inet addr:192.168.254.250  Bcast:192.168.254.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17400626 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27906956 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11832041832 (11.8 GB)  TX bytes:12769358879 (12.7 GB)
          Interrupt:21 Memory:febe0000-fec00000

eth0:1    Link encap:Ethernet  HWaddr 00:1e:c9:20:1c:1b
          inet addr:192.168.80.1  Bcast:192.168.80.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:21 Memory:febe0000-fec00000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6075146 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6075146 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2411847075 (2.4 GB)  TX bytes:2411847075 (2.4 GB)

Marie.O

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3675
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 12.04 network card lost configuration
« Reply #4 on: August 06, 2015, 04:01:48 pm »
cfernandes,

you are running a single NIC setup?

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1105
    • View Profile
Re: 12.04 network card lost configuration
« Reply #5 on: August 06, 2015, 05:16:18 pm »
Hi,

I've had that issue in the past.

I've had to cold boot to fix, or, swap ethernet cables with a cold boot, swap back cables, swap cards, disable mobo ethernet and add another peripheral card, etc.

At the moment my system is solid and I no longer (ATM) receive the 'waiting for network connection message' on a startup.


Cheers.

cfernandes

  • Guru
  • ****
  • Posts: 357
    • View Profile
    • my company web site
Re: 12.04 network card lost configuration
« Reply #6 on: August 07, 2015, 12:34:33 pm »
  yes I am using single card.
 one of my nic is burned and have not had time to replace it, everything was working fine until I hit save the network settings.

save in the database this way
eth0,10.1.1.199,255.255.255.0,10.1.1.253,10.1.1.253,10.1.1.55 | eth0: 1,192.168.80.1,255.255.255.0 |,,

the only way to return to work was correcting for

eth0,10.1.1.199,255.255.255.0,10.1.1.253,10.1.1.253,10.1.1.55 | eth0: 1,192.168.80.1,255.255.255.0