Author Topic: [SOLVED] 12.04 Aeon Z-Stick 2 - No Communication with Controller?  (Read 921 times)

davegravy

  • Addicted
  • *
  • Posts: 551
    • View Profile
[SOLVED] 12.04 Aeon Z-Stick 2 - No Communication with Controller?
« on: September 08, 2014, 06:48:31 am »
I added this device using PnP via orbiter.  After detection and device creation it appears LMCE is completely unable to communicate with the controller. See log:

http://paste.ubuntu.com/8287313/

This same stick in the same hardware config works on 1004.

Phenigma mentioned in IRC seeing similar issues but got things working by doing a few things including resetting his Z-stick. I will if there's no other choice, but I have all my node info from 1004 on the device and I'd rather not break that.

Not sure if it's abnormal but I've deleted and re-added the device several times, with the dongle in the same physical usb port, and the /dev/ttyUSB2 seems to change (it's shown up as USB0 an USB1 in the past)

Any ideas?

« Last Edit: September 09, 2014, 06:01:20 am by davegravy »

davegravy

  • Addicted
  • *
  • Posts: 551
    • View Profile
Re: [SOLVED] 12.04 Aeon Z-Stick 2 - No Communication with Controller?
« Reply #1 on: September 09, 2014, 06:02:01 am »
Some combination of unplugging/replugging and rebooting fixed it. Wish I could provide more info!

sambuca

  • Guru
  • ****
  • Posts: 462
    • View Profile
Re: [SOLVED] 12.04 Aeon Z-Stick 2 - No Communication with Controller?
« Reply #2 on: September 09, 2014, 08:46:17 am »
My guess is a combination of a lock-up of the stick (some Aeon sticks will lock up and have to be un/replugged to resume normal operation), and mismatch between the port configured and the actual port. (Re-plugging a device might assign it a new port as well).

br,
sambuca