General > Developers

Raspberry Pi Generic Serial Device

(1/2) > >>

SBCC:
Hello, has Generic Serial Device been built for the Raspberry MD? Doesn't seem to be loading it when I add a device. By the way great job on this!!! Starts up and runs fine. Video and sound. Thanks to everyone with that effort!

SBCC:
Sorry I acted to soon. It loaded and works fine. Serial ports aren't being listed correctly. Shows as platform/bcm2708_usb+1.3 but that gives me;

--- Code: ---Failed Opening serial port: platform/bcm2708_usb+1.3.
--- End code ---
If I change it in the database to /dev/ttyUSB0 works fine. I know I looked at this a while back and I believe Radu fixed it. I may dig into it more.

Thanks again!

phenigma:
Hey, sorry for the delay, I'm really busy.  I *though* gsd was built ok for the rpi.  If you could detail some of your specifics in a trac ticket with me as the owner I will have a look.   Thanks for testing btw!  I really appreciate it.

J.

SBCC:
Hi Jason

Thanks for getting back to me!

It is built. The problem I'm having is with PlutoUtils/LinuxSerialUSB. I keep coming up with
--- Code: ---TranslateSerialUSB platform/bcm2708_usb+1.2 isn't serial usb <0xb44ff460>
--- End code ---

That would mean that
--- Code: --- if( sInput.size()<6 || ( sInput.substr(0,3)!="pci" && sInput.substr(0,8) != "platform" ) )
{
LoggerWrapper::GetInstance()->Write(LV_STATUS,"TranslateSerialUSB %s isn't serial usb",sInput.c_str());
return sInput;
}

--- End code ---

Is not working as it should and it looks like it should so maybe it is old? I tried to setup a build environment again but lost your instructions and forgot how. I think I might be able to build it on the Pi but that could be slow. Do you have those instructions?

Thanks

Jim

SBCC:
Hi Jason

I just noticed you made that change to LinuxSerialUSB.cpp 3 weeks ago and my installation is older than that. I will upgrade and I'm sure that it will work. Thanks for your time and effort!

Jim

Navigation

[0] Message Index

[#] Next page

Sitemap 
Go to full version