Author Topic: eth0 and eth1 kernel driver in use - Resolved..  (Read 325 times)

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
eth0 and eth1 kernel driver in use - Resolved..
« on: May 15, 2014, 07:28:35 pm »
Hi,

I have a Realtek RTL8169 chip for eth0 and a Realtek RTL81111/8168/8411 for eth1.

I downloaded and installed the r8168 driver from Realtek.

eth0 shows kernel driver in use:r8169
kernel module r8169

eth1 shows kernel driver in use:r8169
kernel module r8168, r8169

How do you get eth1 to use the r8168 driver?

If I blacklist the r8169 driver eth0 dies completely - ifconfig only shows eth1.

I've tried creating alias eth0 r8169 & alias eth1 r8168 in various mod* types of files (plus other things) but nothing seems to work.

Is this even do-able?

Cheers.
« Last Edit: May 16, 2014, 11:17:06 pm by pigdog »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3009
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: eth0 and eth1 kernel driver in use.
« Reply #1 on: May 15, 2014, 07:29:45 pm »
I would check the original driver, move it out of the /lib tree, run depmod -a and reboot and see what happens.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: eth0 and eth1 kernel driver in use.
« Reply #2 on: May 15, 2014, 09:14:41 pm »
Hi posde,

I copied the r8169.ko to my Downloads directory and deleted the file in /lib/modules/3.2.0-61-generic/kernel/drivers/net/ethernet/realtek/

I did depmod -a

ifconfig shows eth0 & eth1.

lscpi -v still shows r8169 in use.

Cheers

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: eth0 and eth1 kernel driver in use.
« Reply #3 on: May 15, 2014, 09:21:52 pm »
Hi,

BTW eth0 shows kernel driver in use:r8169 but no kernel modules:

while eth1 is kernel driver in use:r8169  kernel modules:r8168

Cheers.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: eth0 and eth1 kernel driver in use.
« Reply #4 on: May 15, 2014, 11:09:06 pm »
Hi,

I went back and removed r8169 (again) from the directory, then after depmod -a I did update-initramfs -u and now no eth0.

Back to the drawing board.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: eth0 and eth1 kernel driver in use.
« Reply #5 on: May 16, 2014, 11:16:28 pm »
Hi,

I broke down (ya cheap bastard) and bought a $25.00 PCIe Gig NIC card.

I disabled the on-board NIC in the BIOS.

Reloaded from scratch.

I can now do mtu 9000 on the Core/Hybrid using the r8169 module.

Cheers.