Author Topic: NAS CIFS errors on April 13 28939 snap - Resolved.  (Read 357 times)

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
NAS CIFS errors on April 13 28939 snap - Resolved.
« on: April 14, 2014, 05:13:07 pm »
Hi,

Looks like some error reporting was turned on.

The handshaking between LMCE and DNS 323 NAS continues as reported in http://forum.linuxmce.org/index.php?topic=13577.0 reply #19 but I am now getting flooded with (it is spring) a few    Error connecting to socket - aborting operation     and continuous...

CIFS VFS: Send error in SessSetup = -13
CIFS VFS: cifs_mount failed w/return code = -13

Cheers.
« Last Edit: April 16, 2014, 10:52:30 pm by pigdog »

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: NAS CIFS errors on April 13 28939 snap
« Reply #1 on: April 15, 2014, 11:00:54 pm »
Hi,

I've gone through a lot of on-line stuff with solutions re: manually mounting drives etc. to get things to work.

O.K. I figure I could try to manually mount and set permissions and stuff but why? Really?

This use to work great in LMCE as is - was fantastic, phenomenal, etc, etc.

What is the underlying issue?

Are we looking at a 12.04 bug?

Just curious I guess.

Michaelree

  • Regular Poster
  • **
  • Posts: 17
    • View Profile
Re: NAS CIFS errors on April 13 28939 snap
« Reply #2 on: April 16, 2014, 05:01:51 pm »
I was getting the same errors as you cifs and link errors, I could be wrong but I think something changed in 12.04 version of cifs.  My NAS is just Ubuntu 12.04 with samba installed.  I think the problem with the link errors was because I did not have a username/password for my media share and therefor cifs was mounting it as an unsecured share.  I also had security = share in my smb.conf and I think that was giving the cifs mount error.  changing security = user I belive fixed it, but I did change several other setting in the smb.conf on my NAS.

See if setting the password in the webadmin to yourpassword,iocharset=utf8,sec=ntlm this allowed cifs to mount the drive before I changed any of my smb.conf setting.  I don't think the iocharset is really needed, but the sec=ntlm worked for me.

I could be totally wrong but was able to get the NAS to mount and it had nothing to do with LMCE.

pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: NAS CIFS errors on April 13 28939 snap
« Reply #3 on: April 16, 2014, 10:52:00 pm »
Hi Michaeltree,

FYI my smb.conf is exactly the same in 12.04 as it was in 10.04.

security = user   was already set.

My NAS was open (I'm a bad boy) but it was on an internal network where only LMCE devices could access it.

I played around but I could not get 12.04 to connect.

So to fix it I started from scratch, reloading the Core/Hybrid (because of so many things) and then added a username/password to the NAS.

In my smb.conf I had to add     client lanman auth = yes.

My Core/Hybrid upon NAS discovery asked for NAS credentials and everyone is happy.

I guess we can't be lazy anymore and leave storage devices unsecured.

Thanks for your input.

Cheers.
« Last Edit: April 16, 2014, 10:53:35 pm by pigdog »