General > Developers

O2 Joggler As full MD - Testing needed

(1/3) > >>

garagevibes:
Hi all,

First I'm not to sure where this topic could really lie so please move if needed be,

Basically I haven't invented anything I have just pulled various things together to try and get my Joggler to PXE boot as a full MD, however I have had some issues with my core lately and I don't currently have any other MD's to test so I wonder if anyone with a Joggler wants to try these instructions out and see if they get further than me :)

Ok so where to start first the joggler uses an EFI boot rom which is a stumbling point, however someone far clever than me has created a coreboot/seabios rom replacement for this which in essence will convert your Joggler from an almost atom based pc in to a full atom based pc, I have attached a copy of this but I take no credit its from the www.jogglerwiki.com forum its just here to help people locate it.

So here are the steps to get you to this point, you should note that you will be flashing your boot rom and wont be able to boot to the old software after this although if all goes well flashing back to the EFI boot rom is quite easy and if you have a second Joggler and you do happen to somehow completely brick one you can hot swap the boot rom from a working joggler to fix so this isn't as risky as it initially looks honest :)

so steps:
1 - Download the Joggler reflashing tool and updated openpeak firmware from this site:
http://birdslikewires.co.uk
2 - Follow instructions on the site to install the updated openpeak firmware.
3 - After doing this you are left with a Joggler that is up to date and that you can easily SSH to.
4 - Download the attached rom files on this post unzip and add to a newly formated FAT32 usb stick, there are 2 folders in this zip file one is a backup of the normal EFI boot rom the other is the new coreboot rom, copy the .rom file out of the coreboot folder and place on the root of the usb stick.
5 - Now place the usb stick into the Joggler and reboot.
6 - Check the DHCP address on the Joggler and SSH to the Joggler; username is joggler and password is joggler
7 - Now issue the following commands:

# cd /mnt
This will enter the USB stick
# ls
This will list the files on the stick and should show this:
 coreboot.rom
Now the next two lines will flash the boot rom:
# modprobe fh
# dd if=/mnt/coreboot.rom of=/dev/fh count=1 bs=1024k
Now finally reboot:
# reboot

after reboot you should now see a different boot splash with an icon of a shark, this is now your bios.

So now you have more of a standard PC than a Joggler you should be able to flash a standard disc image now to a usb stick and the Joggler will boot it even windows seems to work sort of but we want to PXE boot so next steps:

1 - Go to www.rom-o-matic.com and create a usb based PXE image and flash to a usb stick.
2 - Place usb stick into the joggler and connect a network cable between the joggler and your internal LMCE network.
3 - Restart joggler and you should boot in to iPXE which will configure the network card and then TFTP from the core.

Now this is as far as I have got, I then get a kernel panic at the point it seems that the initial PXE boot image passes over control to LMCE very much like an issue you would see with an incompatible network card.

Now there are 2 types of Joggler 1 has the r8168 network card the other has a r8169 network card I have the r8168 type and this known to have issues with LMCE so i followed the wiki to recreate the diskless image with the r8168 driver but without success.

As stated before though I have had issues with my core and I get the same error trying to PXE boot VMfusion on my Mac so I would be grateful if others could test this and see if they get the same results and also if anyone has any ideas of what the issue could be it would be great, I think it has something to do with drivers I just cant pin down what ones.

If after this you want to go back to the original EFI rom just place the back up .rom file in the zip attached on the root of a usb stick, place in the joggler, reboot and at the shark logo press the F7 key this will re flash the old EFI rom back and you will be back to a normal Joggler again.

Many thanks

PS seems I cant upload file attachments larger than 192KB so please download the roms from this link: http://www.tardistracker.com/roms.zip

posde:
Cool!

tschak909:
That is very cool.

I do believe a complete media director could be placed onto the mmc, with careful installation of packages on top of a distro such as SqueezePlayOS, but I haven't had time to fully retrofit the entire stack on top.

I have however been able to run SimplePhone, and a few more DCE devices directly on the Joggler, without a BIOS retrofit.

-Thom

garagevibes:
Thanks Thom,

Im afraid I have given up on the retrofitted Bios idea, it almost works gets as far as the passing over control from the PXE environment to the Linuxmce kernel but even though you can set a fake mac address in ipxe for the initial boot at the point Linuxmce seems to take over it runs ifconfig and gets the original blank mac address of the Jogglers network card again and reports FF:FF:FF:FF:FF and fails to add this to the database as it sees it as incorrect.

So I went back to running packages directly on the Joggler again, I followed your guide and got SimplePhone running really well, I then tried to adapt your guide to get xine installed so I could view video and audio, it seemed to almost work I now get a small black box over the orbiter and putting screen -ls in the terminal shows it running, plus I can select media to play and the orbiter now shows it playing but I get no audio or video so I'm probably missing off some needed packages.

I don't suppose you managed to get xine to run during your testing did you thom? or does anyone know what files are required for xine to run?

Many thanks

tschak909:
I would connect to Xine's screen session to see what errors are being emitted. You'll be able to debug from that.

Ctrl-a ] will get you a backscroll.

ESC will escape from that backscroll.

Ctrl-a d will gracefully disconnect you from the screen session.

-Thom

Navigation

[0] Message Index

[#] Next page

Sitemap 
Go to full version