Author Topic: web orbiter refresh  (Read 506 times)

cfernandes

  • Guru
  • ****
  • Posts: 290
    • View Profile
    • my company web site
web orbiter refresh
« on: March 06, 2014, 12:14:08 pm »
hello guys, already have a certain time that a situation bothers me, the refresh of the web orbiter, I have studied the code and saw that the function exists however it never happens unless manually.
I made a change in javascript and is now working.
I wonder if anyone else has this problem and if we could discuss with anyone who has more knowledge of the web orbiter which the impact of this change


Carlos

_if_

  • Guru
  • ****
  • Posts: 239
    • View Profile
Re: web orbiter refresh
« Reply #1 on: March 06, 2014, 05:54:22 pm »
wow, that would be a great benefit!

uplink

  • Administrator
  • Guru
  • *****
  • Posts: 191
  • Linux and LinuxMCE witchdoctor
    • View Profile
Re: web orbiter refresh
« Reply #2 on: March 06, 2014, 06:39:19 pm »
I made a change in javascript and is now working.

I hope I'm not asking for much, but... can we have that change posted here as well, so we can see it?

We may look like mind readers, but we are not :)

Thanks

EDIT:
I wonder if anyone else has this problem and if we could discuss with anyone who has more knowledge of the web orbiter which the impact of this change

That would be me BTW.

Each time this comes up I compare the Dianemo code with the LMCE code, and I don't see anything relevant that would prevent LMCE from refreshing. That's why I'm up in flames that you didn't write the slightest hint about what you did.
« Last Edit: March 06, 2014, 06:51:31 pm by uplink »

cfernandes

  • Guru
  • ****
  • Posts: 290
    • View Profile
    • my company web site
Re: web orbiter refresh
« Reply #3 on: March 06, 2014, 06:53:45 pm »
sorry for not sending my changes.

in my case is working on 10.04  including in security cameras via android orbiter


should be applied in weborbiter.js file in / var / www / lmce-admin / weborbiter


Carlos

uplink

  • Administrator
  • Guru
  • *****
  • Posts: 191
  • Linux and LinuxMCE witchdoctor
    • View Profile
Re: web orbiter refresh
« Reply #4 on: March 06, 2014, 08:39:25 pm »
Right... so what that says is that the problem is in the Proxy_Orbiter. It doesn't set the "anynews" response to "yes" when a new screen is generated.

What you did is to force a full image reload on each timeout - which might be OK on a LAN, but becomes strenuous on slower connections. The "anynews" flag is a small message by comparison.

I'll have to look in Orbiter and Proxy_Orbiter to figure out why that flag is not set to "yes" when the screen changes. That mechanism works fine in Dianemo.

uplink

  • Administrator
  • Guru
  • *****
  • Posts: 191
  • Linux and LinuxMCE witchdoctor
    • View Profile
Re: web orbiter refresh
« Reply #5 on: March 06, 2014, 08:58:24 pm »
OK... found the problem. Instead of "yes", I get "yes<LF>"... which of course doesn't match the test, so you don't get the refresh.

uplink

  • Administrator
  • Guru
  • *****
  • Posts: 191
  • Linux and LinuxMCE witchdoctor
    • View Profile
Re: web orbiter refresh
« Reply #6 on: March 06, 2014, 09:17:33 pm »
You'll be happy to know that the problem is now fixed: http://svn.linuxmce.org/trac/changeset/28792

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: web orbiter refresh
« Reply #7 on: March 06, 2014, 09:23:29 pm »
Thank you uplink and thank you cfernandez! This bug has been with us a LOOOOOONG time, and you two made it go away. New package is on its way, and should be in the repo sometime Friday.

cfernandes

  • Guru
  • ****
  • Posts: 290
    • View Profile
    • my company web site
Re: web orbiter refresh
« Reply #8 on: March 06, 2014, 09:26:25 pm »
yes I'm very happy

thank you

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: web orbiter refresh
« Reply #9 on: March 07, 2014, 06:37:59 am »
new pluto-website-admin package is live in the repo

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: web orbiter refresh
« Reply #10 on: March 07, 2014, 11:54:52 pm »
New update for 1004 as well. _IF_, i hope you like it.

_if_

  • Guru
  • ****
  • Posts: 239
    • View Profile
Re: web orbiter refresh
« Reply #11 on: March 08, 2014, 05:38:19 pm »
posde, did I ever mention that I love you?  ;D

thanks a lot, it's working perfectly!

IF

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: web orbiter refresh
« Reply #12 on: March 09, 2014, 11:07:20 am »
glad to be of help. feels good to be loved  ;D