Author Topic: Issues running Diskless_CreateTBZ.sh on 1004  (Read 293 times)

garagevibes

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Issues running Diskless_CreateTBZ.sh on 1004
« on: February 24, 2014, 08:59:38 pm »
Hi I gave 1204 a go last week but I've dropped back to 1004 for a moment till some of the issues I had get ironed out, however I have installed 1004 fine but whenever I run Diskless_CreateTBZ.sh I get the errors below, does anyone have any ideas?

Thanks
 
Code: [Select]
dcerouter_1039715:/home/daniel# sh /usr/pluto/bin/Diskless_CreateTBZ.sh
Mon Feb 24 19:50:52 GMT 2014 - Logging initiatilized to /var/log/pluto/Diskless_MD_Creation_20140224_195052.log
Mon Feb 24 19:50:52 GMT 2014 - BEGIN: Target: ubuntu - lucid - i386
Mon Feb 24 19:50:52 GMT 2014 - BEGIN: Host: ubuntu - lucid - i386
Mon Feb 24 19:50:52 GMT 2014 - Creating chroot for MD creation at: /tmp/Diskless_CreateTBZ.pNbBudatP
Mon Feb 24 19:50:52 GMT 2014 - Untarring /usr/pluto/install/PlutoMD_Debootstraped.tar.bz2
Mon Feb 24 19:51:05 GMT 2014 - Preparing the diskless system
Mon Feb 24 19:51:06 GMT 2014 - Setting up /etc/sources.list for HOST_DISTRO: ubuntu
Mon Feb 24 19:51:06 GMT 2014 - Setting up SSH
Mon Feb 24 19:51:06 GMT 2014 - Setting up Foxconn NT330i compatability
Mon Feb 24 19:51:06 GMT 2014 - PreSeeding package installation preferences
Reading package lists...
Building dependency tree...
Package debconf-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  debconf-i18n
E: Package debconf-utils has no installation candidate
An error (Exit code 100) occured during the last action
install of debconf-utils
dcerouter_1039715:/home/daniel#

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #1 on: February 26, 2014, 02:20:56 am »
I own errors in that file ;)  and will have a look at getting it updated.  For now, if you search for 'debconf-utils' and replace it with 'debconf-i18n' you should have success.

J.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #2 on: February 26, 2014, 05:25:28 am »
I've done a fresh 1004 install and ran the Diskless_CreateTBZ.sh and ran into the same problem you described.  I made a small change to Diskless_CreateTBZ and have submitted it to svn and requested a new package be created.  This should happen in the next day or two, assuming no other issues arise. 

Thanks for letting us know and let me know how things go.

J.

garagevibes

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #3 on: February 26, 2014, 02:32:33 pm »
Thanks for looking in to this phenigma,

I did manually change the script to debconf-i18n but I then got an error similar that said something like Linux-headers-generic was missing so I then gave up on my attempt at script tweaking :)
 
Last night I attempted 1204 again with the 24 Feb snap hoping the firewall bug was resolved, I had no issues with the install this time it was really smooth and the Nvidia graphic driver installed just fine this time but I still have an issue with being able to see videos of any kind and the internal network doesn't seem to work at all no devices get ip addresses and no devices get PnP detected on the network either, I just recently saw in another post that you discovered another network bug though so ill wait for either of these 2 new snaps 1004 or 1204 im sure ill get one working fine soon ha.

Thanks again for your help, let me know if you need any info from my system.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #4 on: February 26, 2014, 04:56:51 pm »
Hi,  The debconf-utils package should have been available.  The patch I put in should deal with what I believe is a bad sources.list file.

The Feb 24 snapshot has a serious network setup bug that is preventing all internal network functionality.  This should be fixed in the next snapshot (crosses fingers).

J.

garagevibes

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #5 on: February 27, 2014, 12:06:39 am »
Hi,

Sorry I was a bit inpatient and reinstalled 1004 and got your changes from the trac page and ran this instead, it seems your changes have worked great with the last issue but now unfortunately although a lot further along I get another error:

Code: [Select]
Setting up discover-data (2.2009.12.19) ...
Setting up libdiscover2 (2.1.2-3) ...

Setting up discover (2.1.2-3) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Wed Feb 26 21:39:51 GMT 2014 - Prep for MCE device installation
Wed Feb 26 21:39:51 GMT 2014 - Installing  for device 28
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Wed Feb 26 21:39:52 GMT 2014 - Package  installed ok!
Wed Feb 26 21:39:52 GMT 2014 - Installing pluto-orbiter for device 62
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package pluto-orbiter
Wed Feb 26 21:39:52 GMT 2014 - #### Package pluto-orbiter failed (/tmp/Diskless_CreateTBZ.umCv85O4E) - We wait 10sec and try again - to stop retrying press Ctrl-C. 
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package pluto-orbiter
Wed Feb 26 21:40:02 GMT 2014 - #### Package pluto-orbiter failed (/tmp/Diskless_CreateTBZ.umCv85O4E) - We wait 10sec and try again - to stop retrying press Ctrl-C. 
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package pluto-orbiter
Wed Feb 26 21:40:13 GMT 2014 - #### Package pluto-orbiter failed (/tmp/Diskless_CreateTBZ.umCv85O4E) - We wait 10sec and try again - to stop retrying press Ctrl-C. 
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package pluto-orbiter
Wed Feb 26 21:40:23 GMT 2014 - #### Package pluto-orbiter failed (/tmp/Diskless_CreateTBZ.umCv85O4E) - We wait 10sec and try again - to stop retrying press Ctrl-C. 
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package pluto-orbiter
Wed Feb 26 21:40:33 GMT 2014 - #### Package pluto-orbiter failed (/tmp/Diskless_CreateTBZ.umCv85O4E) - We wait 10sec and try again - to stop retrying press Ctrl-C.

I looked at /usr/pluto/deb-cache and pluto-orbiter is there so I'm confused any other ideas?

Many thanks again for your help.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #6 on: February 27, 2014, 04:50:10 am »
Can you please pastebin the entire log.  This all works here so I need to see the whole process.

J.

garagevibes

  • Regular Poster
  • **
  • Posts: 22
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #7 on: February 27, 2014, 08:01:31 am »
Hi,

Thats strange then, maybe I'm doing something silly then, i competed the whole dvd install then there were a lot of updates available this could be mistake :) so I apt-get update and apt-get upgrade then i used wget to pull the updated Diskless_CreateTBZ.sh file you changed, I then moved this over the top of the old one and chmod 755 the file and ran.

The log is attached hope this is of help let me know if you need anything else

Many thanks again

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: Issues running Diskless_CreateTBZ.sh on 1004
« Reply #8 on: February 27, 2014, 11:21:23 pm »
Hi, it's my bad.  I had erroneously commented a couple of lines.  The patch is in svn and you can grab it there now.  Sorry about that.  :(

J.